USB file transfer connection not working with computer: USB choices greyed out

Hello, I know this topic has been discussed before, but I’ve tried everything I have seen suggested.

I can’t link my FP3 to the computer (Windows 10) via USB. The USB options on the phone are greyed out. The cable will charge. I want to transfer photos as my phone is full.

pls note the following

  1. the cable is a data cable and it used to work. I bought a new data cable which doesn’t work either. I have tried both cables with 2 computers at home. I tried it in a telephone shop today using their data cable and computer and that’s the same problem.
  2. every time I do this I switch on and off and restart computer and try again
  3. I have cleaned the port on the phone, there was nothing in there.
  4. I upgraded my phone to Android 13 (hate it!) just in case, but still no joy.
  5. I do not have multiple users on my phone. I do have an SD card if that makes a difference (though it was in, last time I transferred)
  6. I enabled developer tools as some posters suggested, enabled USB debugging, but USB choices and USB tethering still greyed out.

I’m convinced the issue is phone not computer or cable, so what can I do? Does anyone have any other ideas please?

I wrote to Fairphone several days ago, but no response yet. Thanking you in advance

Have you tried using adb (the Android debug bridge) after enbling USB debugging and see if that works? adb push will transfer files from your computer to your device and adb pull will transfer files in the other direction.

That shouldn’t really matter for using USB debugging. You can trigger a connection from your Computer. Just install adb on your computer, connect the device with USB debugging enabled, and enter adb devices in a terminal. If the device is recognized you should:
a) see the phone listed in the terminal
b) be prompted by your phone whether you want to allow the connection with a popup

If you can’t even get USB debugging working (on multiple computers) that way and do not see the device being recognized at all, there’s the possibility that your USB C port has an issue and swapping out the port for a new one might help.

You could also try booting your phone in fastboot mode and listing connected devices on your computer using fastboot devices. If that doesn’t work and you’ve checked that all drivers are installed and up-to-date in your PC I’d say you should consider a hardware issue.

Otherwise: What do you See when executing the abovementioned commands?

Hi Chris, no, not tried the adb- will check it out now- thanks!

No it’s not listing my device. This website suggest I download a USB driver for my phone

What did the commands display when you executed them? You have installed adb and fastboot on your computer (at some point) before trying to execute the command, right?

With regards to the USB driver, maybe try following the ‘Prerequisites’ section of the following instruction site:

What does the device manager show when you open it? Is there any device that could be your Fairphone listed at all?

Also if the automatic driver installation doesn’t work try manually installing the USB driver listed in the first step of the ‘Process’ section.

Disclaimer: I mostly work with Linux, so I may be a little rusty with regards to windows specific stuff.

In your phone? Is it configured as internal or external memory?

1 Like

I can’t remember. I do recall when I installed it originally one way was an issue so I reinstalled it differently

Hello, apologies for late response. The first suggestion didn’t work on my computer and I didn’t have the second computer available to test it there, so I decided to wait until I was back home with my other computer.

However, in the meantime, just yesterday the cable connection worked. I’d really only plugged into charge and the computer popped up a message about my USB debugging- then I saw that the FP3 was visible and it was possible to move some photos over. So I managed to free up 10% of phone memory that way.

Then I unplugged it to use the phone. And now when I plug in, it’s reverted back to charging only.

Ive restarted phone, restarted computer, tried another cable, another port**, no joy. It might just suddenly start to work again maybe tomorrow, maybe next month, maybe in 2024. And that’s what is baffling. I’ll maybe try the other computer this evening now too

**I’ve tried wiggling the connections too! thanks

If its that unreliable I’d personally advise you to try and swap out the usb-c connector module. After all only certain pins are needed for charging, whereas data transfer requires the full set of pins. A defect of specific (maybe a loose soldered connection somewhere) could easily interfere with your phone’s ability to establish a data connection.

Maybe there’s a Fairphone Angel in your area that coult test it with a different USB module for you? That’d save you the trouble of getting one if the fault is somewhere else.

1 Like

There is a difference in cables, 2 and 4 threaded.
2 threaded is only for charging.
4 threaded is for charging and data.
So make sure you have a 4 threaded cable.

And very important
After you have connected with a cable your phone with a computer you have to swipe down on your phone and tap on the message with charging. In the options that pop up you have to select data transfer.


Thanks, yes I’m coming to the conclusion it’s the connector too. And tbh it’s never been reliable but because there were so many other troubleshooting routes out there, I felt the need to try all them first!
and then of course, when it does work, I forget about till next time

Both cables I bought for this purpose were definitely sold as data, and they have worked before, on and off, and one suddenly worked yesterday. I know the message of which you speak but I don’t get it when the phone isn’t connecting. I can also access it via settings, but the options are greyed out

If you don’t get it when connecting then either the cable is faulty or the bottom module (perhaps some dirt in it). And it’s alwalys good to try another usb port on the computer if you have one.

1 Like

Hi all- thanks for advice, I have an update. I ruled out the cable (I own many), the USB ports on computer (tried several computers) and the bottom module (I replaced it- turns out there was nothing wrong with the original). I updated the OS. Used developer mode etc etc

Yet still the file transfer only worked occasionally… but often enough for me to finally move all my photos off it.

Then last week my storage SD card corrupted. Prior to this the camera app was playing up- sometimes not taking photos, sometimes omitting sound on videos, I had previously thought maybe due to full storage, but I’d emptied the phone since… And now the card was the issue

I removed the card and transferred files via a card reader.

The card is no longer on the phone. All photos go to internal memory, but my camera app no longer shows photos taken- it suggests I use google. The video also no longer records sound.

But … the upshot is the USB file transfer now works all the time in any port and with any of my cables.

Now I just have a camera and card to fix! Also I see someone above did query the SD card.

1 Like

I think it might have been the SD card. See update! thanks!

1 Like

I did not expect, that the electronics of the FP3 reacts that fragile, if a SD card is defective.