USB-Ethernet Adapter

I tried to use my USB-C to RJ45 ethernet adapter on my FP4. The status bar icon blink s shortly and then disappears and the network connection is not working. Is this working for someone?
My FP4 is running the latest FPOS A12.

1 Like

Did you check in general for other topics and maybe you could follow-up in one that fits your use case?

As far as I saw it: The posts I found were all about tethering and using the FP4 as LAN access point.
I just would like to use the network via USBC-ETH device instead of wifi or mobile network while I am at home.

1 Like

Ok so I guess that this topic would fit, however does not give any useful information reg. which adapter was used…

Ok I tried the following adapters with the same result:

  • HP RTL8153-3 based USB-C
  • Dell D95GG USB-C
  • Dell FH76N (?) USB-A with OTG Adapter to USB-C

All 3 work fine with my old LG V30 on PE+ (A11). On the FP4 the LEDs for link and bandwidth work, they register with my DHCP shortly but then do not answer ping requests in the network. That behavior seems to correspond to the eth status bar blinking appearing shortly and the vanishing again.

Hi there,
I also tried to connect with our LAN via adapter from Ugreen which works on other smartphones but not on my new Fairphone 4. Does anyone have ideas how to get it working? That would be great!

1 Like

I’ve just tried it with i-tec C31METALGLAN. I also had the cable connection statusbar icon for a short while, then it disappeared. Then I pulled the top drawer and tapped the Internet quick settings tile. Once I’ve done that, the connection appeared again and got stable. On the other hand, I’ve lost wifi, but that’s probably a different problem.

Generally, Usb-c adapters using chipset Realtek 8153 are tested and work with FP4. Contrary, the newer 2.5 Gbps Realtek 8156 is not supported. It doesn’t matter who is the manufacturer of the adapter, only the chipset matters. However, sometimes it is pretty difficult to figure out what chipset is used. Connecting to a Linux PC and running lshw -C network should tell you.


Thanks, I found out, that it works for me with my Realtek 8153 adapter only if I switch off Netguard. According to the developer ethernet should be handled like wifi, but obviously there is a diference.


I bought the tp-link UE300C. It has the chipset RTL8153. But I didn’t manage to get it to work. I am running Lineage OS (currently Android 13) on my Fairphone 4. Do you have any idea what I can try to get it to work?


For me only Plug and Pray helped :wink:

But seriously: The driver for the interface should be available through the kernel and there is not much you can actually do about it. Except for using a different kernel or ask the kernel developer to include the driver for ethernet, i.e. RTL8153 devices

For me a LAN Adapter from belkin model F2CU040 works!! :slight_smile:

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.