USB C audio adapter LineageOS 20

With LineageOS 20 (20-20230615-NIGHTLY-FP4) audio via USB C does not work any longer. I stopped working a while ago with one of the udpates, but I don’t remember when exactly.

I tried the official USB-C-audio-adapter sold by Fairphone and others as well - none works. I also tried different headsets and headphones without any success.

The only thing what happens is a notification about charging the external device, but nothing else.

Did anyone else experience this so far?

No, works fine here.

Same LineageOS build? Then I might give it a try with a factory reset.

I have the newest version: 20-20230625-NIGHTLY-FP4

That version is not offered in the updater.

Using ADB to manually trigger the update as described in Update LineageOS on FP4 | LineageOS Wiki is also is not possible any longer, since connecting the FP4 via USB to the PC just shows a blue “wave” animation on the screen moving from top to bottom and that’s it. No device connection at all, only charging and there is also no notification at all that the device is even connected via USB.

Strange - USB-OTG with a USB stick works fine. So USB seems to work somewhat, but not completely.


Even a factory reset and reinstalling everything from scratch did also not work - USB still only works for OTG and charging and nothing else. No notification to select the mode, no USB debugging, no USB connection in fastboot mode, nothing :frowning: And of course USB C audio also does not work.