English

Upgrading LOS for microG to 15.1 (feedback/issues)

Oops! You’re right, there’s something wrong. I’ll fix it, :+1:

Edit: done.

I had this problem, but seems to be solved by wiping the cache partition (only) in TWRP.

Seems wiping cache /dalvik solved the issue. :+1:

I must come back on my words. After wiping the cache, the battery life was excellent for one day. But today about half (!) of the battery usage is ‘Mobile network standby’. The only real difference between yesterday and today is that yesterday my phone was in an area with excellent mobile reception. And today in an area with very bad reception.
Therefore it looks like 15.1 when it experiences bad reception it uses lots of power to compensate.

Have you tried disabling automatic network selection?
If your provider offers a good network coverage in your country, you will barely need to change network if you don’t travel abroad.
I often disable automatic network selection when I am in areas close to a border, otherwise my phone switches network and it could get expensive!

2 Likes

I finally upgraded today from official Lineage OS 14.1 + my microG installer to Lineage OS for microG 14.1*, and then from that to Lineage OS for microG 15.1. All seems to work well for now (pretty well, in fact!).

Edit: cool easter egg!


(some background)

*= I tried this multiple times in my FP2 in the past and yesterday too. It worked on other devices, including a pair of FP2. But mine, for some reason, didn’t. I blamed my own tinkering testing my microG/UnifiedNlp Installer, but it finally worked today. Magic, :man_shrugging:. I hace a theory, so if someone faces this problem, just ping me by PM.

1 Like

Occasionally I get Google playservices are outdated notifications. Apps threatened me they won’t work without… But they do.
Anyone knows whatsup with this?

I get that all the time, e.g. in the Discord App. Luckily I don’t need that often. And I think I could just use the website.

When I searched for this notification I read somewhere that microG need to up some version number to counter this notification, but this needs to be considered carefully because it could break stuff.
Can’t find the source at the moment though.

1 Like

Yeah, I get those sometimes too, for example on the babyfoon and hmm that’s about it I guess. The notifications in apps are annoying, but the notifications about it from Google Maps or whatever you can actually block. Or get rid of it and use OsmAnd.

@AnotherElk Source for that is somewhere on the microG Github issues tracker

You can just use Discord app in web browser it is nothing more than a wrapper around web browser anyway (probably Electron). Maybe it works with PWA?

microG is a reverse engineering project of the closed Gobble Mobile Services, as you know. Whenever an original part of them changes, things need to be reversed again. It’s a race between the cat and the dog.

In this case, Gobble phased out the Cloud Messaging Service (the API and infrastructure that powers push notifications) in favor of Firebase Cloud Messaging. Reversing and testing this new API takes time, and just changing the version number to avoid these messages could case more harm than good, said @larma.

Source: https://github.com/microg/android_packages_apps_GmsCore/pull/553

2 Likes

On that note … if anyone wants to try Discord in the browser …

1 Like

Well so far fromme the microg forge has worked pretty well. Appart from twitter crashing while opening, and not being able to choose weather provider in the clock widget everything is ok. The twitter thing came from older versions.

But im impressed by the battery performance. Never been better before.

2 Likes

network standby is going through the roof… wiping cache /dalvik didn’t work this time. Bad signal means battery drain, I think :thinking:

I have the same problem now!
Made some research on the Internet and it looks like it doesn’t affect only Fairphone. Someone on a forum says that Google messed up:

There is no fix because this is not a rom issue or device issue. Its a google mess up when they built 8.0/8.1 and word is it wont be fixed till later this year. Not all devices are effected but most are. I had to go back to 14.1 because the drain was massive. Cell standby was at 68% on 15.1 but is 1% on 14.1

I have read a workaround that suggests to set preferred network in “Phone information” (dial *#*#4636#*#* / Phone information / set preferred network). Some people set it on “LTE only”, others on “LTE/WCDMA”).
Any thoughts on that?

2 Likes

I won’t recommend doing it unless you’re sure your area has LTE available anytime. As I rarely use mobile data and anyway my city is all covered up in LTE, I’ll try it.

Edit: making calls didn’t work with “LTE only” selected in my area. Might not be your case, though.

The drop in battery life was obvious to me. I bought recently a new battery and was having an outstanding battery life in 14.1. In 15.1, it foresees only 13 hours with 88%. And I barely used it today…

1 Like

There are some providers who provide very good LTE but their 3G connectivity is sub-licensed or otherwise terrible. In The Netherlands these are Tele 2 and T-Mobile. I don’t have either, but if I had one of these I’d try it out.

EDIT: Furthermore you might wanna set it to GSM only if you have terrible LTE reception. I’m not sure about this but I get around -95 DB on LTE only and around -65 DB on GSM only. If you want to call via LTE, your provider needs to support VoLTE. You can see if you support that in the very same menu as where you set it. BTW, use the dialer, not the contact list (bottom right on contact list).

I updated to the 27/08/2018 OTA from TWRP. Installing through the Updater didn’t work, as expected.

The 27/08 OTA can be re-installed from the Updater and it doesn’t bring an error now, which means next OTA will be installable through the Updater.

2 Likes

I just installed LOS for microG 15.1 from scratch via TWRP by following the instructions from LOS and the microG specific part. Went pretty smooth. Only problem I got so far is concerned with the Signal messenger. I downloaded it as apk from their website, but the dialog “Verify your number” chrashed when I hit register with my phone number. Any hints want might be wrong? I already checked the permission in privacy guard and allowed all requests from Signal.

Most probably it is detecting microG Services Core and trying to register on Gobble Cloud Messaging for push notifications. Enable them on microG and try again.

Did anyone else ever try casting their screen - either Netflix or local content playing in VLC - to a Chromecast device using LOS 15.1 for microG, without GApps? (I did, yesterday, and it didn’t work out.)

I admit it’s somewhat far-fetched to expect a Google device to join forces with a Google-free OS, but still, I’m curious.