Upgrading from *official* 14.1 to 15.1 (feedback/issues)

Thanks to all who contributed to getting 15.1 to the FP2!!

The upgrade worked fine for me (on my second attempt; as I first did not wipe /system).
Hopefully exchange will be available soon, as I unfortunately need it for work.

Either way. Thanks to all for your great contributions to make LOS 15.1 work on FP2!


Thanks for the answer.
Two additional questions. Is there a possibility to deactivate the incognito mode of the keyboard?
And second: Do you have an explication for the fact that the incognito mode doesnt get enabled in my Signal app?

Oh, yeah. From Nougat onwards, in app’s settings you get an option to disable mobile data or WiFi per-app, so it doesn’t connect at all. Quite useful for privacy/untrust reasons. Before Nougat I used NetGuard (same author than Xprivacy), but I have a real VPN now that conflicts with the local VPN NetGuard’s create (VPN connections cannot be chained, unfortunately).

Look in each app settings. Beware that your keyboard will log whatever you type meant to be confidential and probably send it to thousand third-party bussinesses and goverment agencies, depending on their privacy policy and applicable law.

1 Like

Thanks a lot everyone that helps on Oreo, great job :smiley:

I did a factory reset, upgrade Twrp, then use it to instal Lineage, Gapps pico and Su. Everything works well!

The only two problems I have are known bugs: Exchange that is missing, and the camera (Open Camera for me) that cannot record video. Appart from this, it is perfect :slight_smile:

Than again :slight_smile:

1 Like

A post was merged into an existing topic: Easy info about LineageOS 14.1 features not working in 15.1 (e.g. Exchange)?

I upgraded tonight, it seems to work properly. I flashed su-addon and F-Droid privileged extension (was that necessary after wiping system partition?) right after the Oreo image.

Boot time has improved a lot.

Yes, naturally, they live in system.


I successfully upgraded my encrypted phone without GApps and have not lost any data :slight_smile:.
However, two of my most frequently used apps crash frequently :confused:, namely, K9-Mail and OSMAnd (installed via F-Droid). I already reinstalled K9-Mail but now I am not even able to launch it at all – before, it crashed whenever I opened an email, so I was at least able to access my inbox.
Does anyone have a suggestion what to do? Do you know whether it is Lineage or App related?

1 Like

10 posts were split to a new topic: LineageOS for microG vs. LineageOS + UnifiedNlp without microG

My K9-Mail works as before… I use LOS+microg but that should not Change anything, i guess.

Since upgrading to 15.1, I notice that my K-9 Mail sometimes has the status “synchronization disabled”. I haven’t had that at 14.1 yet. Has anyone had a similar experience?
Workaround: Disable- and Enable mobile data.

I also observed this with 14.1, since adding K9 as an exception in battery saving optimisation it never happened again.


I can make photo’s, but can’t record video’s, “could not start media recorder can’t start video recording” is the error. Anyone facing the same issues?


Thank you very much for the info!! Will wait fort an update then

K-9 development is rather stalled.

p≡p is a K-9 fork with material design and opportunistic GPG. Works fine for me on Oreo thus far.

EDIT: It is free on F-Droid, btw.

1 Like

This doesn’t look stalled IMHO: https://github.com/k9mail/k-9/commits/master


Hi. I tried to update Official LineageOS 14.1 to 15.1 via TWRP following instructions founded
First time I wiped system and cache before flashing, but I got endless loop on system reboot.
Second time I wipe data too, but still got endless loop on system reboot.
I tried to restore the backup I had done previously, but I got un error.
Tried again after a fresh dowload and SHA256 verification, but still endless loop until battery go down…
May someone help me please?

Great job done, thanks to all, especially @chrmhoffmann !

My upgrade didn’t run so smoothly yet:

  1. installed twrp-3.2.3-0-FP2.img
    Then in TWRP:
  2. wiped system, cache, dalvik
  3. installed lineage-15.1-20180813-nightly-FP2-signed.zip and open_gapps-arm-8.1-nano-20180815.zip
  4. Reboot to system,
  5. My FP2 is encrypted, so after a short time I entered the decryption PIN
  6. Reboot continued, but didn’t end
    After > 60 minutes I rebooted again into recovery.
    This time I swiped almost all (system, cache, dalvik, and also data), and again did the installation of LOS and GAPPS.
    Now the reboot finished after around 4-5 minutes, with a fresh LOS 15.1, without any apps installed.
    As I my FP is also my business phone I need again today, I restored yesterday back to LOS14.1.

I’ve read that @lklaus faced something similar, and continued later with wiped data partition.
Has anyone had the same experience, and might give some advice?

Later this afternoon I’ll try again to run the upgrade.