English

Upgraded to Android 7.1.2, dual SIM broken

Did the Nougat update. With both SIMs in, it reports that I have no SIMs. If I take out the 2nd SIM, it is fine with the first one.

Edit: swapping the SIMs round fixed it!

Edit 2: That fix only lasts a few hours!

Back to square one. Can anyone tell me how to fix this or revert to previous Android version?

Did you upgrade the system while having both SIMs in and both activated?

1 Like

Revert option - Manual install of 18.04 (if you’re on FP open, different images are needed, but as you don’t mention that you are, I’m assuming you’re not):

Fix option - Not sure what happened, but related to that I’m also interested in the answer to the question @Amber just asked.

1 Like

Yes, the phone had the 2 SIMs in (activated) when I upgraded via the app - I have been using it dual SIM for the last few years.

Is it a requirement to take out one of the two SIMs before upgrading? If yes then FP need to put that on the main instruction page asap

I will wait for a few days (using just one SIM, which is working fine) to see if a fix is found, but thanks for the downgrade link.

No, in contrary: It seems best choice to have both SIM cards inside and especially requires both activated. So you did everything correctly.

1 Like

Ok good.

Strangest thing is that swapping the SIMs round gets them working, but it doesn’t last. Wonder if anyone else is seeing this.

2 Likes

I tried again with both SIMs and this time it’s been fine, quite a few days without any problems.

I’ve been having the same issue since the update. With two SIMs, neither of the two gets recognised. By swapping them before booting, I can sometimes get both to work simultaneously, but as soon as I reboot, I lose them again. If I take out my second SIM, it recognises the first SIM every time. For now, that seems to be the only stable way to use my phone, but it’s of course not really a satisfying solution.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.