Upgrade to 1.6.2 - error on restart

After downloading 1.6.2 via Updater, get to restart request. Phone powers off, then fairphone symbol, then Android ‘robot’ symbol, then error message. At the foot of the screen the two error messages are
footer is wrong
signature verification failed

At the top of the screen are two lines (these may not be totally accurate, the type is tiny)
Android system recovery <3e>

I then take the reboot option offered and phone works, albeit still on version 1.5

I have one SIM card and an SD card installed

did you make a systembackup ?
otherwise, did u try removing the battery for at least 30 seconds ? before tryin to reboot ?

Signature verification failed generally means that the download is corrupt. Please try downloading the update again.

1 Like

also id suggest getting the small programm called “adb”, theres also a version adb and fastboot out there, which i recommend.
with this you should be able to set the phone into recovery mode if the hardware startup fails (i think it was power + vol down)

@AlbertJP is right, this problem has occured and been solved the way he suggests several times before. I for my part would always prefer to manually install updates to reduce the risk of corrupt wireless downloads.

I have a working Fairphone, so see no need for trying these ideas, thank you

My report above is after my third attempt to download and install. How long do I need to keep trying?

As I have a working phone (though on version 1.5) I see no need to get so involved. I am not a technician and have little knowl;edge of Android - I just need a working fairphone that I can keep up to date for security reasons.

I have downloaded 3 times. At 600 Mb a go this will affect my download budget if I just keep doing it. I want a system where downloading via Updater just works.
Do you mean by manually installing, that I download to my PC then install? same download budget, bit technical for me. never had this problem with updates via wireless/updater before. What is happening this time to make it so difficult and complex?

I am sorry to hear that you don’t succeed in updating your FP OS. Your OS is a changing system (with every update/new app etc. you are changing it), it is not static. That’s why problems may occur. You could try wiping cache and data of the Updater app (to do so, go to Settings > Apps > All Apps > Updater, wipe cache and data) and try to download the update again. Please also have a look into this useful wiki for troubleshooting.

Thanks for this. I am reassured via the wiki, that this has happened to others. Following your lead I have cleared download data, stopped Updater (which continues to run after the error reboot process), cleared its cache and data and then retried - same error message. Then cleared cache etc as before, and demounted SD card. The green robot (who chose that colour?) is now chewing its way through the update. Can’t prove it, but looks like having apps on your sd card upsets something.
My thanks again.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.