English

Updating TWRP wipes data - why?

Hi,
I’m on an old Lineage OS version and recently tried to update to a newer version, but failed with a mysterious behaviour during the TWRP update before the actual Lineage OS update.

My setup is the following:

  • My Lineage OS version is nightly 2018-01-09 (so quite old).
  • My data partition is encrypted.
  • My current TWRP version is 3.0.3-1 from this forum post of @z3ntu, which was actually the first TWRP version supporting decryption of the data partition.

Now I found this post stating that for updating Lineage with encryption on Android 7.1, a TWRP version >= 3.1.0-0 is necessary, since partitions have changed somehow. So I updated TWRP to version 3.2.1-0 via fastboot flash recovery and the result was that right after the flashing the phone booted into the new TWRP recovery and automatically wiped my data! It then booted into the system which was a naked Lineage OS…

Fortunately, I had performed a TWRP backup before. Hence, I could just downgrade to the old TWRP 3.0.3-1 and restore my backup. And I cancelled my attempt to update.

However, I clearly want to update my OS in the near future.

So, has anyone (an) answer(s) to (one of) the following questions:

  1. Did someone else experience the same weird behaviour while updating?
  2. Why the hell is TWRP wiping my data after it has been updated? That’s unexpected behaviour and I was really lucky to have a backup (I thought about whether to backup before the TWRP update or not).
  3. What exactly changed with the partition scheme? Is this an Android change or a TWRP change? Does someone by chance have a link to a resource where this is explained in more detail?
  4. Is it possible to update Lineage to at least the last 14.1 release (and if necessary TWRP to some higher version before that) without wiping data?
  5. If no, is it possible to perform a TWRP backup on TWRP 3.0.3-1, then update TWRP to 3.2.1-0 and then restore the TWRP backup on the new TWRP version 3.2.1-0?
  6. Is it possible to update Lineage to 15.1 without wiping data? (I guess, the answer here is definitely no, cause it’s a major OS upgrade and actually the most disrupting Android upgrade so far because of the architecture change in Oreo.)

Remark: I don’t really remember whether I tried updating Lineage without updating TWRP, but I think I tried and didn’t work. However, I haven’t tried updating manually from TWRP yet, as far as I remember…

Any help is highly appreciated.

Just a wild guess but why are you using TWRP 3.2.1-0 instead of 3.2.3-0?

1 Like

As far as I remember, there was no TWRP 3.2.3-0 when I tried to update (some while ago). And I don’t remember whether I used 3.2.2-0 or 3.2.1-0, but in the end this should not make much of a difference regarding the problems.

This topic was automatically closed after 183 days. New replies are no longer allowed.