English

Updating LOS for microG from 17.1 to 18.1

I’ve got an FP3 with LOS 17.1 + microG and I’d like to update it to 18.1 + microG. The first install was something of a struggle so I’m hoping for a bit of help. The little documentation I’ve found on is :

Upgrade from LineageOS 15.1 to LineageOS 16.0

To upgrade from LineageOS for microG 15.1 to LineageOS for microG 16.0 it is not necessary to wipe your data, just upgrade your TWRP bootloader and flash manually the latest LineageOS for microG 16.0 zip.

To upgrade from LineageOS 15.1 to LineageOS for microG 16.0, first upgrade your TWRP bootloader, then upgrade to LineageOS 16.0 and finally follow the Migration from LineageOS instructions.

To upgrade from an unofficial LineageOS build to LineageOS for microG 16.0, a factory reset is required, otherwise you can create your own migration zip, and follow the Migration from LineageOS instructions.

The official LOS instruction is a bit different Upgrade LineageOS on FP3 | LineageOS Wiki. Could someone please share a step by step guide how to go about this?

Well, it depends: If you have locked your bootloader after installing LOS 17.1, you will have to unlock it again, which will result in data loss and factory reset.
If your bootloader is still unlocked, it will be quite as simple as in the first paragraph of your quote:

For me, this worked flawlessly.

2 Likes

I remember that when I selected the LineageOS 18.1 update in the Android update checker, it gave me a link with instructions of what I needed to do. I didn’t have to clean flash or anything, it was just putting a zip on my phone and browsing it with LineageOS recovery I believe.

Do you not get some kind of link with instructions when you choose it in the updater?

1 Like

@TheLastProject yes, there is a link to LOS and how to update, but I’m running LOS+microG

@HMZ As I installed 17.1 during the summer I’m guessing that TWRP is the latest (3.5.2 was released in April).

I haven’t locked the bootloader since, I haven’t been using the phone yet but plan to start with 18.1.

So “flash manually the latest LineageOS for microG”, does that mean step 3-5 in Upgrade LineageOS on FP3 | LineageOS Wiki?

Sorry for asking a lot of questions, but I’ve never installed a custom ROM before the 17.1 and don’t really know the lingo around it.

Yup, exactly!

But instead of " Download the LineageOS install package that you’d like to install" in step 1 you should instead download the relevant LineageOS for microG package: https://download.lineage.microg.org/FP3/ (so the most recent lineage-18.1-****-microG-FP3.zip).

Following all the other steps as normal worked fine for me.

2 Likes

Took some time to actually do it, but it worked like a charm. Thanks for the help!

1 Like

Hi! Have you run an update via update - tool since install? My FP refuses to boot android system after updating to version 18.1-20211104.

This is for FP2, but I also had to wipe my phone in order to upgrade from LOS for microG from 17.1 to 18.1 :-/.

I installed 17.1 during the summer and updated to 18.1 two days ago using adb as described above. Didn’t have any problems using that method

OK! So you did not use the internal update manager after initial installation of 18.1?

No, it’s only a 3 days old install and i used the latest so I haven’t yet. I installed lineage-18.1-20211104-microG-FP3.zip so the release in itself should be safe

Yes, thanks! The last update was successful but the latest failed. So i’ll wait for the next one and try again.

Hi jon, could you update your device to the new version published today?

update
I tend to be pretty lazy with updating but I tried it this morning and it worked fine. Not sure if it’s a feature or a bug but when I started the current and previous versions were listed (nov 4 and 17.1), and after updating the current is there (nov 18).

I could fix my problem as well. Thanks