English

Updating LineageOS 14.1 via TWRP + feature test

Short questions only as I never used open_gapps:

  1. Does it take care for updates of downloaded Google-Apps?
  2. Is it necessary to install always latest version of open_gapps or does it update itself?

Thanks!

1 Like

Using LoS 14.1 here on my new (and encrypted) FP2. I tried to install the latest update via the included updater, but that didn’t work. I don’t get a prompt to decrypt and the update doesn’t start. Is there a how to for encrypted phones and could someone point me there?

Edit:
Using TWRP 3.2.2. Where does the updater app store the zip file? I could just install it by myself.

Thanks,
Singu

1 Like

There:
/data/lineageos_updates/

The last version of TWRP broke the auto update.

2 Likes

Thanks, manually installed the update. Were there important fixes in TWRP 3.2.2 or is it “safe” to use TWRP 3.2.1 then?

I would say, no issue to use the previous version until the fix comes.
Enjoy your FP2 with LOS!

1 Like

Thank you :slight_smile:!

(I just edited the topic title to make clear it’s about official LineageOS 14.1 here, while unofficial LineageOS 15.1 is over there.)

1 Like

Digging up something old …

When I went through all the settings in 15.1 I found those here, perhaps they were there in 14.1 already? But doesn’t matter much, there will be a switch to 15.1 somewhen sooner or later …

Settings

  • Google (Services & preferences)
    • [Internal] - Google Play services modules

This seems to have all the info about when each Google Play services module was last updated.
But beware … If they were installed with TWRP while TWRP didn’t have the correct date and time, those modules can end up with a last updated date in January 1970 :slight_smile: .

1 Like

Now that LOS 15.1 has just been released, will LOS 14.1 continue to be updated?
I hope so, I may wait for a few weeks before to do the upgrade.

1 Like

No. Lineage does not allow to have two builds live.

Chris

Think, my above comment was too early.
Cannot reboot recovery. Tried :

  • Restart recovery
  • Pressing volume up and power and
  • ADB reboot recovery

FP2 always reboots and it seems that there is no TWRP!
What can i do? Reinstall TWRP?

It might be tricky time-wise, but i have no problem booting into recovery… Starting a reboot and immediately press and hold volume up, until twrp screen shows, but before the fairphone bootlogo shows

2 Likes

Volume Up while starting or rebooting should work, please try again.

Else there’s still fastboot booting a signed TWRP image …

1 Like

This word “tricky” helped, because it was really necessary to strictly follow your instruction.
It works!! Many thanks.
In 14.1. it was possible to enable in developers options direct reboot to recovery. But this does not work here.

1 Like

You can still enable the same option, but with the new camera modules it currently doesn’t reboot to recovery.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.