English

Update 1.4.2: Can't open /dev... permission denied

Hello and thank you for your fair initiative !

I just ran the update 1.4.2 and at reboot I got the boot menu with, at the screen bottom, the following error message:

[...]
 Verifying update package...
E:footer is wring
E:signature verification failed
Installation aborted.
E:Can't open /dev/block/platform/msm_sdcc.1/by-name/misc
(Permission denied)

Then I selected first reboot option and my phone booted normally. Even though I had to enter my SIM code with very low brightness.

Updater still suggest me to install 1.4.2.

What should I do ?

2 Likes

Hi!
I’m having a similar problem, and I get the same error message whenever I try to do anything in the recovery (power on while holding volume up button).

On update to 1.4.2 my phone is mostly stuck in a bootloop, it’s got to the pin screen a few times but then reboots a few seconds afterwards.

I’ve sent a support request to Fairphone, I’ll update here when I get a reply.

This one usually shows up, and isn’t a problem:

This is the one to watch out for.

It means either something went wrong during the download, or you’re using a custom recovery system such as TWRP (in some cases when you root the phone).
If you’re using TWRP, take a look here.
If you’re not, try again to see if it works this time around. If it doesn’t, you could try installing the update manually.

The guidance that Fairphone support give on bootloops seems to be to do a factory reset (but beware that this will delete all your data). See this support article.
Alternatively, you could try to download the update on your PC, and applying it via an SD card as explained in the manual install instructions. In that case skip the wipe data option first.

I’ve done a factory reset (thankfully I already had everything but a few text messages backed up!), and installed 1.4.2 from the SD card, now just waiting as it reboots… and it’s not worked.

Same problem as before, except this time it booted into the first setup screen (choose your language) before crashing and rebooting again.

I’ve tried to install 1.3.6 from the SD card, but get the same error mym posted earlier:

If you’re getting those errors on just about any file you’re trying, I’d nearly start to suspect something isn’t quite right with the recovery itself. The fourth manual install option (flashing the binary images) is the most thorough reset that I can think of, plus that if you use the 1.3.6 binary image you’re immediately back to 1.3.6. Do you have a chance to try that?

I did not rooted the phone.
Could it be related to the microsd card (128Go) I put in recently?

I just tried again and that time it went fine :slight_smile:
Thank you!

I’m glad mym has had more luck than me!
I’ve reflashed 1.3.6 using fastboot, and it appears to have worked correctly, but it’s still crashing and rebooting.
It will boot all the way to the initial setup screen where it asks you to choose your language, then asks what sim you want to use for data, and crashes. With no sim cards in, it won’t even let you pick a language, the screen is totally unresponsive and I had to take the battery out to reboot and try again.
Thanks for your hepl so far Johannes, any more ideas? Or any information I can get from my phone that would help to diagnose the problem?

Seeing as with that level of a reset software problems are unlikely, it could be a hardware problem that only started to manifest itself after the exertion of installing the update. I’ve read that glitching screens are sometimes solved by removing the screen and putting it back again, making sure that everything is aligned properly. Otherwise, I’d suggest contacting support as they’ll be able to get your phone fixed under warranty: open a ticket (be warned that responses currently take a long time) or call them; details are at the very bottom of the page with the support form.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.