Unwanted notification sounds

Since a few weeks my FP1 has started to send me irregular (but often, every two or three minutes) notifications about an unknown subject. The notification sounds, the screen lights up and then disappears again. When I start the phone (I have to enter my pincode) I find nothing. This is very irritating because I use the phone also as an alarm clock. Therefore I had to set the notifications to none (geen), but now I don’t get the notifications I need for SMS, e-mail or Whatsapps. I spent hours looking for the source of this unwanted notification, but could not find it. I asked my clever (nerd) cousin, he could not find it. Finally I asked a professional technician, even he could not find it. O, and I didn’t install any new apps!
It annoys me tremendously, perhaps someone can help.

There are some apps that will show you your notification history. I don’t know if instantly or you’ll need to let it run for some time for it to log the upcoming notifications. You will probably enable some accessibility setting, too. Anyway, you can later inspect that history and uncover the verbose app, :wink:

There is a settings widget 1x1 with a gear symbol (in German it’s called Einstellungsverknüpfung). Add it to your screen and chose the function “notification protocol” (Benachrichtigungsprotokoll) from the list.

Roboe, I tried to understand your advise but did not succeed. You may have noticed I am not an experienced IT-user. “There are some apps …”. In Google Play I find trillion notification apps, but none seems to tackle my specific problem. Anyway, thanks for trying to help.

s99h, thanks for your reply. But honestly, I don’t understand a word of what you are telling me. I tried to find the widget 1x1 you mentioned, but did not succeed.

Here are some screenshots (unfortunately in German). Possibly, they look a bit different to your phone because I’m running the alpha version of the upcoming Android update.

(Long-press and place it on your home screen)



Actually, @s99h’s approach is cleaner: you don’t need to install any external and potentially unsecure app, as I suggested. I’ll try to rewrite their instructions:

  • Tap and hold an empty space on your home screen. A menu will show in the lower of the screen.
  • Select the center button, Widgets, to add a new widget to the home screen.
  • Flip through the widget list until you find the Settings shortcut widget, with a gear icon, :gear:
  • Tap and hold the icon and place it to an empty space on your home screen.
  • A fullscreen list will appear. Select the Notification log option.

Now you can access the notification history and identify the verbose app by tapping the new icon on your home screen. Then you can uninstall it or mute it unchecking the Show notifications check on their settings (tap any unwanted notification at the Notification log screen to access their settings).

P.S.: Damn @Stefan! You were quicker than me! Hahaha. Thanks for the pics, :wink:
P.S. 2: Also thanks to @s99h because I didn’t know Android has an user-reviewable notification log. I’m disconcerted the option is not found anywhere on the Settings, though, :confused:


Thanks to all of you. I finally found the culprit. It is the SD card that started to go wild. I removed it and the phone is now functioning normal again.

Verstuurd vanaf mijn iPad


Great troubleshooting spirit again! :smiley: And good to hear, @wimkamerman, that you found the cause of your notification mayhem. :slight_smile: