English

Unroot a Fairphone 2 running LOS 16

Tags: #<Tag:0x00007f05de322e00>

Hi all,

My phone has recently been rooted by a Colombian phone shop with magisk and kingo root in order to get around the homologisation issue there. Now some of my banking apps won’t work. If I do a fresh install of TWRP will my FP2 still be rooted?

Cheers!

(p.s. I’m using LineageOS 16)

Remove the magisk installer and reinstall LineageOS 16. Then it should be unrooted. TWRP does not have to be reinstalled.

1 Like

If you or a phone shop feel the need to root again, just install addonsu-16.0-arm-signed.zip from https://download.lineageos.org/extras with TWRP.

To unroot later, just install addonsu-remove-16.0-arm-signed.zip from the same place.

6 Likes

Thanks for the advice

Thanks for the reply. I noticed this today when going through the Lineage installation instructions, this is what I’m going to do before I return to the shop in a week or so. Does that come with SuperUser or something similar? Cheers.

I meant, with the SuperSU app

No, there’s no App.
You install the addonsu ZIP … phone is rooted.
You install the addonsu-remove ZIP … phone is unrooted.

If the phone was rooted via another method, it has to be unrooted according to the other method.

2 Likes

Does this come with a root manager? What is the best way to ensure that there is no funny business going on whilst the phone is rooted? Thanks again!

No, it doesn’t.

You install OS updates, if there are any.
You don’t install Apps which could possibly do funny business.

3 Likes

OK, thanks. I will bear that in mind.

(Expanding @Volker reply.) Before installing a LOS update, get a root file manager and remove all files in /etc/system/addon.d/ except blacklist. If you have F-Droid Privileged Extension or Google Apps (GApps) installed, preserve those files accordingly named too.

The files there dictaminate what system modifications should be preserved between updates (they are called “OTA survival script”). That way nothing you don’t want survives and you have a clean system.

1 Like

On my system (LineageOS based /e/) these could (only) be found under /system/addon.d/:thinking:

EDIT: … /e/ based on LineageOS 16

Thanks for pointing that out. I’m still running 15.1 here.

I just remembered (because I don’t need to use this normally) …
There is a setting in Developer options where, once the phone is rooted, you can set Root access to Disabled/ Apps only/ ADB only/ Apps and ADB.
This gives you a certain level of control, but the Disabled setting might not be enough for every App in question to run, e.g. some banking Apps might still complain depending on how strict or deep their checks of the system are.

Hi,

Thank you, I saw that yes. In the end I followed Volkers advice to get my apps working again and then rooted the phone with addonsu-16.0-arm-signed.zip to complete the homologation (we don’t have a word for this) when I returned to the shop. It worked a treat, as did the addonsu-remove-16.0-arm-signed.zip so thanks for tip.

Three more days until I find out whether the process actually worked and I can continue to use my FP2 here!

Thanks all.