[UNOFFICIAL] Stock ROM Android 4.4.2/4.4.4 Kitkat for FP1 & FP1U

I flashed fp1-kk444-CH-0.9.6 and the last open GApps mini package (instead of the nano package). It works well and now I have both “Corporate” (with the stock email app icon) and “Exchange” (with the Gmail icon) entries in “Add an account”!

I succeeded to get my Office365 emails inside Gmail (big relief!). The trick is to put “outlook.office365.com” as server instead of “mycompany.xx” which appears by default. I found the trick in a Nexus help forum.

One funny thing: the Office365 server sent a kind of alert to Gmail asking for security rights and I had to allow them before being able to see my emails. I never saw this kind of “back-challenge” behaviour before,


And the dialer app looks … new. Is it from KitKat?

I installed the Mod from chris hoffmann and it works great. Version 0.96 ist published and everything works fine. Internet,Bluetooth( In Ears, Car Radio,etc). I recommend to install the software. Yesterday i tried to pair with a Moto 360 2 Smartwach and Huawei Watch and it works. (The Smwartwatches need 4.3, so with 4.2.2 you cant use a Smartwatch.). Without a Mod i would be really disappointed from Fairphone…
I dont understand that chris hoffmann can port KitKat and Fairphone is not able to do.
Chris is publishing every month a new version with new cernel improvments and security updates vom Google, i think thats a support i prefer…

i dont know why, but it works not with this command:

adb push cwm-fp1-kk.0.1.img /storage/sdcard1
adb shell
dd if=/storage/sdcard1/cwm-fp1-kk.0.1.img of=/dev/recovery

in my case it just works with this command:

adb push cwm-fp1-kk.0.1.img /storage/sdcard1
adb shell
dd if=/storage/sdcard1/cwm-fp1-kk.0.1.img

Not for CyanogenMod he isn’t, though he is for the non-CM version of KitKat (see this topic). His cyanogen port hasn’t been updated since September 2014 as far as I can tell.

By the way:[quote=“jogabonito, post:126, topic:1071”]
dd if=/storage/sdcard1/cwm-fp1-kk.0.1.img

Will just produce output on screen, it won’t write any changes to your system without an output specified.

There’s some discussion/speculation on why Fairphone does not provide CyanogenMod with the FP2 (which is somewhat relevant to FP1 as well) here:

1 Like

I dont kno why but

dd if=/storage/sdcard1/cwm-fp1-kk.0.1.img

works in my case , i tried it several times with dd if=/storage/sdcard1/cwm-fp1-kk.0.1.img of=/dev/recovery but this doesent work.

Chris updated version 0.96 if im correct. What did you mean with Chris did not update his mod since 2014??

Do you mean this http://forum.xda-developers.com/fairphone/orig-development/rom-cyanogenmod-11-4-4-4-kitkat-t2862874??

Sorry, missed that. You’re referring to his (other) KitKat port. Note that it is NOT a CyanogenMod port. You probably meant to post in this topic:

My fault, yes thats the correct topic.

It works still great! Thanks a lot!
I now tried the Nova launcher and it works much faster and smoother as with the original launcher, at least for me.
The problem is that the Nova launcher is not open source and uses internet. I do not like this, so I blocked all Internet for it with xprivacy and it still works :slight_smile:

Just for your information…

1 Like

I have installed Verion 0.96 Yesterday and nearly everything seems to work well! Thank you very much for the good work!!!

The only Problem I have is with pairing Bluetooth LE Devices.
I have a Suuntoo Ambit 3 Peak and a VivoFit2 Device. Both appear as devices under Settings/Bluetooth but the Apps (Movescount from Suunto and Connect from Garmin) are not able to detect ore pair them.

Any Hints - or anything I can do to support you and your work?

I think Fairphone should hire you ti improve their Customer Service! :wink:

Best wishes

1 Like

One issue I have noticed: My battery seems to drain faster than with the stock firmware.
(But this is entirely subjective - I have no measurements to prove this. Or the end of life of my second battery is coming nearer. Or it’s the weather - more sun light -> brighter display.)

Or it’s a calibration issue maybe?

With the original firmware I experienced a slowly declining battery charge stopping at ~ 15 % and staying there for a while before quickly dropping to zero.

With flashing this firmware I tried recalibrating the battery (I used an app called BatteryCalibration to delete battery stats) and this led to a more realistic decline of the charge that android displays. Furthermore I now always charge my phone to 100 % before flashing a new firmware.

1 Like

Hello everybody,

Janxgeist -> I have the same problem you, I have a Suunto Ambit 3 Sport.

Have you got to run your fairphone with movescount?

Thank you and Best regards

Changelog fp1-kk444-CH-0.9.7:


I don’t know either. But I know that the updater script in each of the update packages checks one of these and stops if it is set to something different. If you change it by yourself, you have to change the update script (inside the ZIP file) as well each time you update.

With the 0.9.7 update my Fairphone 1 does not start the OS. It hangs on “Loading…”. When I reinstall 0.9.6 my phone boots without any problem. Anyone with the same problem?

Loading/Rebooting looks ‘normal’ here. I used adb sideload to upgrade from 0.9.6. I do not have GAPPS installed.

  1. The Fairphone branding (blue background & “Loading …”)
  2. The Android Boot screen (black background & “ANDROID”)

Have you ensured that the checksum is correct? Normally I would recommend to try a clean install, but 0.9.6 -> 0.9.7 worked here. Upgrading/reinstalling xposed worked as well.

The upgrade worked for me, too.
One weird thing I’ve encountered: After the upgrade my phone didn’t reboot. Instead it shut down. I had to manually turn it on again.

Thanks for your replies @YtvwlD and @fp1_wo_sw_updates! I did not sideload the zip, I used the CWM bootloader. I will try it again with sideloading, hopefully that helps :slight_smile: I will update you on my progress!

Maybe you can also tell us how the installation looks like.

Normally you should see something like that on your computer:

loading: 'fp1-kk444-CH-0.9.X.zip'
sending: 'fp1-kk444-CH-0.9.X.zip'  100%    

and something like this with the green robot on your cell:

Sideload started ...
Restarding adbd ...
Finding update package ...
Installing update ...

You could also try to clean the phone’s cache from the recovery. It could be that you have some strange app that has dex issues.

And if nothing else works, data as well. But keep in mind that this will remove your data (all settings related to applications).

I use recovery wipe data and wipe cache if a phone “hangs” during a boot. Normally you can see this in the adb logcat message, but just cleaning them is often easier than explaining whole process. I also have lost track how the whole stupid java stuff works anyway.

Hello Oslalo,
actually I got the stock rom 4.4.4 to run on my Fairphone 1 and was able to download and install the Movescount App, but I’m still not able to do the pairing between the Suunto Ambit 3 and the Phone.

Unfortunately something with the BLE drivers seemst to still not work up to 100%