English

[UNOFFICIAL] Stock ROM Android 4.4.2/4.4.4 Kitkat for FP1 & FP1U

You either need to modify the exiting rom or build a new one (Currently not possible, I guess). But the FP1 is ahong phone, so why modify it? Ahong is a Chinese phone company, the FP1 is a slightly modified phone of theirs, but with some fair materials inside and a nice & shiny metal back cover.

Yes. But it’s not jb anymore. :stuck_out_tongue_winking_eye:

And the stock firmware had a better device name.

0.9.6 released.

Download: here

Changelog fp1-kk444-CH-0.9.6 (you might want to check if there are new gapps here as you need to flash them again at same time: http://opengapps.org/):

7 Likes
  • Android upgrading with adb sideload fp1-kk444-CH-0.9.6.zip worked flawlessly on an already 4.4.4’ed phone.

  • Xposed reinstall through the updater application worked also.

Is there a slim chance to somehow add new Bluetooth firmware to the rom? LE works, but very randomly. I looks like some FP1 users are interested stable BT/LE.

Thank you

I need to get a LE BT device sigh :slight_smile:

NO DONATIONS ACCEPTED :slight_smile:

1 Like

BTW: A dirty upgrade from 4.2.2 (Stock Fairphone OS with Storage Upgrade) worked flawlessly for me. (I did have a backup.) All my data is there - eveen though my phone was encrypted. :slight_smile:

Yes, the phone reboots several times in the process (about 5 times), but that’s not a bootloop.

Interesting. Maybe I was to impatient when I switched to chris’ builds but I had to factory reset to get it running. I don’t remember exactly at what point I had decided this was the case :slight_smile:

Edit: And at that time I had blamed the encryption.

1 Like

Me too. I wanted to wipe /data after the second reboot.

I’m glad, I didn’t. :slight_smile:

Here is my “Add an account” dialog in System settings:

Looking for similar screenshots on google, it seems that “Corporate” = “Exchange” in the english version.

1 Like

Thermostats are pretty cheap LE BT devices for testing. But the apps for them are horrible.

I flashed fp1-kk444-CH-0.9.6 and the last open GApps mini package (instead of the nano package). It works well and now I have both “Corporate” (with the stock email app icon) and “Exchange” (with the Gmail icon) entries in “Add an account”!

I succeeded to get my Office365 emails inside Gmail (big relief!). The trick is to put “outlook.office365.com” as server instead of “mycompany.xx” which appears by default. I found the trick in a Nexus help forum.

One funny thing: the Office365 server sent a kind of alert to Gmail asking for security rights and I had to allow them before being able to see my emails. I never saw this kind of “back-challenge” behaviour before,

3 Likes

And the dialer app looks … new. Is it from KitKat?

I installed the Mod from chris hoffmann and it works great. Version 0.96 ist published and everything works fine. Internet,Bluetooth( In Ears, Car Radio,etc). I recommend to install the software. Yesterday i tried to pair with a Moto 360 2 Smartwach and Huawei Watch and it works. (The Smwartwatches need 4.3, so with 4.2.2 you cant use a Smartwatch.). Without a Mod i would be really disappointed from Fairphone…
I dont understand that chris hoffmann can port KitKat and Fairphone is not able to do.
Chris is publishing every month a new version with new cernel improvments and security updates vom Google, i think thats a support i prefer…

i dont know why, but it works not with this command:

adb push cwm-fp1-kk.0.1.img /storage/sdcard1
adb shell
dd if=/storage/sdcard1/cwm-fp1-kk.0.1.img of=/dev/recovery

in my case it just works with this command:

adb push cwm-fp1-kk.0.1.img /storage/sdcard1
adb shell
dd if=/storage/sdcard1/cwm-fp1-kk.0.1.img

Not for CyanogenMod he isn’t, though he is for the non-CM version of KitKat (see this topic). His cyanogen port hasn’t been updated since September 2014 as far as I can tell.

By the way:[quote=“jogabonito, post:126, topic:1071”]
dd if=/storage/sdcard1/cwm-fp1-kk.0.1.img
[/quote]

Will just produce output on screen, it won’t write any changes to your system without an output specified.

There’s some discussion/speculation on why Fairphone does not provide CyanogenMod with the FP2 (which is somewhat relevant to FP1 as well) here:

1 Like

I dont kno why but

dd if=/storage/sdcard1/cwm-fp1-kk.0.1.img

works in my case , i tried it several times with dd if=/storage/sdcard1/cwm-fp1-kk.0.1.img of=/dev/recovery but this doesent work.

Chris updated version 0.96 if im correct. What did you mean with Chris did not update his mod since 2014??

Do you mean this http://forum.xda-developers.com/fairphone/orig-development/rom-cyanogenmod-11-4-4-4-kitkat-t2862874??

Sorry, missed that. You’re referring to his (other) KitKat port. Note that it is NOT a CyanogenMod port. You probably meant to post in this topic:

My fault, yes thats the correct topic.

It works still great! Thanks a lot!
I now tried the Nova launcher and it works much faster and smoother as with the original launcher, at least for me.
The problem is that the Nova launcher is not open source and uses internet. I do not like this, so I blocked all Internet for it with xprivacy and it still works :slight_smile:

Just for your information…

1 Like

I have installed Verion 0.96 Yesterday and nearly everything seems to work well! Thank you very much for the good work!!!

The only Problem I have is with pairing Bluetooth LE Devices.
I have a Suuntoo Ambit 3 Peak and a VivoFit2 Device. Both appear as devices under Settings/Bluetooth but the Apps (Movescount from Suunto and Connect from Garmin) are not able to detect ore pair them.

Any Hints - or anything I can do to support you and your work?

I think Fairphone should hire you ti improve their Customer Service! :wink:

Best wishes
PT

1 Like