[UNOFFICIAL] ✏ HOWTO Testing the latest UNOFFICIAL 4.4.4 ROM and switching back to FP OS again [for Unix & FP1]

Me too never had the problem of multi-dd commands in order to flash the recovery nor the IMEI problem :smile:
Good how-to thank you :smile:

I agree. I also forgot about “adb reboot recovery”, good point! I remember that that works well. Thanks @chrmhoffmann!

@jftr: A lot of good points as well. It’s a wiki now, please feel free to change anything! I don’t like writing a howto for only one or two Debian based unix distributions, that’s why I did not mention any package management systems. But your right with making things easier to understand of course (typography, package names …) All good ideas!

Regarding dd: I thought about getting the checksum from the device directly to compare it. But I never did that. (I only installed the 4.4.4 very briefly).

@DjDas: (dd) Maybe it was a problem with my device? Interesting, thanks for the feedback. I will remove the extra dd’s. A check if the dd was successful by checking the checksum of the device would be much better anyway.

All: It’s a wiki now, please feel free to change everything! But please keep in mind, we cannot cover “how to use unix/cmd” details here, the howto is about changing the OS software on a unix based phone :smile:


It worked for me the first time, too.

1 Like

3 posts were merged into an existing topic: [UNOFFICIAL] Stock ROM Android 4.4.2/4.4.4 Kitkat for FP1 & FP1U

I think you should mention that you have to wipe data when you come from 4.4.2 or older.

It would be good to also explain how to install gapps.

Thanks for this guide BTW!


I added a quick “fix”, please correct me if needed, it’s a wiki! :smile:

BTW: Can you elaborate on the sources/bin blobs you use, or is it better not to ask?

1 Like

Can someone that uses the xposed framwork update the wiki on how to install the xposed framework on 4.4.4? It did not worked well for me the first time, but a howto would be nice so we can extend the wiki on how to install microG as well.

I’ve tried the Xposed Installer (713.3KB) from the following post:


It worked for me and solved the Version 19 issue.

1 Like

Thanks, confusing that there is not official source for v58(?) :frowning: Not really something I would like to add to the Wiki right now. But it’s good to have something that seems to work fast!

If those will work? Are the files the same?

Ehhh can’t find the fp1 launcher download link… can someone help? thanks

It’s linked (to the google playstore) from our forum list of lauchers:

Or are you looking for something different? The F-droid version is disabled. Other than that, the google play store version, the source code, and the disabled status in F-droid can easily be found via most search engines…

1 Like

You can find the launcher in /system/app/ in any of the OTA zip files on https://fairphone.zendesk.com/hc/en-us/articles/202478028-Manually-install-Fairphone-OS-for-the-Fairphone-1.

1 Like

Thanks, I found it on google play…

Will switching back to the FP OS ROM wipe my installed apps and data from the 4.4.4 ROM? I’m assuming I will need to be running the FP OS ROM to upgrade to the forthcoming official 4.4.4 upgrade.
Thanks for any advice

You don’t have to downgrade to Fairphone OS 1.8.7 to install Fairphone OS 2.0 Macadamia (Kitkat 4.4), but it is always adviced to wipe data, cache and dalvik cache before installing a new ROM. Backup your apps with Titanium Backup and you should be good to go.

Thanks very much Stefan

see here: FP1: Macadamia 1.9.9-pre3 Alpha , I’ve tried the no-worry approach, and it worked.

1 Like

As Chris discontinued support for his edition, I’d suggest you close this topic pointing to the upcoming Macadamia edition.

I disagree. As long as there is no official release (it’s a closed alpha), this thread is the only resource for FP1 users to get/talk about 4.4.4 and to get a better recovery. Please keep the discussion here open for a while. I hope not for too long … but as long as there is a 2nd update for first official update maybe :wink: