Unlocking boot loader: adb problem

Hello Forum,

I am new here, hoping that I ll find some help here.

Trying to unlock the bootloader, I am running into a weird problem.

My brandnew FP4 (fully up to date) does not enter fastboot mode.
Not from command line, nor manually (1/ Off, 2/ volume down+power).

For command line, I switched OEM unlocking to on, and USB debugging to on. Command line does recognise FP4:

adb devices
List of devices attached
108d628b device

After adb reboot bootloader, FP4 does as expected say “Device state - locked” (on phone screen).
However, FP4 also looses contact with adb over PC. So, system stalls if commanding:

fastboot flashing unlock
< waiting for any device >

When in bootloader there is no feedback on PC terminal anymore upon any adb commands.

The manual procedure to enter fastboot (1/ Power off, 2/ volume down+power) as recommended in FP4 tutorial does not do the job either. Just some vibrations and nothing else.

Would there be any advice out there?

You cant use ADB when in fastboot.

When the phone is not detected in fastboot, try a different cable.

Does not work on the FP4, please see here

1 Like

Thanks for your suggestions, but … strange, the tutorial (https://support.fairphone.com/hc/en-us/articles/4405858258961) says:

1st step: Put your Fairphone in fastboot mode.
E,g. by " ADB reboot bootloader`". That was successful.
2nd step: Command: “fastboot flashing unlock”. That is NOT successful.

Cable is working correctly, as proved by proper device recognition in ADB. (Brandnew FP cable). However, tested another cable. Same result.

The Cable + Volume Down is given in the same FP tutorial. Result is picture of a nearly full green battery. Thereafter utter silence (blackness).

Other ideas are needed :unamused:

Perhaps, I used the wrong wording to explain my problem. I attach a picture of where I get.

My questions is how I could possibly make the next step to unlock the bootloader. The PC command “fastboot flashing unlock” (as per tutorial) just gives a “waiting” response for ever.

Your phone is in fastboot mode (1st picture above) and not recognized by your PC.

Which operating system is installed on your PC?

Did you also try anothee USB port?

If you have try more cable. Cable working in normal and ADB mode, might still not work with fastboot.

Maybe its a driver problem on the PC, especially when you use Windows (10).


Thanks, Yvmuell,

This is on Win10. Next try will be Linux.

A working adb connection doesn’t indicate anything, fastboot is a different beast and is very picky about the combination of USB-cable / -port sometimes.

1 Like

There were quit a lot of people who were able to use adb on windows 10 but not fastboot. In most of those cases it was a missing driver. The easy solution (that may not always work) often was to have the phone in fastboot mode while connected via USB and then forcing a search for optional windows updates. That way, several people were able to install the missing driver.


Dear Vymuell, Hirnsushi and Ingo,

Thanks a lot for yr suggestions. When I learned of the Win10 issue with fastboot, I decided to take the Linux route. Following the instructions at How to Install iodéOS 3.2 on a Fairphone 4 for Dummies - Brotcast (from AlphaElwedritsch on this Forum?), my FP4 is now “Bien Iodé”.



This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.