"unknown command" issue w/ fastbootd [solved]

Dear all,

I’m confused about a fastbootd issue I encountered when trying to boot into a not-flashed TWRP image: fastbootd claims not to know the “boot” command.

State of the device:
OEM unlocked
boot loader unlocked
rooted with Magisk (booting the patched boot image - not flashing it)
Build number: FP4.FP3V.A.116.20220414
Android 11 (RKQ1.210505.001) ; Security update: April 5, 222

Fastboot client used:
fastboot version 9.0.0_r3
on linux (Gentoo)

As you may know, the root procedure involves using abovementioned “boot” command in fastboot… so it did work before.

Now, however, there’s an entire list of commands the PF4’s fastbootd doesn’t accept anymore:
fastboot flashing unlock: FAILED (remote: Unrecognized command flashing unlock)
fastboot oem device-info: FAILED (remote: Command not supported in default implementation)

fastboot boot twrp-3.6.0_FP4-UNOFFICIAL-20211216.img
Downloading ‘boot.img’
OKAY [ 2.540s]
FAILED (remote: Unrecognized command boot)
Finished. Total time: 2.583s

Something I noted:
When I rooted the phone, “adb reboot bootloader” AFAIR brought me straight to fastboot.
Now I need to navigate through recovery menus to end up in a screen with different appearance, reading “fastbootd”, instead of “fastboot”.

Does anyone have a similar issue or know how to boot into something supporting the boot command, again?
I would like to create an image of my current setup without flashing TWRP.

Thank you!

You are in the wrong fastboot, fastbootd (with the d at the end!) is fastboot in userspace, what you want is the “real” fastboot also called bootloader.

Either select “Reboot to bootloader” in fastbootd or reboot the phone with fastboot reboot bootloader.

I know it’s super confusing :see_no_evil:
Oh and welcome to the community btw :wave:


Thank you! That was quite enlightening. :slight_smile:

I had indeed overread that the bootloader dialog in fact read “FastBoot Mode” as well.

Interesting enough, it fails to register with the fastboot client.
Whenever I issue a fastboot command after loading into the bootloader, I now get “”

As I wrote earlier, fastboot in FastBoot mode worked before - so I’m still puzzled it doesn’t anymore.
At least I’m debugging the right mode, now :stuck_out_tongue:

Does fastboot devices output anything? :thinking:

Did you change the USB-cable and or -port since your last successful fastboot connection?
fastboot is very particular when it comes to accepting USB connections, sometime cables work just fine with adb but can’t be used for fastboot.

Does your phone show up in lsusb while you’re in the bootloader?

1 Like

Good morning!

Crazy enough: I seem to have used a different port - and while it then became visible in fastbootd, it didn’t for fastboot.

Kudos & thanks to hirnsushi!

As documentation for those having the same problem (it seems as if fastbootd took over even low-level USB communication):

Bootloader/Kernel fastboot on the wrong port:

not listed in fastboot devices
not listed in lsusb
dmesg output showing wrong device speed:
[18971.925179] usb 1-1: new full-speed USB device number 109 using xhci_hcd
[18972.075191] usb 1-1: device descriptor read/64, error -71

after switching to Recovery/Fastbootd (side remark: the mentioning of ‘bootloader’ is not helping, here :stuck_out_tongue: ) :

device listed in fastboot
device listed in lsusb as
Bus 001 Device 120: ID 18d1:4ee0 Google Inc. Nexus 4 (bootloader)
[19463.145117] usb 1-1: new high-speed USB device number 119 using xhci_hcd
[19463.327071] usb 1-1: New USB device found, idVendor=18d1, idProduct=d001, bcdDevice= 4.19
[19463.327077] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[19463.327081] usb 1-1: Product: FP4
[19463.327084] usb 1-1: Manufacturer: Fairphone
[19463.327087] usb 1-1: SerialNumber: XXXXXX

Bootloader/Kernel fastboot on the only holy, just and right port:
[19013.535165] usb 1-2: new high-speed USB device number 113 using xhci_hcd
[19013.715752] usb 1-2: New USB device found, idVendor=18d1, idProduct=d00d, bcdDevice= 1.00
[19013.715754] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[19013.715755] usb 1-2: Product: Android
[19013.715756] usb 1-2: Manufacturer: Google
[19013.715757] usb 1-2: SerialNumber: XXXXXX

Matter resolved, TWRP successfully booted via fastboot :slight_smile:

1 Like

I’ve removed your serial number, can’t be too careful these days…

I’m glad you got it working now! :metal:

1 Like

Hello everyone, I hope someone can help me.

I want to unlock the bootloader, but I can’t get along with the instructions.
Of course I’ve done developer mode, OEM unlocking and USB debugging. Fastboot is installed.
I am following this guide: https://support.fairphone.com/hc/en-us/articles/4405858258961

So I enter “ADB reboot bootloader” and the smartphone goes into fastboot mode.
Now I enter “fastboot flashing unlock”, nothing happens on the smartphone, ADB shows me “Waiting for Device”
According to the guide, I should now follow the instructions, but apparently I have to do something else first? The only choices are “Restart bootloader”, “Recovery Mode” or “Power off”…

Can someone tell me what I have to do? Thank you very much!
Many greetings!

Welcome to the forum

Please looks at the following and similar

If you search you will find lots of such requests



Hello Amoun, thank you for your quick reply. I’ve already tried the search function, but without success.
I fail at the simplest hurdle.
When I give the command “fastboot flashing unlock”, adb reports “< waiting for any device>”, and nothing happens on the phone.

I have to assume that I am missing something very simple that is so obvious that it is not explained anywhere because it is clear to everyone?

Feeling a little stupid right now… :wink:

1 Like

Welcome to the forum from me as well :wave:

That issue is most likely caused by your USB-cable / -port, here’s the relevant part:

Disregard that last point if you’re not on Linux.

Edit: Moved it to the wrong topic at first, sorry about that :see_no_evil:


I had excludee the cable because the “adb reboot bootloader” command worked. Will try a different cable, thanks!

Im on Windows 10, not Linux

If i command " adb reboot bootloader", im landing at this screen at the picture, is that right or is there something to do before continue with the guide?

Yes, this is the correct screen. As you write"adb reports “< waiting for any device>”" you’re referring to “the >fastboot< command reports this output”, right (as “fastboot flashing unlock” is NO adb command).
Did you try to start the command as “administrator”?
If I remember right there have been people with a similar problem (adb works, fastboot does not) here on the forum and the solution has been to change the cable, use a newer fastboot version or use a different USB port (don’t remember exactly…).


Else its always worth it to check that the driver are up to date, for this connect the FP to the PC while in fastboot, open Windows updates, manually search for updates, click on additional updates and then driver and check if there is anything fastboot or google related to install…


I will try your ideas tomorow, thanks for the input🙂

1 Like

Ok, and btw: the post that the 3rd cable on the second USB port helped (when adb was working and fastboot wasn’t) can be found here:


Hi Guys.
So I took a newer cable, another USB port, and checked for updates again.
And it worked, thank you very much!

I was damn happy for a moment, but then I wanted to lock the bootloader and I got an error “your device is corupt” or something like that.
Since then, the phone hasn’t come out of the bootloader, even unlocking it doesn’t bring any improvement.

I’ll use the search function to see what I can do. First of all, thank you!


Does unlocking still work? Then you’re happy and we should be able to find a solution.

If not, well, then you should have a look at the topic

Bad news there is: in case “oem unlocking” is disabled (so unlocking is no longer possible) there’s currently no hope for self repair
Good news there is: in all mentioned cases the French repair service could repair the phones for about 30€

1 Like

Thanks for the link Volker, I was looking for something like that.
I’ve solved the problem now, but probably not definitively.

What worked for me was “fastboot flashing unlock”, “fastboot flashing critical unlock”, flashing /e/, “fastboot flashing critical lock”.
The moment I tried to run the last step “fastboot flashing lock”, the error message came up and I was trapped.
Nothing worked - except “fastboot flashing critical unlock”. So I did everything from begin and left out the last point.
It’s probably not that good, but I didn’t feel like doing it all over again…
Now I have /e/, but fastboot is open. Is that very bad?

Yes, that’s more or less described in some of the posts in the topic I’ve mentioned above.
It seems that this may happen if the system you’d installed before (probably FPOS) had a newer security fix level than the system you’d installed afterwards (in your case /e/OS). But still it’s not totally clear (at least to me…).
There’s an according /e/OS bug report here: FP4 Device corrupted and won’t boot in locked mode after /e/OS install (#5107) · Issues · e / Backlog · GitLab

Well, as often: “it depends”… For many people it’s not that bad. Some still regard it as a security problem. And even some apps (like some banking apps) might not work with an unlocked bootloader.

For more information have a look at this topic:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.