Unable to update/install Signal messenger app after upgrade to Android 10

Hi all,

I wanted to update the messenger app “Signal” on my Fairphone 2 (from version 5.32.15) to the latest version (5.39.3) but the installation is failing. I’ve tried different versions and different ways to install the app and also uninstalled the old version - but unfortunately without success. The old version was installed before I upgraded to “Android 10: Fairphone Open 22.02.0-rel.0”. Currently it is even not possible to install the old version (5.32.15) again. Therefore I think that the problem is somehow related to the new Android version. I have just upgraded to “Fairphone Open 22.04.0-rel.1” but the installation of the Signal app is still failing. Some details…

My phone:

  • Fairphone 2
  • OS: Fairphone Open 22.04.0-rel.1; without any Google Mobile Services

What I already tried:

  • installing version 5.39.3 (and all other non-beta version between 5.32.15 and 5.39.3) via Raccoon (https://raccoon.onyxbits.de/, this is how I usually install apps not available via F-Droid store) via default profile → no error messages are shown; result: no app on phone
  • copied APK files of different versions (downloaded via Raccoon) to my phone and installed them → notification bubble “Fehler” (= error) is shown without any further details
  • downloaded official APK from Signal >> Signal Android APK → same result (notification bubble)
  • could not find any related topic here in the Fairphone Community Forum
  • did a really quick web search without any promising hits

I don’t have any problems with other apps I install/update via Raccoon, Signal is the only one.

I don’t know what to do next. Signal is my main messenger app, so It’s quite important for me to get it running again as soon as possible.

Is there someone who has the same setup with Signal working? I appreciate any help, ideas etc.!

Thanks in advance
Oliver

1 Like
To be honest, I am very doubtful this will help, but it won't hurt: After the upgrade, some "Enhanced hardware features" are disabled by default unless you activate them anew. You can find these in Settings > System > Maintenance > Enhanced hardware features. (Click for screenshot)

Again, I doubt these are needed for a messenger, but as I don’t use Signal, I might simply not be aware of any special traits of it.

1 Like

Thank you @urs_lesse. I just tried it out but without any effect unfortunately. Thanks anyway!

2 Likes

Hi all,

a last attempt to maybe get additional replies.

Is anyone out there with a Fairphone 2 + latest Fairphone Open release who can confirm or disprove a problem related to this setup in combination with the messaging app Signal? It would already be really helpful to know whether I’m the only one having that problem or not. (Maybe someone with the mentioned setup could simply try out to install the app and report whether it worked or not.)

Thanks in advance
Oliver

You could try using the Aurora Store and if this neither works you can maybe open a new issue on the bug tracker

2 Likes

Installing Signal via Aurora Store worked! Really great! Thanks a lot, @yvmuell!

However I don’t understand how this way differs from the other ways I have tried before. Are there different, hardware-specific versions of Signal? I though there would be only one universal version for Android 4.4+.

No idea if there is a difference or what it could be…
Just as FYI: it seems there are some FOSS Signal Forks available one is this (never tested it…)

Thank you! Didn’t know there are some FOSS forks available. Would also be an alternative solution, good to know, thanks!