Unable to leave splash screen after "Internal Storage issue"

Hi together,

I had a problem with my internal storage (it no more free space) and then it was impossible for me to start my Fairphone - it always hangs up at the splash screen.

I’ve already asked in the old forum: https://fairphone.zendesk.com/hc/communities/public/questions/200220799-No-more-free-Internal-Storage-FP1-doesn-t-start#answer-200056139

So, Joe answered me that there would come an update to fix the bug this week. Unfortunately, I’m not sure how to install it - because I can’t start my Fairphone and hence the Fairphone Updater, too.

So there are several options.

  1. Do a factory reset in the recovery mode. I’d like to keep my personal data (photos, …) because I didn’t do a backup (I’m so stupid). Are they lost then, too?
  2. Update the phone. I explained why I don’t know how to do this above.
  3. Get my data from my phone and then reset it. Unfortunately, I can’t use adb because USB Debugging isn’t enabled. And as far as I know ADB sideload isn’t capable of transferring files from the phone to the computer.
  4. this is an option you may probably know…?

So, did anyone of you have a similar problem and resolved it someway or knows more about Android or the recovery options than me? I appreciate any solutions and suggestions.

Hi @datokrat,

This sounds like a more technical issue that you should write Fairphone Support directly about at www.fairphone.com/support.

(Sorry that you have to re-write this from the old to the new forum; and now write again to Support! I didn’t understand your question fully the first time.)


Hi @datokrat have you tried wiping the ‘cache partition’?

You do this from the recovery mode but select ‘Wipe Cache Partition’. No personal data is lost, as it is simply a temporary system store.

It might, just might be enough to let you back into your phone and allow you to back things up etc.

Mmh, I already wrote a support request. I thought that a solution might be also interesting for other users. Is there a chance to get an answer to the request until friday?

@Chris_R: Thank you for your suggestion! I already tried that and it didn’t help, unfortunately. I suspect the main cause in overfilling the “internal storage” partition.

1 Like

Hi @datokrat,

You will have to do a hard reset probably (extended answer via your support request).
After updating, look into making a back-up for future reference.



Thank you. I could rescue all my data by using adb sideload to update to FP1.6 Cherry. If someone needs more information, just ask here…


My Fairphone has a similar issue. See also: Battery problems (wrong charging status / battery might be dying) and Battery problems (wrong charging status / battery might be dying)

I can’t reach the ‘hard reset’ screen either and don’t even reach the splash screen, just the blue lights up when i try to start the phone.
I already contacted support last week, but am still awaiting a reply.

Any suggestions how I could fix it?