Unable to install storage upgrader under Kola Nut 1.8.7

I did not find a topic with this (only for koala nut 1.8.5) so I started a new one, is this OK?
here’s my problem:

Help!!! :frowning:

After thinking about it for a long time I decided to solve the insufficient storage thing today, the official instructions for this sounded quite good:

Big problem now: everything was OK up to step 9 / 20:

The update files have been downloaded.Choose RESTART.
The update will be installed and your Fairphone will reboot.

but then the screen just stayed blue something like 15 min. nothing happened. Also nothing happens when I press the power button. Then I removed the battery for a while and tried to reboot again. I had the blue screen for a very long time, and then finally the Fairphone logo, funny cartoons and Fairphone percussion music etc.
Unfortunately still TWO partitions, (and of course all my data is gone, which I back-upped of course) so I would have to start all over again.
Any suggestions what I can do?
I need to use the phone properly tonight.
Please help! :frowning:

Thank you!

Quickest answer: Manually install Kola But 1.8.7 / Storage Upgraded.

Reason: Sometimes the Fairphone Upgraded doesn’t manage to properly restart the phone and start the update process. Installing through Recovery Mode bypasses the Fairphone Updater app.

1 Like

I am trying this - but first big obstacle is that for some reason the phone does not recognize the sd card anymore (where I am supposed to download the zip-file to).

edit. I saved the zip-file to the phone but from there I cannot open it. But ,of course’ when I look for it (step 4) I can see the data on the sd-card.

I have no idea what to do now. :disappointed:

I guess you ar referring to the RecoveryMode / Install form SD-Card?
Can you see there the SD-Card at all?
If not you have to move the ZIP-File to the internal storage and open it from there! Is it possible for you?
Cheers, Robert

yes, sorry, I meant step 4 of this manual https://fairphone.zendesk.com/hc/en-us/articles/202478028-Manually-install-Fairphone-OS-software-update-version-Kola-Nut-1-8-7

[quote=“therob, post:4, topic:10813, full:true”]
Can you see there the SD-Card at all?
If not you have to move the ZIP-File to the internal storage and open it from there! Is it possible for you?[/quote]
That’s the problem. As I said, when I connect the FP to my computer I don’t see the sd card, only internal storage / phone, which is why I moved the zip-file there.
When I get to step 4

FP1 old partition layout: Apply update from the “Download” folder on the Fairphone’s internal memory. Do this by choosing “apply update from sdcard”, and navigate to the “Download” folder.

I only see the sdcard - but not the phone storage.

edit: it is getting worse:
when I have the FP connected to the computer I can see the zip-file in the download folder of internal storage.(and can’t see the sd card)
When I remove FP from computer and go to file manager I don’t see it any more (but see the sd card and its contents).

how annoying :cry:

OK, starting again form beginning, maybe I missed something…

What is the current status of your FP?
Can you still boot it up normally and open the Android-File-Explorer?
If yes: you can see internal storage AND SD-Card, right?
If yes: just copy the ZIP-File to both of the locations to be sure you will find it later (if necessary download it again)

If this is not possible, try this:
If you still can connected the FP to your computer, but do not find the SD-card: try to use different connections type which you should be able to choose at the notification bar of the FP while connected --> USB settings --> MTP etc…just try the different options, if you see them.

So what?

1 Like

Hi the rob and thank you for your help :smile:

well, booting it normally is relative :wink: but yes, sort of normally.
In the file explorer I see both internal and sd storage.
I made a mistake earlier. When I connect the FP to a computer I can only see the SD card (not the internal storage, don’t know why). So I did in fact copy the zip-file to the sd-card.
this is good.

I got across step 4 from this manual this time. this is also good.
but :frowning:
the installation was aborted after a short while, with “error”.

I will now download the zip file again and start the whole thing again, just in case, but I fear it won’t work. Because I did download the right file the first time as well, and the installation started…

I tried it again, same thing.
First the installation starts, then it stops.

– istall /sdcard/download…
Installation aborted.

When I first dowloaded the ZIP file on my computer and copied it to the phone (fist to the SD, then to the internal storage), I couldn’t find/open it in recovery mode either. Somewhere I read that it needs to be in a determined folder. So then I just dowloaded it with the phone, which stored it automatically in the right folder, the standard download directory, I guess. That time I saw the file in recovery mode and was able to run the update.

hm, weired…

  • Which exact ZIP-File you have downloaded? (maybe it is the wrong version for your storage layout?)
  • Your current storage layout is 1+12GB or already 13GB? How much free storage is available in each?
  • Are your data at the phone important, or did you anyway made a backup so we dont have to care about? If this is the case maybe “wipe cache partition” or doing a “factory reset” could help before making the manual upgrade?
  • Your error message is just as you posted - nothing more? Afterwards it only boots in the old FP-OS, right?
  • And what means “booting it normally is relative” exactly?

After you answered these questions, maybe somebody else have a better idea?

@Irina_Spitznagel: I think @Ruth_FP1 is now already one step furhter, as he/she already could choose the ZIP file…
Cheers, Robert


Wiping the cache partition should not mess wih any user data, so I guess a backup is not necessary in this case (of course it’s good to have one anyways).

Yes, I made a back-up before I started the whole process, and this is strongly recommended in the two instructions and also on the FP during the process you are made aware that all data on the FP will be erased (so if you did not make a back-up before you will do it then).

installing storage-upgrade
Manually installing storage-upgrade

I had to use the phone yesterday so I reinstalled all data, and had quite a few problems there, which I have put in a new topic Problems with back-up / restore (standard app)

Today and tomorrow I also have to use the FP a lot, so I will try to repair the back-up / data. And then have another go at the storage think later this week.

Thank you @therob and @Stefan for now, see you later :sunglasses:

1 Like

That’s quite strange, even though it did not work according to the official FP instructions and the way it happened on the FP it has secretly worked and I now have only one internal storage (13,4 GB) and no phone storage any more.
Free drinks for all!

Ruth = she :wink:


That means…all your problems are gone now?
What FP-OS do you have running now (check FP-updater)?

No, it just means that the storage upgrade was successful and I now have one partition for the internal phone. :+1:
Unfortunately this resulted in lots of new problems I haven’t quite solved yet: contacts and some dates in the calendar and most text messages I have double or more now. :-1:

I still have Kola Nut 1.8.7 just as before I started the storage upgrader installing.

OK, that means you dont have problems anymore connected with the storage upgrader, which is good.
Unfortunately we don’t know at which moment you had success with applying it, right?
Maybe you can narrow down what the most likely scenario of your succes was.

Then we can close this topic and continue the discussion about your other problems at your other post.
Cheers, Robert

I wrote here already, my last step was (from the manual installation):

This is all I did. Apparently even though I got an error message the installation was successful.
I know this does not really make sense, but this is all I did.

edit: and I updated the problem list in the back-up topic: Problems with back-up / restore (standard app)