Unable to install August security update on FP3

I have never before disabled Netguard for any update, and even this one downloaded OK, seemingly at least. Either the update wanted do download some payload through sth I have blocked (not sure what, though, but who knows, I haven’t got Netguard Pro yet, so no logfile for me :slight_smile: ). Or, it was just a coincidence, and the update had a random element to it, that just worked after trying it the 10th time…

How can I remove the cache and restart the download?

I moved your post here to avoid duplicate topics.

So I’m reading up on the new android 10 update.

I recently bought a new fairphone 3 for my girlfriend, arrived about 1 week ago. Her phone is on Android 10.

I, however, have my fairphone 3 since january and it is stuck on android 9. When I go to the update page it says I have the most recent update, which is from 15th june 2020.

What is going on? I want the android 10 update and I want it NOOOOOOWWW!!! :’( :’( :’(

Please, anyone? What can I do?

  1. Insert the SIM card of someone else in your phone, that is not from Vodafone or a related network.
  2. Or install manually the update but I don’t recommend it to you.

My SIM is not from Vodaphone, but I tried without SIM and still nothing.

Vaguely I remember getting an update message in an inconvenient moment a while ago and I thought I’d do it later so clicked it away. Could that have something to do with this problem?

Still stuck on android 9.
Before manual install I consider backing up everything and resetting to factory settings, but not looking forward to it. So any other advice is welcomed!

What provider do you have? If your provider is using vodafone’s mobile network-infrastructure it can result in the same behavior as if you’d have a vodafone SIM.
And just removing the sim isn’t enough in that case, you’d have to insert a sim from a different provider…


I have got the same Probleme.

My best guess by now is, it is because I have rooted my FP3 and have TWRP installed. If that is the case, how do I proceed? Unroot?? But how, unfortunally, I did not back up the original boot.img when I installed Magisk. Or can I download a update.zip an flash it via TWRP?

1 Like

Yes, that would be the reason.
As long as Fairphone only provide incremental OTAs instead of also supplying Full OTAs like other vendors do, the OTAs will fail if any of the partitions that are to be updated have been modified.
That includes having Magisk or TWRP installed, or having done modifications to the system-partition.
Typically with other vendors the OTA-Updater will first try an incremental update and then use a full OTA if the incremental update fails.
Magisk saves a copy of the original boot.img which can be restored using the Magisk-Uninstaller.
However if the boot.img was already modified before installing Magisk (i.e due to installing TWRP) or any other modifications to the other partitions have been done, that won’t be enough.

As above, any modification to any of the partitions that are included in the (incremental) OTA will make the update fail.

It needs to match the OS-Version that is currently installed, other partitions may also need to be restored.

TWRP should be able to install the OTAs directly or through sideloading (it does include the update_engine_sideload)
This does have the same restrictions as a normal install though and will fail if the system was modified.


I have same problem but not installed twrp but magisk only.
Does it mean now that we will never get an update again? :astonished:



the current FPOS (FP3-REL-Q-3.A.0045-20200905.155001-user-fastbootimage) can be downloaded from the following link.
is it not possible to simply install the OS over it with the option “2. Keep user data” as in the following step?

Magisk may then have to be installed again.


It works! :grin:



For the history books, same issue for me with today’s version …0054… update, had to turn off Netguard again, then it worked (2nd attempt, 1st one was with Netguard on).

1 Like

the latest update also worked :smiley:

I finally found a way to get the update, after a hard struggle. I gladly share it to anyone who wants to know.

My problem was that I didn’t even get the message saying there was an update. The updater would say I had the most recent version, but it was from 15th of June 2020. So certainly not the most recent.
I first tried what was recommended to me, being doing a manual install. That did not work, because I couldn’t even unlock the root bios. So it wasn’t an option.

I did the following;

  • back up all data
  • reset to factory settings
  • remove SIM-card
  • start up the phone
  • ignore or skip all install messages, accept WIFI connection
  • Choose default English U.S. as operating language
  • Once the phone ready, it finally automatically gave me the update message and I was able to install it.
  • After full update install I recovered my back-up. It installed everything back, I only had to put the icons for the apps back the way I want them.

Before doing a factory reset, did you try just to remove the SIM card, boot and see if you were prompted to update? It might have been this the problem.


I did and it didn’t do anything. I couldn’t even unlock the boot for some reason, although I followed all the required steps and unlocked developers mode and everything. Didn’t do anything. So factory reset was only way for me

1 Like

Had the same result myself…I time to file a bug with Netguard!

1 Like

Well, I guess hereby we have solved our little mystery here :slight_smile:

Thanks for confirming!

I also can’t seem to update my Fairphone 3, with the same “Installation problem” error after it tries for a bit to install the update.

  • I have a Simyo SIM card, which uses the KPN network.
  • I currently have Android 10 with build number 8901.3.A.0054.20200929.
  • I do not have Netguard (or any similar app) installed.

I have previously run TWRP on the device although I was under the impression that it only ever touched RAM: I booted it with fastboot boot twrp-3.4.0-0-FP3.img and I don’t think I did anything with it. Later I re-locked the device, wiping all data in the process. It still says secure boot is disabled but I don’t get any message on startup. So, I’m guessing the device is still not fully restored to its original state and perhaps my unlocking adventures have modified one of the system partitions.

So my question is now: how can I install this update? If possible without having to wipe my phone again.