English

Unable to install August security update on FP3

I had previously installed the Android 10 update when the popup came on my FP3. Then today I got the notification that the August security update was out. When I try to install that, it fails. I’ve tried a handful of times to no avail.

Is this a known issue? Anyone else having this problem? Any troubleshooting tips?

Carrier: T-mobile(update downloaded over wifi though)
Build number: 8901.3.A.0033.20200815
Model: FP3
Android Version: 10
Software update: FP3.3.A.0045

1 Like

Interesting, I had the same issue but thought it was due to the rooting of my device (I restored the boot partition before trying the update though). Did you root your device?

1 Like

I have not, most tweak like stuff I’ve done was try to remove chrome and google photos through ADB(which didn’t work, but that’s a different issue).

Got any suggestions for what I should try?

Let’s wait and see if others have the same issue. Maybe the update is just broken. Note that the Android 10 Update has been removed from the service page. Maybe this is related?

3 Likes

Ohh that’s possible. Maybe it tries to call out for the remaining update parts, and because they pulled it(for whatever reason) it’s failing. I’ll stand by then!

1 Like

Ok I manged to update, looks like my system.img got modified for some reason due to rooting. I restored the original partition and then the update went through. So it’s not an issue with the update itself.

1 Like

Hi there,

quick question, as this is the first time happening to me; today I got the latest FP3 update. Went OK, but after reboot a message came up, telling me the update failed (check battery>50% & connection). Battery and Connection are not an issue, I tried again. 5 times. No good.

Am I the only one with this problem?
What is “the usual solution” (if such thing exists) to this? Ignore&Wait?
Anything else I can try? (besides OS reinstall, which I would avoid if I can, for the pure lazyness of not setting everything up once again, just for an update)

Cheers,
Sebastian.

I moved your post here as you indeed aren’t the only one.

2 Likes

@alex21: thanks!! (couldn’t find this thread at first, but just stumbled on it, too)

@grumpy: since I have not done any modifications to my phone’s inner clockwork, but did as @strongthany did, remove some stock apps via adb, but that didn’t stop the big update to Android 10 to run through, hence I was not thinking about this causing an issue.

Hence, standing by, too :slight_smile:

1 Like

@swhcz This is off topic but can you DM me or something about getting apps removed through ADB? I’m having issues pulling Chrome and Photos off my phone.

I got the update request again this morning, and applying it this time went without issue.

1 Like

Encouraged by @strongthany’s reply, I tried again this evening. Failed 3 times. Couldn’t let go, though.

Not sure if related, but it worked after I switched off Netguard.
(it was on in all previous attempts).

Case closed for me!

3 Likes

Odd, I had Netguard on as well when it wasn’t working. I didn’t have to disable mine to get it to work tough. Did you have Netguard filtering traffic?

I have never before disabled Netguard for any update, and even this one downloaded OK, seemingly at least. Either the update wanted do download some payload through sth I have blocked (not sure what, though, but who knows, I haven’t got Netguard Pro yet, so no logfile for me :slight_smile: ). Or, it was just a coincidence, and the update had a random element to it, that just worked after trying it the 10th time…

How can I remove the cache and restart the download?

I moved your post here to avoid duplicate topics.

So I’m reading up on the new android 10 update.

I recently bought a new fairphone 3 for my girlfriend, arrived about 1 week ago. Her phone is on Android 10.

I, however, have my fairphone 3 since january and it is stuck on android 9. When I go to the update page it says I have the most recent update, which is from 15th june 2020.

What is going on? I want the android 10 update and I want it NOOOOOOWWW!!! :’( :’( :’(

Please, anyone? What can I do?

  1. Insert the SIM card of someone else in your phone, that is not from Vodafone or a related network.
  2. Or install manually the update but I don’t recommend it to you.
4 Likes

My SIM is not from Vodaphone, but I tried without SIM and still nothing.

Vaguely I remember getting an update message in an inconvenient moment a while ago and I thought I’d do it later so clicked it away. Could that have something to do with this problem?

Still stuck on android 9.
Before manual install I consider backing up everything and resetting to factory settings, but not looking forward to it. So any other advice is welcomed!

What provider do you have? If your provider is using vodafone’s mobile network-infrastructure it can result in the same behavior as if you’d have a vodafone SIM.
And just removing the sim isn’t enough in that case, you’d have to insert a sim from a different provider…

2 Likes