Unable to install apps on a fairphone 4 with /e/OS v1.17

I just received a new fairphone 4, but I’m not able to install apps. When I try, it acts like it’s downloading the app, but after the download gets to 100% the install fails as it says “retry”. I ran the updater, which updated the OS, but this didn’t help. I’ve been only trying to install free apps, and I’m logged in as anonymous. I’d be grateful for any suggestions!

What app is it ? :interrobang:
I can install any apps on Murena /e/ OS.

So far I’ve tried to install several terminal emulator apps, like Terminux and “Terminal Emulator”. These are all in the open source category.

I use Termux, but there will be additional problems to solve because the phantom processes killer terminates Termux. :disappointed_relieved:

I think this is not just an issue with /e/ OS; any Android version 12 and above will have this problem. :roll_eyes:

If you have this problem with any apps, I would suggest you to clear cache and data of App Lounge and restart it.
For issue with eOS, you can also reach the Murena community forum: https://community.e.foundation/
…and welcome to this forum.

1 Like

jobal, thanks, I just tried clearing the data and cache but the error remains. Any other ideas? I’ll open another thread on the murena forum.

KaMiao, I wasn’t aware of that issue, but that’s kind of horrifying. Any recommendations on a good terminal app?

Termux is great; it allows you to run a Linux desktop system on the FairPhone. :heartpulse:

However, no matter what, you will eventually encounter the phantom processes killer issue. :disappointed_relieved:
We can only wait to see how Murena solves this problem. :face_with_spiral_eyes:

I believe all your other apps can be installed without any issues; it’s only this app that seems to have a problem. :thinking:

Success! I started a thread on the /e/OS/ forum, and one of the folks there directed me to this thread:


In Settings->Advanced Privacy->Manage My Internet Address, I had checked “Hide my real IP address”. When I switched this to “Use my real IP address”, I was able to install apps.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.