Unable to install APK

Good afternoon,

unfortunately, I forgot to install an appropiate offline-translator app on my FP4 before leaving home, so I’m trying to do that now. After reading some reviews, I tend to chose the MS-Translator App, as it seems to have quite nice offline-options, which is mandatoriy for me. As the internet is restricted here, I cannot install anything from GooglePlay. So, I downloaded an APK (4.0.543) and tried to install it. This ends with an error message, saying that the app is not compatible with my phone. I tried switching to developer mode, without any different result.

Does anyone have an Idea if there is a workaround or can anyone confirm that MS-Translator is not compatible with FP4?

Greetings from Lhasa,
Thomas

This is not a fairphone problem I think. From google searches I learn that the APK is either not for your android version or the APK has a incompatible architect structure.
Check which cpu architecture you have: ARM, ARM64 or x86
Then see if the app is compatible with your version: https://apkpure.com/microsoft-translator/com.microsoft.translator/download ( Architecture: arm64-v8a,armeabi-v7a)

2 Likes

Good evening!

Meanwhile, I got a VPN running, so installing die app the “official” way, instead of downloading an APK, worked. The app runs fine and does a great job. Unfortunately, tibetic languages are not yet supported…

Greetings from Lhasa,
Thomas

1 Like