English

Unable to boot into recovery

Hi everyone

I have been trying to install on LineageOS on my brand new Fairphone 3+ and I’ve run into some trouble. I’ve been following these instructions and am stuck on step 6 using LineageOS Recovery. The basic problem is that I don’t see the recovery menu.

I get to this screen and choose Recovery Mode

I found this thread with the same problem but his solution isn’t working for me. I just get the “No command” sleeping robot screen. On that thread his solution was to press Power AND THEN Volume Up (while still holding Power) but that just brings me back to the sleeping robot after a restart. After a few minutes the phone reboots and goes back into normal Android (without me doing anything to cause this action).

Any ideas? Thanks!

Just to be sure, you mean you’re stuck in the “LineageOS recovery” step in this screenshot?

The photo you posted is of the FP3 in bootloader mode. Which means you should be at steps “Boot your FP3 into the bootloader” and “Connect your FP3 to your computer”.

So I would assume that something went wrong in the next step "Open Minimal ADB and Fastboot and enter the command fastboot boot RECOVERY-FILENAME.img"

As you said you’re using the LineageOS recovery: what happened after you executed fastboot boot lineage-17.1-20210329-recovery-FP3.img?

Hi Ingo!

many thanks for responding. Sorry my post wasn’t very clear. I found the solution using some internet searching and reading the Lineage Wiki here - this command worked and now I’m able to get into recovery.

fastboot flash:raw boot_a lineage-17.1-20210329-recovery-FP3.img

It’s a little bit confusing having different instructions on this site and on the Lineage wiki, but hopefully I’ll get there. I’m just going to try the copy-partitions-20210323_1922.zip thing now.

If I have more questions, I’ll post back here, if that’s ok?

3 Likes

Yeah, follow-up question are perfectly fine.

Ok, just one question. I think I have succeeded in sideloading LineageOS and Gapps - the 47% success confused me but I figured it out. I’m hoping that slot A was the right one to choose.

My question is: how do I get back to the main menu from this screen? The guide says to use the back arrow, but I don’t see it? I know I can get back to by going into fastboot and then into recovery, but surely there’s a direct route?

Thanks again!

Unfortunate after I rebooted things didn’t go very well. At the moment the phone doesn’t boot into Android. If I boot into Recovery, I get this screen (see the message at the bottom).

I tried a Factory Reset but I’m still getting the message.

Also earlier, I had this message but am not seeing that now.

What’s the recommendation here? Start the process again? Maybe I could try it with TWRP. Could it be I need to use slot B instead of slot A?

Thanks for any ideas

It doesn’t matter if you use slot b or a as long as you use the same one throughout the installation procedure.

I guess it’s easiest to just start again. But I can’t recommend on TWRP vs. Lineage recovery. Haven’t used either of those on FP3 so far.

3 Likes

Thanks. It worked the second time around. I think part of the problem was my confusion about how to use back button in the Recovery menu. It took ages to figure out that you have to use a combination of the Power and Vol buttons in order to go back to the previous menu. So I probably crashed out of that menu a few times, which didn’t help.

I appreciate the support!

4 Likes

I thought I had the issue too, but actually, I hadn’t understood that after sending the recovery image ( “fastboot boot`imagefilename.img”) and relaunching the bootloader (startup with Vol- + power), you had to choose “launch recovery” in the bootloader menu.
What is also a bit strange is that the recovery still has a “e” logo (my previous system). Am I using the correct recovery?

That sounds wrong.

If you do fastboot boot recovery.img it should directly go to the new (temporary) recovery.
In case you need to press Volume-down + Power and go to the bootloader menu, it’s clear it won’t work.

1 Like

Hmm. Indeed there’s something strange. I have tried two procedures: the one on the Lineage Installation wiki on this forum, and the one on Lineage’s own FP3 installation wiki. In the Lineage wiki procedure, the fastboot flash boot <recovery_filename>.img instruction fails (my mac’s Terminal reports “fastboot: error: boot partition is smaller than boot image”).
The equivalent step on this forum, when I send fastboot boot <recovery_filename>.img seems to work, terminal reports:

Sending 'boot.img' (65536 KB)                      OKAY [  1.443s]
Booting                                            OKAY [ 39.140s]
Finished. Total time: 40.783s

After that, the phone restarts after a security warning about the unlocked bootloader (with a possibilty to interrupt the reboot), but then doesn’t go into the recovery, but in an ordinary launch, launching /e/.
I can launch recovery from a bootloader restart (Power + Vol-), and then choose to launch recovery, and that lands me in /e/'s recovery. (I had installed /e/ through their “easy install” utility, so I hadn’t met theses difficulties before).
But I never achieved a reboot into an alternate recovery, tried both procedures, and two recovery images (the one from Lineage or the one from Lineage+MicroG, which is my actual goal).

Is it possible / safe to use /e/'s recovery to install Lineage17+1 + MicroG (from here)?
Or would my best bet be to reinstall FP’s original OS?

1 Like

I would say yes, a recovery is a recovery and the /e/ recovery is a fork of the Lineage recovery anyway. But I haven’t tested it myself.

2 Likes

It worked. I successfully installed Lineage+MicroG (17.1) using /e/'s recovery that was previously installed on my Fairphone.
Now on to exploring Lineage!

3 Likes

I’m new to Fairphone and LineageOS and am facing some troubles getting the system installed as well.

I’ve tried to follow both, the Wiki and the Guide in this forum, and while I can boot into the regular Android recovery I can’t boot into Lineage recovery.

The commands fastboot boot lineage-17.1-20210705-recovery-FP3.img and fastboot flash:raw boot_a lineage-17.1-20210705-recovery-FP3.img both work. But the phone still only boots the Fairphone Android system. Manually booting into recovery (POWER + VOLUME UP) always only boots the regular Android recovery.

So, what exactly has to be done to boot into the Lineage recovery?

Any ideas and help is greatly appreciated.

What fastboot version do you have? It may be worth checking if a newer/older one works better.

Hi,
I also had a hard time booting into recovery mode.
In the end, I managed thanks to this Reddit post: https://www.reddit.com/r/LineageOS/comments/n0k6sn/fairphone_3_fastboot_error_boot_partition_is/

This command lets you know which slot is active (a or b)

$ ./fastboot getvar slot-active:a 
slot-active:a: No                                                            
Finished. Total time: 0.008s                                                 
$ ./fastboot getvar slot-active:b
slot-active:b: Yes                                                           
Finished. Total time: 0.007s

If slot b is active, the following command will flash to the correct slot:

$ ./fastboot flash:raw boot_b ../lineage-18.1-20210816-recovery-FP3.img                                                                         
Sending 'boot_b' (65536 KB)                        OKAY [  3.207s]              
Writing 'boot_b'                                   OKAY [  0.312s]              
Finished. Total time: 3.592s                                                    

Then use adb normally to flash LineageOS:

$ ./adb sideload ../lineage-18.1-20210816-nightly-FP3-signed.zip
2 Likes