Ubuntu OS on Fairphone 2

New Update on a Port of Ubuntu Touch for the FP2:

@Douwe, your forum post is also quoted in the article :slight_smile:

Another very relevant quote is the following:

[quote]…be aware that the Fairphone 2 does not support MHL (a USB to HDMI technology) so cannot be connected to an external monitor through a cable to drive a ‘converged desktop experience’.

We don’t yet know Ubuntu plans for wireless connection technologies like Miracast which could, in theory, support such a feature.


just saw this spanish article:

Refering to Marius Gripsgårds article.


So, the problem with lacking MHL-support might be solved, sooner or later…

1 Like

Hey everone,

here is a description how to install Ubuntu OS alpha on the FP2:


Please note: this seems to be at a really early development stage. The only things that are currently working are: Graphics, Boot & Touch.


I said it for Fairphone 1 and I’ll repeat for Fairphone 2 : this is my dream telephone, but I won’t just use it with a google account cause I don’t trust google, I don’t like google, I think google is much a greater problem for the world than the ones Fairphone is trying to solve. So as soon as I get an open source OS I’ll buy it without a second thought, and Ubuntu would be my first choice.


Well, the FP OSOS is ready for testing and works just fine. You can sign up here or wait a few more weeks (I guess) until it will be officially available.
Moreover, also Sailfish OS is available for testing and hopefully soon will officially be available.

Anyhow, it is easily powwible to install an OS without the need for a google account already.

Btw: also for the FP1 you didn’t need one, as the Gapps where not pre-installed.

1 Like

What do you think, are they still working on this? https://devices.ubports.com/#/FP2

I’d really love to see Ubuntu running on my FP2!

Looking at the builds and the checksums in the jason file the builds still seem to happen (every day the same?). But I can’t find a Changelog. But maybe it will help to ask the devs nice & friendly and just post their answer here?


KDE+Plasma runs under Ubuntu too: Plasma Mobile.

Ubuntu Fairphone 2 port is coming along nicely


And a link showing alpha status of ubuntu-convergence on a fairphone 2

Any idea which channel one should install? I tried stable which booted but didn’t find my SIM. devel-proposed and devel-rc-proposed didn’t boot.


could you say ma how you flash UbuntuTouch?
i always get this error: “Can’t boot recovery image”

at the moment my FP2 runs on "FP Open OS 16.04.0"
an i flash UbuntuTouch with (in fastboot on Debian as root):
ubuntu-device-flash --server=http://system-image.ubports.com touch --channel=ubuntu-touch/stable --device=FP2 --bootstrap

Thanks a lot

Hey @marc13,

i found a way to run Ubuntu touch on my fp2
I had the same error.
Then I boot to the Ubports recovery with the power button and vol up.
-> Ubuntu actions->wipe date factory reset
connect the phone to the pc

and try the ubuntu-device-flash … command without the --bootstrap option.

After that, the phone reboots. 15 min later there was a blackscreen and I removed the battery. and restarted the phone.

Now ubuntu touch works.

Sorry, I hope, you can understand my english :wink:


Edit: if you have a encrypted phone, you have to reset all android datas in the rec-manager

1 Like

Cool! Which channels are you using and does it recognize SIM card?

sudo ubuntu-device-flash --server=http://system-image.ubports.com touch --channel=ubuntu-touch/stable --device=FP2

Stable channel, but sim doesnt work ;(

1 Like

same here and only the stable channel boots up.

Hey @pata,

To flash Ubuntu OS on your FP2, do you need to have a particular build of Android ? Can I flash I with Fairphone Open or do I need the “official” build of Android ?



Has anyone of you succeded in installing devel_rc-proposed which should come with sim-support, as far as I understand? Or in getting in contact with the ubports-people (mariogrip)? I tried both and couldn’t achieve one of it.
@anon59030904 Have a look at this wiki page

Thanks @juri.gagarin.ii ! Flashing with your wiki and the stable image worked, but no SIM support (shit !). I tried installing devel-proposed, but the phone stayed stuck with the Fairphone logo. I’m back to FP Open OS for the moment, but I hope that problem can be solved :slight_smile:

And by the way, does anyone know how to unlock your phone with Ubuntu touch, as just pressing the power button shortly didn’t do anything for me (I had to press it a long time, as if I wanted to make my phone reboot) ?

EDIT : for the second “problem”, it’s not a problem any more and it works. But do you know how to enable MTP ?