UBPorts 16.04 updates + feature tests

That’s what I’m saying. In Xompass app, the compass is not moving if phone is rotating. Also the SensorStatus app show no numbers in compass tab, so my guess is, that UT is not even avare, that there is an compass in phone.

1 Like

Just saw that there is already an issue about it: https://github.com/ubports/ubuntu-touch/issues/38


I’ve done some testings and with your installer the process went further, until I got this:

It worked with Ubuntu 16.04 :grinning:

Report: Compass issue updated.

1 Like

12 posts were merged into an existing topic: State of the Ubports installer

I switched back to Fairphone Open some hours later since my device was rebooting randomly. I will wait for this system to be reliable before considering adopting it for good.

The OTA-6 update for Ubuntu Touch is now released, and will be made available to all users progressively through the next five days.
With it you can expect some significant improvements to the Morph Browser, the OnePlus One, and several other fixes.
Find out more at: https://ubports.com/blog/ubports-blog-1/post/ubuntu-touch-ota-6-release-186

A big thank you for all contributors!

#UBports #UbuntuTouch #OTA6 #Shiny #Release

1 Like

Updated using the updater app on the phone to version 16.04 (2018-12-16 or r660)

What works for me

  • call / be called
  • send SMS / receive SMS
  • internet via WiFi
  • internet via mobile network (4G)
  • USB connection to PC / MTP
    • it takes some time before folder contents are shown (used to be faster)
    • Logitech K400 Wireless Touch Keyboard + Mouse works
    • changing to correct physical keyboard from the status bar works
  • keeping the time zone after reboot
  • screenshot (press + hold Vol-up and Vol-down)
  • external sd card
    • access existing photos with the gallery app
    • navigate through the existing folders with the file manager app
  • shutting down the phone
    • for Android >= 7 this only causes reboot instead of shutdown with the new camera module
  • location (GPS)
  • openstore
  • camera (new camera module)
  • bluetooth
    • audio speaker: MusicMan BT-X2
  • alarm (incl. swiping it off)
  • automatic screen rotation
  • calendar app
    • using my CalDav calendar (via adding online calender in the app)
  • contacts app
    • using CardDav (via syncevolution script)
  • email (Dekko2 community edition)
  • gallery app
  • file manager app
  • terminal app
  • media app
  • music app
  • notes app
  • calculator app
  • weather app
  • logviewer app
  • telegram app
  • enabling ssh
  • external monitor via WiFi direct
  • the syncevolution script to set up my owncloud account
  • Adding an owncloud account (in settings > accounts)
    • note for people who use HTTPS with self-signed certificates: needs to be set up as described in this earlier post about the syncevolution script: March 4th
  • running desktop apps with libertine (can be configured/packages can be installed via settings app)
    • initial container setup took roughly 1h, so be patient
    • tried these desktop apps so far
      • aisleriot: seems to work
      • claws-mail: starts, needs USB keyboard + mouse to be usable, but some dialogs can’t be operated properly
      • frozen-bubble: starts, but it uses only one small corner of the display which makes it unusable
      • xskat: doesn’t even start

What doesn’t work for me

  • flash (new camera module; known issue)
  • compass (known issue)
    • both Xompass and SensorStatus apps don’t show any reading as if there was no compass (but the FP2 has one)
  • Spotify
    • web player has no way to login on a mobile phone
    • no app available for xenial; CuteSpotify vivid app doesn’t work

Some more points

  • I get a few random reboots that usually don’t happen on LineageOS; but not as many as other UT users report (but then, I don’t use it as daily driver…)

Running android apps vie Anbox (emulates 7.1.1)

  • This is still experimental and needs to be enabled manually (again after each system update)
  • Installation
  • Installing android apps
    • Simply copy the APK file(s) to the phone and do adb install <name of the file>.apk
    • if you want to use app from another android phone, you can pull the APKs as described in https://stackoverflow.com/questions/4032960/how-do-i-get-an-apk-file-from-an-android-device#18003462
      • connect the android phone with USB cable and USB debugging enabled
      • list all packages with adb shell pm list packages
      • get the full path for the package name you’re interested in: adb shell pm path com.example.someapp
      • pull the APK using the output of the last command: adb pull /data/app/com.example.someapp /path/to/desired/destination/com.example.someapp.apk

Out of the box there is no file access between UT and anbox; to access the anbox files from UT do

mkdir -p /home/phablet/AnboxHome
sudo chmod -R 777 /home/phablet/anbox-data/data/media/0
sudo mount --bind /home/phablet/anbox-data/data/media/0 /home/phablet/AnboxHome

Finally, these are the apps that work for me

  • CatLog
  • Onleihe
  • Spotify
  • Threema (Polling instead of Push notifications)
  • WhatsApp (probably also polling)
  • my banking app

But please take note: I haven’t tested those in depth and am not using them on my daily driver, so maybe some problems went unnoticed so far.

What didn’t work

  • Opening developer options crashes the settings app
  • AdAway (needs root)
  • Bücherhallen (doesn’t run without gapps; managing wish list works)
  • car2go (doesn’t run without gapps)
  • DB Navigator (crashes immediately on start)
  • Drive Now (doesn’t run without gapps)
  • Firefox (looks as if it works, but web pages are rendered entirely black)
  • iButtons (simply doesn’t start)
  • Real Drum (simply doesn’t start)
  • Stadtrad (doesn’t run without gapps)
  • vlc (upper third of screen remains black, the app window seems shifted down and lower part is not visible)

a few additions:

  • bluetooth
    • audio speaker: JBL Go - not working
    • audio speaker: JBL Clip 2 - working
1 Like

Today I tested Spotify in anbox on my way to work. Playing stuff online, i.e. not downloading the music first as I would usually do.
Didn’t notice any difference to using it on my main phone except that UT doesn’t have controls to play/pause/skip on the lock screen.

Not sure if that would work as a daily driver, though: during 50min the battery went down 16% (mobile data and wifi on, GPS and bluetooth off).

Hallo Ingo,
vielen Dank für Deine Anleitung für Anbox… irgendwie habe ich es geschafft. Was ich noch nicht kann - wahrscheinlich fehlendes Basiswissen - ist eine app neu auf meinem FP2 zu installieren. Wo bzw. wie bekomme ich den package name von WhatsApp auf mein FP2??
Danke und Grüsse aus Kiel

Okay, I just solved the WhatsApp.apk problem and just found a new one: the file access. I can find the AnboxHome with Dateiverwaltung (UT) but not with file (Anbox). I just need help to switch between both. Fore example to transfer the utcontacts.vcf to Anbox and use it with WhatsApp.
The following is working:
File, Contacts (without Import), Calender, Settings, Clock.
Still not working:
Camera, Email and the file access Anbox to UT
I just wont to switch to an other OS… but now I stay @ ubports

It might not be possible at the moment. Anbox is in a really early stage.


I just thought it would be so easy to get all the well known contacts into the Anbox. I tried using dropbox to transfer the file. Dropbox in Anbox is working fine, but after saving the file to my device, I can’t find the file at the device. Dropbox opened a different container comparing to the Anbox - file container . Now I will test Whatsapp typing the contacts again and it it works that won’t be bad at all.

I just tried: after the three commands I posted above (mkdir, chmod, mount) I could copy a VCF file from UT to AnboxHome and then import it in the android contacts app.

BTW, in the UT telegram group someone asked about spotify web player in the new morph browser. In the past I only tried the old one.

Doesn’t help much. It is possible to login at spotify.com but then opening the web player at open.spotify.com just looks the same as with the old browser: no access to your playlists, no way to actually play songs (it’s the same on Android BTW, so I guess mobile browsers are not supported, indepenent of the OS).

So it seems the only way to listen to Spotify on UT is with anbox + original android app (at the cost of a big battery drain).

Because I update so often, I became too lazy to manually do the aethercast fix to the apparmor settings each time and wrote a script for that: https://gist.github.com/Ingo-FP-Angel/905c5655511435b0ded2eb354dab538b

1 Like

You’re a script angel, @Ingo ! :smiley:

1 Like

7 posts were split to a new topic: State of the Ubports installer

UBports team published a really interesting new video: UBports: Life porting session of Halium on FP2

1 Like