UBPorts 16.04 updates + feature tests

Updated using the ubports-installer pre-release 0.1.21 AppImage version.
Installation went smoothly, but there is one known issue: FP2 not detected despite it is detected - split brain? #187. If that happens, simply select the device manually and continue.
It should no longer necessary to go back to very old installer versions (several after 0.1.9 had problems here and there).

So now I’m on version 16.04 (2018-07-21 or r395)

What works for me

  • call / be called
  • send SMS / receive SMS
  • internet via WiFi
  • internet via mobile network (4G)
  • USB connection to PC / MTP
    • it takes some time before folder contents are shown (used to be faster)
    • changing to correct physical keyboard from the status bar works
  • keeping the time zone after reboot
  • screenshot (press + hold Vol-up and Vol-down)
  • external sd card
    • access existing photos with the gallery app
    • navigate through the existing folders with the file manager app
  • shutting down the phone
    • only causes reboot instead of shutdown on LineageOS
  • location (GPS)
  • openstore
  • camera (new camera module)
    • flash does not work
    • front camera image is upside down
  • bluetooth
    • audio speaker: MusicMan BT-X2
  • alarm
    • some people report crashes (cause might be having more than one alarm or an repeated alarm; didn’t dare try that yet)
  • calendar app
    • using my CalDav calendar (via syncevolution script)
  • contacts app
    • using CardDav (via syncevolution script)
  • gallery app
  • file manager app
  • terminal app
  • media app
  • music app
  • notes app
  • calculator app
  • weather app
  • logviewer app
  • telegram app
  • enabling ssh
  • the syncevolution script to set up my owncloud account
  • Adding an owncloud account (in settings > accounts)
    • uses HTTPS with self-signed certificate (needs to be set up as described in this earlier post about the syncevolution script: March 4th)
  • running desktop apps with libertine (can be configured/packages can be installed via settings app)
    • initial container setup took roughly 1h, so be patient
    • tried these desktop apps so far
      • aisleriot: seems to work
      • claws-mail: starts, needs USB keyboard + mouse to be usable, but some dialogs can’t be operated properly
      • frozen-bubble: starts, but it uses only one small corner of the display which makes it unusable
      • xskat: doesn’t even start

Used to work but not at the moment

  • automatic screen rotation

What doesn’t work for me

  • flash (new camera module; known issue)
  • Spotify
    • web player has no way to login on a mobile phone
    • no app available for xenial (didn’t try CuteSpotify vivid app)
  • email
    • no app available for xenial (didn’t try Dekko 2 vivid app)
  • External monitor via WiFi direct (with a Samsung BD-J5500 Blu-Ray player)
    • device is not found
  • Android apps
    • anbox is not yet supported on the FP2

Some more points

  • I get a few random reboots that usually don’t happen on LineageOS; but not as many as other UT users report (but then, I don’t use it as daily driver…)
1 Like

Great work @Ingo ! I can’t wait to replace Android for good !

Thanks, @Guillauume but I’m actually not really contributing to Ubuntu Touch, I just happen to test their progress from time to time and let people know in this topic :wink:

1 Like

I know but you make it a lot clearer :slight_smile:

1 Like

you could use SailfishOS :wink:

1 Like

That works well, too

Now that Lineage 15.1 is officially supported I’m testing Ubuntu Touch again. Updated to 16.04/devel version 2018-08-11. No time for a full feature test, but things I noticed

  • The Samsung BD-J5500 Blu-Ray player is now found via WiFi direct but connecting fails
  • The libertine desktop app scope now shows the installed apps

Then I also tried the vivid version of cutespotify, but it fails to login. Tried to build it myself for xenial but I already failed at download a required library from spotify because the linked download page no longer exists.
uMastonauts (for Mastodon) seems to work somewhat, i.e. I was able to login and it showed my timeline a couple of days ago but today the app screen stays blank.

The phone was switched on for 26 hours now and the battery is down 59%. But then I’m not using it much as my main use cases don’t work (yet). I had GPS and bluetooth enabled for roughly half of the time (which I usually switch off on my main phone).

1 Like

Thanks for your regulär reports!
Do you have any knowledge about the state oft anbox? Last thing I heard was that it is being worked at but there are problems for certain devices due to kernels.
Has the camera improved for the new models? Last time I tried it was working so far that the picture had the right orientation, but taking photos was incredibly slow and flash was not working. (I wonder whether they could benefit from @mal’s work, as the camera is perfectly working with SFOS.)

As far as I understood, there is no work being done at the moment to bring anbox to new devices as everyone concentrates on getting 16.04 done. And IIRC anbox has some challenges with qualcomm devices, so I wouldn’t expect anything soon for the FP2.

Also, I don’t think anyone works at the FP2 new camera module problems (no flash, front camera picture is upside down).

Edit: at the moment, there is no fully working email client, but a first alpha of dekko2 is out since yesterday. Setting up an IMAP account worked fine, but that alpha version doesn’t display multipart emails yet.

1 Like

The issues in Anbox are not so much with Qualcomm but wayland in general. Upstream Anbox doesn’t yet work well with wayland backend of SDL. There is work being done to fix it but might need some changes to Anbox. In theory the alternative approach we have used in Sailfish might also work in other mobile platforms such as Ubuntu Touch. Not sure what backend Ubuntu Touch actually uses though.


Can’t say. Whenever there is talk about anbox in the UT telegram groups there are references about trouble with Qualcomm devices. But maybe this is just coincidence.
And as far as I understood, UT uses Mir, not Wayland.

1 Like

Thank you.
At least for me, camera isn’t upside down anymore (when I tried last time). It has correct orientation, but is incredibly laggy when you shoot a photo. So, as there seems to be progress in this issue, I thought that some progress might have happened to the flash in the mean time, too.

1 Like

Haven’t done any new testing, but just wanted to share that OTA-4 is out which means that now 16.04 LTS is the base of Ubuntu Touch :slight_smile:

Ubuntu Touch OTA-4 Release :uk:
Ubuntu Touch auf LTS-Basis gehoben :de:

It still has a few problems, so the automatic update for existing installations on the stable channel will switch to 16.04 with OTA-5 which is expected to arrive early October.


I’m on OTA-4. With some issues that need to be solved on OTA-5 (for example, Web Browser-next is not yet ready), but it runs really well. Very good OS. Dekko 2 Beta runs well, although needs to be “finished”. But I can see new mails, answer them… Flash is yet useless. But Camera runs very well (front camera is upside-down, but I think this is a “Stranger Things” reference, Isn’t it? Ho, ho…).

I hope OTA 5 will arrive with amazing changes too. And I heard that OTA 7 will bring Unity 8 and probably New MIR, in January. Great!

1 Like

Small update: there is a call for Anbox development testers in the UT forum


Ubuntu Touch OTA-5 succesfully upgraded from OTA-3, with the ubports-installer on Xubuntu, with sudo. :white_check_mark:

What works for me:

  • New browser: Morph. :earth_africa:
  • Dekko 2 community edition: sending and receiving mails (IMAP). :email:
  • Telegram, even for group messages. :arrow_forward:

What I’ll test later:

  • CardDAV/CalDAV sync. :calendar:
  • Linphone SIP VoIP calls :phone:
  • SSH connection with laptop :computer:
  • Libertine container :tophat:
  • Anbox ?..

What doesn’t work

  • Flash (new camera): known bug :flashlight:
1 Like

Just installed UT again on my device for testing and restored the contents of my home directory.
Wanted to try out anbox next, but the system.img only has 2GB which are almost full. I found some instructions how to enlarge that, but I’ll postpone that for later.

Edit: there is also some hint to clear the apt cache and set the reserved blocks in the image to 0. Then the space is sufficient.


First impression: anbox enabled (not actually running) already drains the battery a lot (phone is unresponsive and gets extremely hot).
So the most important command to learn was anbox-tool disable. :smiley:

1 Like

Now some real testing…

I pulled some APKs from my android phone using this description at Stack Overflow.

Then I pushed them to my ubuntu phone

adb root
adb push *.apk /home/phablet/anbox-data/data

Once the APKs where on the phone I installed them as described in the UBports anbox doc.

Refreshing the app scope made all the nice android app icons appear.

As I feared my bike sharing app doesn’t work. It uses Google maps but Google services are not available in anbox.

What does work is Spotify :slight_smile:


Would MicroG be available (now or in the future) ? It could do the trick :wink:

1 Like