English

UBPorts 16.04 updates + feature tests

Kernel flashing is definitely needed.

Recently I learned that when you do an OTA update, the anbox system is still there, i.e. you don’t need to run install_anbox.sh, just flash the kernel.

But I assume, that install_anbox.sh is still necessary when using the installer or the corresponding manual commands. Haven’t tried that yet.

1 Like

Thanks! That’s why it was crashing :wink:

Hi,
I have a question, and I think that I once read something about it on the forum, but I can’t find a detailed answer. Mostly to @Ingo, as you change OS quite often, but maybe @oli.sax also?
How do you backup and restore your OS when you make your tests? Let’s say someone is under the latest Fairphone Open OS or LineageOS (with or without microg), and wants to try UBports.
Can you describe all the steps you do (including the time it takes to do so)?

  1. Backup your phone (with TWRP or with Titanium or another method?)
  2. Install UBports
  3. Play around
  4. Restore your initial OS (how from UBports)?

Thanks in advance!

I have an FP2 dedicated for testing purposes so I don’t restore a previous OS.

What I do is backing up my ubports user data with rsync. And of course that can be reversed to restore the data (not the apps; still need to look into that) if I for example were to check out Sailfish and then return to UT.

Thanks for the answer! Yes, I would like to find a Fairphone or an old Nexus 5 or something similar to play around with UBports…

Isn’t it so that you need Android 6 to install Sailfish? I think you can’t even do it from Fairphone Open OS with Android 7. Going from UT to Sailfish would be a really long process then.

1 Like

When the phone is not at the exact required Android version it’s basically two or three additional steps in the installation sequence for Sailfish.
It doesn’t matter if you come from Fairphone (Open) OS, Lineage with or without microG or Ubports in that case. The steps/effort are the same.

Hi @chrisse !
Unlike @Ingo I have only one FP2, so I switch regularly from one OS to another :smiley:
Here are my steps:

  1. Backup my daily-driver-OS with TWRP.
  2. Transfer this backup to my laptop (very important if the installation process wipe the internal data!! - less important in case of OTA upgrades)
  3. Install SailfishOS/UbuntuTouch/LineageOS following the instructions
  4. Play with it…
  5. (UBports only) Reflash TWRP, because ubports-installer use their own recovery
  6. Backup the new-OS with TWRP
  7. Restore the TWRP backup of my daily-driver-OS

Each backup/restore with TWRP takes maximum 5 minutes.
Installation time depends of the OS (c.a. 10~30minutes).

2 Likes

How did you do this step, if I may ask? Is there any special approach to install TWRP while on UT?

No, it’s the simple approach :slight_smile:

  • adb reboot bootloader (or Power + Vol Down)
  • sudo fastboot flash recovery twrp-fp2.img
  • sudo fastboot reboot with Vol Up to go directly to recovery
2 Likes

Wow, so easy. Thank you.

And the image twrp-fp2.img I download from https://dl.twrp.me/FP2/ right?

Indeed ! :slight_smile:

Additionally and optionally, you can also fastboot flash splash splash.img an image from here, as UBports flash its own “powered by Ubuntu” starting screen :wink:

1 Like

TWRP takes care of the OS backup, allright.
But what do you do with your personal data in Internal Storage, which TWRP does not backup?
Do you use a patch (successfully)?

1 Like

Hello @AnotherElk !
Usually I do only OTA-updates without wiping the /data/storage, so I don’t backup it automatically.
When I have to wipe (e.g. fresh install), I connect the FP2 to the computer by USB in mode MTP then I copy/paste :slight_smile:

1 Like

In the Ubuntu forum someone had tried to install GAPPs in anbox. Which got me curious if my car sharing apps would work with the play services installed.

Unfortunately the opengapps repos on github are down at the moment. So I tried with some old GAPPs I still had on my laptop but it seems they are too old (Dec. 2017).

In case anyone is interested: here is more info

3 Likes

opengapps repos are back, so anyone who wants to try can do again :slight_smile:

1 Like

In the meantime I got a MS Display Adapter. Connecting to it works (not always on first try) and once it’s connected it doesn’t crash as with my BluRay player.

But unfortunately the screen is a little off, e.g. the settings app is moved to the left and part of the text is cut off.

1 Like

Ubuntu Touch OTA-8 is here !! To find out more on how to get OTA-8, its features and updates, click on the link below.

https://ubports.com/blog/ubports-blog-1/post/ubuntu-touch-ota-8-release-207

#UBports #UbuntuTouch #OTA8 #Blog

2 Likes

Solved that by installing the Wireless Display Adapter app from the windows store on my laptop. Then it was possible to change the overscan of the adapter, so that the entire desktop is now visible :slight_smile:

2 Likes