UBPorts 16.04 updates + feature tests


I just thought it would be so easy to get all the well known contacts into the Anbox. I tried using dropbox to transfer the file. Dropbox in Anbox is working fine, but after saving the file to my device, I can’t find the file at the device. Dropbox opened a different container comparing to the Anbox - file container . Now I will test Whatsapp typing the contacts again and it it works that won’t be bad at all.

I just tried: after the three commands I posted above (mkdir, chmod, mount) I could copy a VCF file from UT to AnboxHome and then import it in the android contacts app.

BTW, in the UT telegram group someone asked about spotify web player in the new morph browser. In the past I only tried the old one.

Doesn’t help much. It is possible to login at spotify.com but then opening the web player at open.spotify.com just looks the same as with the old browser: no access to your playlists, no way to actually play songs (it’s the same on Android BTW, so I guess mobile browsers are not supported, indepenent of the OS).

So it seems the only way to listen to Spotify on UT is with anbox + original android app (at the cost of a big battery drain).

Because I update so often, I became too lazy to manually do the aethercast fix to the apparmor settings each time and wrote a script for that: https://gist.github.com/Ingo-FP-Angel/905c5655511435b0ded2eb354dab538b

1 Like

You’re a script angel, @Ingo ! :smiley:

1 Like

7 posts were split to a new topic: State of the Ubports installer

UBports team published a really interesting new video: UBports: Life porting session of Halium on FP2

1 Like

I updated to OTA-7 with the custom script (UBports installer PR517 didn’t went to the end…)

My installed apps were all still there :slight_smile:

Then I tried re-installing anbox:

adb shell
chmod u+x install_anbox.sh

However, android apps are loading forever and phone is getting hot and hardly responsive…
@Ingo Is this the correct steps to restore anbox after an update? Is kernel flashing necessary or not?

1 Like

Kernel flashing is definitely needed.

Recently I learned that when you do an OTA update, the anbox system is still there, i.e. you don’t need to run install_anbox.sh, just flash the kernel.

But I assume, that install_anbox.sh is still necessary when using the installer or the corresponding manual commands. Haven’t tried that yet.

1 Like

Thanks! That’s why it was crashing :wink:

I have a question, and I think that I once read something about it on the forum, but I can’t find a detailed answer. Mostly to @Ingo, as you change OS quite often, but maybe @oli.sax also?
How do you backup and restore your OS when you make your tests? Let’s say someone is under the latest Fairphone Open OS or LineageOS (with or without microg), and wants to try UBports.
Can you describe all the steps you do (including the time it takes to do so)?

  1. Backup your phone (with TWRP or with Titanium or another method?)
  2. Install UBports
  3. Play around
  4. Restore your initial OS (how from UBports)?

Thanks in advance!

I have an FP2 dedicated for testing purposes so I don’t restore a previous OS.

What I do is backing up my ubports user data with rsync. And of course that can be reversed to restore the data (not the apps; still need to look into that) if I for example were to check out Sailfish and then return to UT.

Thanks for the answer! Yes, I would like to find a Fairphone or an old Nexus 5 or something similar to play around with UBports…

Isn’t it so that you need Android 6 to install Sailfish? I think you can’t even do it from Fairphone Open OS with Android 7. Going from UT to Sailfish would be a really long process then.

1 Like

When the phone is not at the exact required Android version it’s basically two or three additional steps in the installation sequence for Sailfish.
It doesn’t matter if you come from Fairphone (Open) OS, Lineage with or without microG or Ubports in that case. The steps/effort are the same.

Hi @chrisse !
Unlike @Ingo I have only one FP2, so I switch regularly from one OS to another :smiley:
Here are my steps:

  1. Backup my daily-driver-OS with TWRP.
  2. Transfer this backup to my laptop (very important if the installation process wipe the internal data!! - less important in case of OTA upgrades)
  3. Install SailfishOS/UbuntuTouch/LineageOS following the instructions
  4. Play with it…
  5. (UBports only) Reflash TWRP, because ubports-installer use their own recovery
  6. Backup the new-OS with TWRP
  7. Restore the TWRP backup of my daily-driver-OS

Each backup/restore with TWRP takes maximum 5 minutes.
Installation time depends of the OS (c.a. 10~30minutes).


How did you do this step, if I may ask? Is there any special approach to install TWRP while on UT?

No, it’s the simple approach :slight_smile:

  • adb reboot bootloader (or Power + Vol Down)
  • sudo fastboot flash recovery twrp-fp2.img
  • sudo fastboot reboot with Vol Up to go directly to recovery

Wow, so easy. Thank you.

And the image twrp-fp2.img I download from https://dl.twrp.me/FP2/ right?

Indeed ! :slight_smile: