English

UBPorts 15.04 updates + feature tests

Inspired by the similar topic about LineageOS I’d like to describe my experience with updates to Ubuntu Touch by UBPorts.

Installed via updater to 15.04 r19 (aka. OTA-3).

The following things work so far for me

  • call / be called
  • send SMS / receive SMS
  • internet via WiFi
  • internet via mobile network
  • location
  • main camera (new module)
  • selfie camera (new module)
    • but picture is upside down
  • USB connection to PC / MTP
  • USB OTG
  • alarm (incl. swiping it off)
  • screenshot (press + hold Vol-up and Vol-down)
  • bluetooth (speakers)

The following doesn’t work for me so far

  • Flash (new camera module; known issue)
  • Adding an owncloud account (in settings > accounts)
  • Spotify web player
    • looks like only the main content is displayed, no way to login
  • External monitor via WiFi direct (with a Samsung BD-J5500 Blu-Ray player)
    • screen does not update anymore after around one minute
    • small strip on the left of the screen is not visible

Things I haven’t found out yet

  • How to make a system backup
    • didn’t find something in the UBPorts recovery (which is needed for the updater to work properly)

Plus more stuff I haven’t tried yet…

4 Likes

Thx for this thread.
It’s a really good thing to give everyone interested in going that way an idea what to expect from firsthand experience.
I guess phonecalls and SMS work as well :wink:

1 Like

Yes they do, I just updated my post with a few more results :wink:

You are trying to add your owncloud to the calendar, right?
If doing that within the app doesn’t works, you can alternatively try the script installation !

In a way, yes. My goal is to use contacts and calendar from my owncloud server.

I tried it with the “Add account” from the settings, not from within the calendar app. But maybe both ways end up in the same UI, didn’t check yet.

Maybe I’ll first try to set up Let’s Encrypt on my server first. Finally I have a reason for actually doing that :slight_smile:
Then I’ll try your suggestion. Setting up ssh to the phone seems quite helpful in any case.

Small update. I set up ssh, but didn’t find time to follow the alternate script installation for owncloud.

Let’s Encrypt didn’t work, because I’m on some dyn DNS provider and the rate limit for that was already exceeded :wink:

In the meantime there was a small update to r20 which I successfully installed via updater. Didn’t do the full feature test. No obvious changes. But following some discussion in the UBports telegram group I found that the camera flash doesn’t work, so I added that to my initial post.

One thing I need to find out is how to do a full backup of my running 15.04, because I’d like to try 16.04, but only when I’m sure how to get back to a running system in case it doesn’t work well enough.

1 Like

I also give Ubport a tey. But I couldn’t find a way to sync contacts with my own CardDav server. I had also problem with terminal (someone should try to copy termux) and couldn’t use apt.

What I’ve done to do this is to backup my /home/phablet/ folder with rsync, assuming I have Linux and SSH set up and enabled on my phone :

  • rsync -rvlpogtD --delete --progress rsync://phablet@ipaddress/home/phablet/ /home/usernameoncomputer/ubuntu-touch/

What this command does is the following : it syncs your files on your computer, preserving time, date, groups, users that can use the files, deletes the previous versions of the same files (which performs an incremental backup then if files exist) and show you the backup progress. If you use this method, I strongly recommend to test it with a dry run before :

  • rsync -nrvlpogtD --delete --progress rsync://phablet@ipaddress/home/phablet/ /home/usernameoncomputer/ubuntu-touch/

The n option tells the program to do so.

If you have Windows, I think you could copy-paste all the files in the same folder (even the hidden files) on your computer. It contains all your configuration and userdata. What I had to do, after my backup was restored with the reverse operation (so you’ll need to remove all the files in the /home/phablet/ folder before copying if you’re on Windows), was to reinstall all apps in order to open them again, but the app configuration was still here. It was a little strange. And all my contacts, pictures and everything were here again.

Actually, if you’re on Windows, you can install and try Cygwin, which is a tool which provides you the opportunity to run Linux tools on your computer. You can then install rsync, using the Cygwin package search.

The reverse operation with rsync (copying your /home/phablet/ files on your phone again) would be :

  • rsync -rvlpogtD --delete --progress /home/usernameoncomputer/ubuntu-touch/ rsync://phablet@ipaddress/home/phablet/

You have to make your system image writable in order to do this : type sudo mount -o remount,rw / on a terminal on your phone (or via adb shell). By default, the system partition is read-only, so you can only use the Open Store to install and remove apps. However, using apt on your phone is not recommended, see here why : https://askubuntu.com/questions/600065/consequences-of-using-apt-get-in-ubuntu-touch.

Concerning the terminal, it’s the best I could test on a phone. The only thing I regret is the impossibility to scroll it in order to see and check the output of commands such as ls -lha. What problems did you run into with the terminal ?

2 Likes

Personally, this is my method:

  • I reinstall TWRP as the recovery (fastboot flash recovery twrp-3.2.1-0-FP2.img) then I do a full backup, and then copy the backup folder on my computer.
  • With this method, obviously the UBports-recovery is erased, and without it it’s not anymore possible to perform OTA updates (the new distro is downloaded, then it reboots to recovery and cannot perform the update from TWRP…), however to go from OTA-2 to OTA-3 I just reinstalled the stable image with ubports-installer (without wipe) and to my surprise my apps and my preferences survived :slight_smile:

Another option if you want to use TWRP without erasing the UBports-recovery, you can launch it without installing it with this tuto (fastboot boot twrp-3.2.0-0-FP2-signed.img). Note that you need a signed version of TWRP that can be downloaded here.

3 Likes

Just follow this wiki :slight_smile: : at this moment, calendar sync can be done within the Calendar app, but for contact syncing the script method is still required…

1 Like

… or (for reference just in case) can be made by yourself out of the original unsigned images.

On Linux/macOS …

… or Windows …

3 Likes

My flash also doesn’t work (new camera module), I was afraid that this new hardware is already broken but indeed this is only software issue! I reinstalled FPOpenOS just for testing and there the flash is working fine :slight_smile:

(Note that the new flash doesn’t work on my current version of LineageOS+MicroG, I’ll investigate that later… EDIT I reflashed modem.zip and now the flash is working on LineageOS)

1 Like

Thanks all for your input about backup. In fact I already know and use rsync for backup of one PC + raspi. :wink:

For the sake of learning I guess I’ll try out the option to use TWRP without installing and do the signing myself.

3 Likes

Didn’t do much with UT lately but tried using an external monitor via WiFi direct plus real keyboard connected via USB OTG.
On the other end there’s a Samsung BluRay player that supports screen mirroring.

Works only for a minute or so. Then the screen no longer updates.
Besides that the very left part of the virtual screen is not visible.

Would be pretty cool to get that working :wink:

You are lucky to have it for one minute, when I tried (with a hdmi dongle) it was all black :wink:
See discussion here : apparently not all screenmirroring dongles are compatible with UbuntuTouch, one that is fully compatible is the Microsoft dongle (sic ! )

1 Like

I have Ubuntu in my PC and Ubuntu Touch UBPorts in my tablet. Yesterday, after a problem with Sailfish, I have installed Ubuntu Touch in my FP2 too.

The installation is complicated, cause UBPorts-installer snap has an issue and stops working in the middle of the process. But finally I reached the installation with version 0.1.9 of UBPorts-installer.

Really awesome OS, runs almost perfect (well, there are some things that don’t go, but nothing important: flash, for example), and soon will arrive version 16.04 stable (now, release candidate is available for testing). I think this is my final goal in the search of a FP2 software, after FairphoneOS, FOpen and Sailfish.

2 Likes

This topic was automatically closed after 183 days. New replies are no longer allowed.