TWRP for Fairphone 3

oh great, thats even better, saves some space on my phone. i will read into it more. thanks for the help

I built a recovery image and since all those instructions and readmes were rather confusing, here is what I typed:

mkdir somefolder
cd somefolder
repo init --depth=1 -u git:// -b twrp-9.0
mkdir .repo/local_manifests/
tee .repo/local_manifests/FP3.xml << EOF
<?xml version="1.0" encoding="UTF-8"?>
<project name="chaosmaster/android_device_fairphone_fp3" path="device/fairphone/FP3" remote="github" revision="android-9.0" />
<project name="chaosmaster/android_kernel_fairphone_sdm632" path="kernel/fairphone/sdm632" remote="github" revision="twrp-9.0" />
repo sync

# fix all python2 scripts
mkdir ./bin
ln -s `which python2` ./bin/python
ln -s `which python2-config` ./bin/python-config
export PATH=./bin:$PATH

bash # only supports bash
. build/
export DTC_EXT=$PWD/prebuilts/misc/linux-x86/dtc/dtc
# will tell device not found, but still succeeds
lunch omni_fp3-eng
mka recoveryimage
fastboot boot out/target/product/FP3/recovery.img

Folder size is 30,4 GiB


Sorry, I know this is a n00b set of issues and question, but how would I go about using the zip installer.

In the past I have simply directly flashed TWRP to devices. I can see there have been issues with install and I don’t want to corrupt the device.

Many thanks

Then you don’t install it, you just boot it …

1 Like

Thanks, all sorted and installed

Hi there,

I’m not sure I would tell this here, if I wouldn’t, please tell me, I’ll delete my message. I’ve encountered a problem rooting my phone using twpr and magisck. May anyone help me ? I’ve created a new post in order to avoid “flooding” this one, here Problem with rooting FP3

And really sorry if my ask seems to you inappropriate.

I moved your post here.

Just to make sure, if I flashed your dump of A.0105 and was able to OTA to A.0110, I should stille be able to OTA, right?

I’m asking because my phone shows me that an update to A.0111 is avialable, but fails to install, but I haven’t modified my system since then.

What you see in the screenshot is not an error message, is there a button ‘Fortfahren’ which you can click?

Yes I can, but it simply results in an installation error:

After that, just flash the stock package again, this worked for me.

1 Like

This is going to format my userdata, right?

Edit: No it doesn’t. Found out by trying.

Could someone provide me with a full stock dump? The original link no longer works and I managed to trigger verity on my phone.

So, I’m on A0111 and rooted with Magisk. How does the update process look like for me? Can I just flash the A0111 image to restore stock boot, update, and then re-do the Magisk root procedure? Or do I have to be more careful and do something else before?

You should be able to directly do the OTA update. And you can even keep Magisk by just uninstalling it (restoring images, not full uninstall), then install the update normally but DO NOT REBOOT, then on Magisk, select “install in inactive slot (after OTA)”. This should work if you did not modify the system partition (mount read only).

Hey, thank you very much for your response. Sadly, I didn’t keep my system partition read only when rooting, so I guess flashing the stock sytem image is unavoidable for me.

This .zip is not directly flashable in TWRP, right? But can I unzip it and use its contents with the restore-option?

No, you can unzip it and flash the partitions with fastboot.
Here’s a script you can use or have a look at to see how it’s done …

Thank you very much, everything worked fine and I now have an even better understanding on how to flash around the FP3. Looking into that script was interesting, I didn’t realize that the FP3 has two slots for a bootloader.