English

TWRP for Fairphone 3

Ok, let’s try …

Step 0.
Don’t really install TWRP if you want to keep your Fairphone OS updating automatically. Installing TWRP means changing the boot partition, which will break OTA updates of Fairphone OS because the updating process checks whether the partitions are unchanged.
This is now different from how TWRP and OTA updates worked on the Fairphone 2.

Step 1.
Unlock the bootloader. This will also do a factory reset.
Heed the warning …

Step 2.
Instead of installing TWRP, just boot it with fastboot from a computer (fastboot is part of the Android SDK Platform Tools) …

You might also be the first to try this :wink:

Not (yet) "for dummies" https://forum.fairphone.com/t/fairphone-3-unlocking-possibly-without-factory-reset/57683
1 Like

I can understand you’re eager to get this tested, but I don’t know whether that’s such a good starting point “for dummies” :wink: .

1 Like

It does unlock, it remains to be tested, if it really doesn’t require a factory reset.
But maybe you’re right, this isn’t “for dummies”, I’ll edit my post.

1 Like

thanks both of you.
too bad twrp wont be like on fp2 with the updates, but i would take that. twrp was very helpful for my fp2 with the total system backup, which i dont have right now with the vanilla fp3 and if the Open OS will come for fp3 maybe it is the easiest way to install that, i guess. so i try to prepare it for that day. i have no problem with updating manually, i mostly do that anyway.
but your suggestion was not to intall it and instead unlocking bootloader and then use fastboot via a pc and boot twrp? did i get that right? so basically i use twrp on my pc for the smartphone and i can back up everything like that?

Not quite.
You connect your phone to your PC via USB, boot the phone into Fastboot Mode, and then you execute fastboot boot twrp.img (or whatever the filename is) in a command line on the PC.
This will then boot TWRP on the phone without you having to install it. Nothing will change on the phone, as long as you keep System read-only in TWRP (important!) …

You can then use TWRP on the phone to backup the partitions …

Here’s a little something in case you’re interested …

2 Likes

I just want to add, that if you intend to root or otherwise modify your system that will also result in OTAs failing.

1 Like

oh great, thats even better, saves some space on my phone. i will read into it more. thanks for the help

I built a recovery image and since all those instructions and readmes were rather confusing, here is what I typed:

mkdir somefolder
cd somefolder
repo init --depth=1 -u git://github.com/minimal-manifest-twrp/platform_manifest_twrp_omni.git -b twrp-9.0
mkdir .repo/local_manifests/
tee .repo/local_manifests/FP3.xml << EOF
<?xml version="1.0" encoding="UTF-8"?>
<manifest>
<project name="chaosmaster/android_device_fairphone_fp3" path="device/fairphone/FP3" remote="github" revision="android-9.0" />
<project name="chaosmaster/android_kernel_fairphone_sdm632" path="kernel/fairphone/sdm632" remote="github" revision="twrp-9.0" />
</manifest>
EOF
repo sync

# fix all python2 scripts
mkdir ./bin
ln -s `which python2` ./bin/python
ln -s `which python2-config` ./bin/python-config
export PATH=./bin:$PATH

bash # envsetup.sh only supports bash
. build/envsetup.sh
export ALLOW_MISSING_DEPENDENCIES=true
export DTC_EXT=$PWD/prebuilts/misc/linux-x86/dtc/dtc
# will tell device not found, but still succeeds
lunch omni_fp3-eng
mka recoveryimage
fastboot boot out/target/product/FP3/recovery.img

Folder size is 30,4 GiB

2 Likes

Sorry, I know this is a n00b set of issues and question, but how would I go about using the zip installer.

In the past I have simply directly flashed TWRP to devices. I can see there have been issues with install and I don’t want to corrupt the device.

Many thanks

Then you don’t install it, you just boot it …

1 Like

Thanks, all sorted and installed

Hi there,

I’m not sure I would tell this here, if I wouldn’t, please tell me, I’ll delete my message. I’ve encountered a problem rooting my phone using twpr and magisck. May anyone help me ? I’ve created a new post in order to avoid “flooding” this one, here Problem with rooting FP3

And really sorry if my ask seems to you inappropriate.

I moved your post here.

Just to make sure, if I flashed your dump of A.0105 and was able to OTA to A.0110, I should stille be able to OTA, right?

I’m asking because my phone shows me that an update to A.0111 is avialable, but fails to install, but I haven’t modified my system since then.

What you see in the screenshot is not an error message, is there a button ‘Fortfahren’ which you can click?

Yes I can, but it simply results in an installation error:

After that, just flash the stock package again, this worked for me.

1 Like

This is going to format my userdata, right?

Edit: No it doesn’t. Found out by trying.

Could someone provide me with a full stock dump? The original link no longer works and I managed to trigger verity on my phone.