English

TWRP for Fairphone 3

Unless Fairphone/Arima releases a signed firehose-programmer.
That would basically make it unbrickable through software.

2 Likes

Probably not likely to happen, is it? Is such a tool available for other phones?

Yes, some vendors like Xiaomi apparently release it.
I suppose if enough of you ask the support for it, maybe they’ll come forward.

1 Like

Ooooh … I want unbrickable :slight_smile: .

Would it be realistic to pursue this through Fairphone channels?
Could this have any advantages for them?
Could this have any effects they don’t want to have?

Or should we go with the recent fad and simply say “We want this NOW disregarding of how reality works, and if we don’t get this now YOU ARE NOT FAIR!” :slight_smile: ?

1 Like

This would be a software “repair yourself” tool. I think it is in their advantage to give it. But this is probably in Arima’s hands. Which will make it harder to get, such like the flashable image they wanted to provide.

1 Like

@lorahaspels: Could Fairphone please explore the possibility of releasing a signed firehose-programmer for the Fairphone 3?

“Unbrickable through software” sounds like at least the Fairphone support department could be in favour now that the custom ROM genie is out of the bottle :slight_smile:Edit: and people apparently brick their phones by flashing Fairphone Open OS for the Fairphone 2 to it … German example, French example.

@lorahaspels: While we’re at it … Is there an ETA for the OS image Fairphone wanted to release? …

“We are working towards making available: a flashable image for download and manual flash”

2 Likes

New TWRP release is up. This one fixes installing full stock ZIPs.
Thanks to @pigpig for testing!

5 Likes

Thanks ! I could flash the latest A110 stock ROM, but I was required to format the data partition (though the factory reset menu). Anyway, everything works now.

1 Like

Not sure, why a factory reset would be required.
I guess it depends on what state the system was in before flashing the 110 stock.
I wonder if switching slots before flashing 110 (when coming from 105) would not result in that.

There was no state at all, i was total anarchy… :smile:
I think that I wasn’t very careful, but thanks to the a/b system you can recover quite easily from your mistakes.

First of all MANY, MANY THANKS to all of those who work hard on making the FP3 a really fair and free phone! I’m not a programmer or developer and therefore very happy that you do that…

I have a question about how to backup in TWRP:
For a “normal” backup, just to be able to restore the status my phone has right now, which boxes do I have to check in TWRP? Is, for example, DTBO or Firmware required?
My phone is on TWRP 3.3.1-0_k4y0z-20200202-02, rooted with Magisk and I have installed a handful of apps from F-Droid. Most of g00gle stuff is deactivated.

Many thanks for your help!

2 Likes

2 Likes

Ah, thanks! I missed that among all the posts… didn’t see the wood for the trees.

What is TWRP? (fairphone-noob here)

TWRP is short for Team Win Recovery Project. It is an alternative (not supported by the phone vendor) recovery program available for a lot of phone models, now including the Fairphone 3 (albeit not officially on the TWRP website yet).

The Fairphone 3, much as any other Android phone, has a recovery program installed by default, but this stock recovery program is limited in what it allows you to do.

TWRP opens up more possibilities like easy backup and restore of some things on the phone and perhaps more importantly making installing so-called custom ROMs possible, and then still some more stuff.

Custom ROMs are alternative OSes for a phone. They can be other Android flavours (often built to include as little Google involvement as possible, which many users want) or even totally different OSes.

Please see twrp.me for general information and FAQ.

Running TWRP and custom ROMs has serious implications.
What’s more at the moment, on the Fairphone 3 TWRP and custom ROMs are still in an early stage, trying them out right now is still pioneering stuff and not for the faint of heart.

It can be fun, though, if you have a plan B or backup regarding your phone and your data :slight_smile: .

3 Likes

Make sure to have your tranquillization drops nearby :dizzy_face:

1 Like

tranquility drop: in order to install or even boot TWRP, you need to first unlock the bootloader. Doing so will wipe all your userdata. So unless you have it installed already or at least the bootloader already unlocked, using it for backup would be kinda pointless.

to go down that rabbit hole, you need to leave everything behind and do a factory reset of your phone. there is no way back. (well, there is. re-flash the phone to unmodified stock and relocking the bootloader, but guess what, this again wipes all the data :wink: )

5 Likes

:grinning: Thanks, corvuscorax! In an earlier stage, this indeed would have accelerated my pulse to 220, for sure. But I already unlocked the bootloader, have TWRP installed and the phone rooted.
Nevertheless: What you are saying can’t be pointed out often enough. In my mind, I see numerous guys desperately tapping on their phone… :cold_face:

1 Like

Hey Hey.
First of All: THANKS to all of you for working so hard on solutions for the FP3 and helping people with issues. I really appreciate this, as I intend to use the FP3 with LOS.
I’m following the discussions on this forum for a time now, unfortunately I also have to write a post now…

I have (at least) soft bricked my FP3: It only boots into fastboot mode, I can’t enter recovery or fastboot boot the TWRP img and I am afraid I made a stupid mistake.
I originally followed pigpig’s thread about how to flash ROMs with GSI but the system directly went into a reboot cycle.
With the intention to do the process again, I downloaded the Fairphone_FP3_8901.2.A.0105.20191217_12171325_user_release-keys ZIP and tried to install it with TWRP to get back to stock. Unfortunately stock also didn’t exceed the rebooting cycle.
Next I wiped the phone with all all options checked – I’m sorry fo my stupidity – to be able to make a “clean” install and got where I am now. I didn’t know this would break the whole thing and I thought I can then use TWRP to install things…

Following pigpigs instructions in this thread I tried to flash all the partitions from k4y0z stock zip manually. But imgs like product, vendor and system are missing. Would I have needed to make a back up of them myself? :-/

I hope anyone can help me. If you need more information, just ask. I didn’t want to flood the thread with details.

best, Janos

Did you try this ?