TWRP Experiences, Pros & Cons

Because I cannot mount /data.

I want to understand, but I have no clue, how.

/data is a partition and no matter what’s on that partition I can copy that partition as an image.

/The option to mount /data is IMHO for use with the filemanager.

Correct me, if you know better, but write the reason.

That would be my understanding as well, that for copying a partition it shouldn’t matter if it is encrypted or not. However, when trying to make a backup with TWRP, it fails with the error message, cannot mount /data.
So it seems that with the backup function it is not copying the partition as an image (like dd), but rather taking the files.
Anyhow, the result is that using the TWRP backup function does not work for the /data partition.

hmmm, interesting. I too thought of dd. OK, I’m still learning.

I just wanted to encrypt my datas (for trying, what happens), when I read in another thread, that once /data is encrypted, there is no way back. So I do not try, sorry.


On an old Samsung phone I had CWM installed and I had no problems making backups of an encrypted /data partition. It is a pity that this TWRP port (I am not sure if TWRP in general should be capable of this) cannot do it.

But for me personally it would be a no go to not have my data partition encrypted.

But also Titanium makes decent backups, takes less than 5 minutes to have the phone and all settings as before, after wiping the data partition.

As far as I know, on lollipop twrp can only backup encrypted partitions starting with version 3 dot something due to the design of the encryption Google choose. Will have to look it up where I read this. And yes, twrp backups are tar images


Why is Fairphone not listed in ?


Because it’s not officially endorsed by twrp, but “only” some version. FP would have to go through some steps to have it declared official

A question - probably a stupid one. I backed up with TWRP for the first time today - never know when it might come in useful. I found the backup folder with Amaze afterwards, and copied it to my SD card (which involved choosing root directory to grand write access - I followed the instructions the phone gave me - hope it wasn’t a mistake). Does this make any sense? Would it make sense to save a copy to my computer (in case I lose or break my phone)? How is this usually done (I suppose there is a simpler solution than copying stuff several times)?

It does make sense to store the backup to the SD card and to the computer also.
Before you make a backup with TWRP you can choose the backup location (internal/externalSD).
If you move the backup afterwards you could run into troubles when you want to restore again.

Got it - I hadn’t realized that I could change the destination for the backup. Thank you!

PS Can I delete the first backup and its copy now? By simply deleting the “backup” folder?

Does anyone else have problems using ADB in TWRP?

I just stumbled over this today. ADB works fine when running FPOOS. Then I went into TWRP. ADB devices finds the phone, but the computer suddenly does not have authorization to use ADB. After booting again into the OS, ADB works again as just fine.

So apparently I have no authorization to use ADB in TWRP, while it works fine in the OS.
Is it necessary to give an extra ADB authorization within TWRP?

The same here a few days ago:
No possibility to use e.g. ADB shell with TWRP. I wanted to modify some system files to gain write access on my external sd card (I finally tried it on the running OS and it fortunately worked).

I also got the message that an authorization is required. I wasn’t sure, but thought, that this should have been working some months ago.
My phone is encrypted and with FP Open OS 16.08 on it in comparison to the status a few months ago, where it wasn’t encrypted and ran an older version of the OS. Maybe one of this changes is the cause for it.

I then played around with some options and after activation of ADB sideload in TWRP at least this seemed to work. But I haven’t done more testing on it.

I also noticed that TWRP seems to forget settings everytime. It e.g. always asks if I want write access to the system partition and even if I choose “never ask again” it asks on every start of TWRP. And there is more: It also forgets other settings like vibration when typing, timezone, etc.

In the meantime I would also assume that the authorization problem is related to the encryption of /data, maybe also your other problems.

@Johannes pointed out this possibility. Looking at another post from him, where he describes the location of the authorization file, this also makes sense: The file is apparently stored somewhere in /data:

Unfortunately the version or the modification of TWRP which Fairphone uses cannot handle encrypted /data partitions (see also @lklauspost above) , which is very very annoying and significantly reduces the usefulness of TWRP. Actually it renders it rather pointless. Particularly that you can’t use ADB, as usually using ADB in recovery is an important way for troubleshooting.

Edit: @paulakreuzer, maybe this info can be added to the first post: The Fairphone port of TWRP that ships with Open OS is not able to deal with encrypted devices, which makes it impossible to make system backpups, and apparently also to use ADB in recovery.


Quite some time ago I also said, that TWRP needs working support for decryption ot /data in order to be better than e.g. my current ks01lte device, which also suffers from a working decryption of /data :-/.

I have a problem with TWRP which has to do with encryption. I’m using the exposed framework on my phone (especially for Xprivacy). Now, after every update I need to flash the framework again. Since the last update, however, I encrypted my phone and as you probably will expect (I hadn’t thought about that) I cannot flash any files on my phone anymore. Do you know if there is any other possibility to flash the framework (maybe outside TWRP)?

It should still be possible to install it via TWRP, but you need to have the files on a SD-card, and not on the internal memory.
I am actually considering to try installing stock recovery, since with TWRP on an encrypted device you can’t even ADB sideload. As sad as is sounds, but currently the stock recovery has more advantages on an encrypted device than TWRP (can’t believe I have to say that).

I already moved the files to my SD, yet it still doesn’t work (I can start the installation/flashing process this way, but it fails). I guess it’s because the data directory where the files have to be moved to is encrypted.

It basically should work, because the files are written to the /system partition, and not /data partition (which is the encrypted one). I have installed these files (openGAPPS, xposed) several times on an encrypted Open OS, so basically, it should work.