twrp-3.2.1-0-FP2.img not functional on my new Fairphone2

While trying to switch to LineageOS on my brand new FP2 following the instructions provided by LineageOS, I got stuck at step 6, the recovery software failing to appear, leaving a dead Fairphone robot on the screen whith the comment “no command” - no matter how I tried.

I then switched fron FPOS to FPoOS, just to be sure I could read instructions. That went without a hitch.
While unzipping the manual-switcher, I noticed that the package contains an images/recovery.img, which did seem to come up allright when booting the phone for recovery, after I had flashed it according to the instructions (step 5.) .

That file, images/recovery.img, appears to be a functional substitute for the failing “official” verwion.

It’s the one I’ll use when proceeding with the LineageOS installation.

My recollection of forum posts concerning this is as follows:

If you install TWRP into a Fairphone OS installation and reboot the phone into Fairphone OS, Fairphone OS will restore its own stock recovery.
If you install the current TWRP version into a Fairphone Open OS installation with its outdated TWRP version and reboot the phone into Fairphone Open OS, Fairphone Open OS will restore its own outdated TWRP version.

To make a new TWRP install resident on the phone, you have to reboot into TWRP right after installing it.

Alternative in any case: Booting the current TWRP version without flashing it …

https://forum.fairphone.com/t/howto-use-twrp-without-flashing-it-e-g-for-backup/23747?source_topic_id=39079
1 Like

That’s stock recovery.

Did you boot into recovery immediately after the fastboot installation, or did you do a normal boot first? If the first boot after flashing TWRP is a normal boot, it often gets overwritten by the stock recovery. If the first boot is directly into recovery, TWRP fill take measures to avoid that from happening, as mentioned on the TWRP install page:

Note many devices will replace your custom recovery automatically during first boot. To prevent this, use Google to find the proper key combo to enter recovery. After typing fastboot reboot, hold the key combo and boot to TWRP. Once TWRP is booted, TWRP will patch the stock ROM to prevent the stock ROM from replacing TWRP. If you don’t follow this step, you will have to repeat the install.

Anyway, as you’ve found out, installing Fairphone open also gets you TWRP, so you should be good to go.

EDIT: Apologies if this a double post - it seems the forum is behaving a bit strangely for me, as I’m now seeing posts with inconsistent time ordering as well as experiencing long loading times.

2 Likes

Thanks for answering.

After the flashing, the powerdown did not seem to work at all, and I (wrongly) assumed that a boot to recovery must happen from a powered-down state.

So I unlocked the phone by issuing a “fastboot continue”, which actually rebooted the FP2 into normal operations.

It’s all a bit of a black art, isn’t it ?

Right now, i am looking into taking contacts from a 12 year old Sharp mobile (in csv-format) into the android realm. If you have some advice, I take it gladly.

Regards.


Edit: I just checked again, and I cannot boot-to-recovery from a fastboot state using the vol- and power buttons.

That’s because Volume Up + Power/ reboot gives you the recovery, Volume Down + Power/ reboot gives you Fastboot mode.
When in fastboot mode, you can do “fastboot reboot recovery”.

If it was me, I would import the CSV data into Mozilla Thunderbird’s address book, and then sync this address book to the Android phone with MyPhoneExplorer (Windows only, though).

I tried that earlier too, but fastboot just spits out the --help message. I have a desktop running a current debian derivative, and my laptop runs voidlinux (libc-based).

Here the version information:
Desktop: fastboot version 1:7.0.0+r33-2
Laptop: fastboot version ecf5fd58a8f5-android

Both versions deny the “reboot recovery”. I have done most of the work using my laptop.

Since I am now able to boot-to-recovery, and I have proceeded to the options screen described in LineageOS’ installation guide, I am inclined to leave this TWRP and VOL+/Power topic sleeping, for now.

Thanks for the time and attention, and regards.

Hello Johannes,

That’s a paragraph that is missing from LineageOS’ installation
instructions,

  •        Type "Fastboot reboot" AND hold the VOL+ and PWR
    

buttons until the recovery software goes live*.

It seems I’m the only one acting without this piece of trivial
knowledge :wink:

Thanks again.

-rg-

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.