English

Turn off vibrate keypress - settings already adjusted!

Hi all.

I inherited a FP2 as my work phone. I would like it not to vibrate when I use the touchscreen, ever.

From reading similar posts, I confirm that the following has already been done (ie. that they are inactivated).
Settings > Sounds & Notifications and untick “Vibrate on touch”.
Settings > Language & Input > Android Keyboard (AOSP) > Preferences and untick “Vibrate on Keypress”.

They always were, since I received the phone. But the vibration continues. It does not vibrate when I select apps on the home screen or when I dial a number. However, it does in every other circumstance that I have so far found - text entry within apps, calendar, searching for contacts…
Is there any other way to turn this off?

Try switching the settings and back again and then reboot.
If that doesn’t help go to Settings > Apps > All > Settings and clear cache and data (you’ll lose your settings) then set those options back to not vibrate and reboot again.

Thanks for suggestions. I just tried the first option - hasn’t worked.

As a FP newbie, what kind of settings will be lost with clearing cache? Just so I can prepare myself for what happens. My life so far with this phone has not made me enamoured of it, so I’d prefer to expect the worst…

I don’t think a lot (I never actually did it myself). Worst case you’d have to enter all your Wifi keys again.

So, cleared cache and rebooted. Problem still persists… I really want to like this phone, but I am having difficulty…

1 Like

If you’ve already installed XPsosed and install GravityBox module there are lots of configuration settings which let you disable almost every kind of vibration feedback.

Riiiiiight. I understand technically what that sentence means, but it also demonstrates very nicely my limits on how much I care about vibration feedback - or about getting involved with a phone.
Many thanks for the suggestions, I appreciate them. However, I’d rather just have something where the standard settings work in the first place.
Looks like I’m just going to have to put up with a vibrate-y keypad :frowning:

Strange. I can imagine that some 3d party apps have their own vibration on tap options, but I never encountered such. You’re also not using a 3rd party keyboard app are you?

Nope, it’s the standard keyboard that comes with the factory version. Sigh.

Just got my new Fairphone and having same problem. This is really annoying… Turning off all key sounds and vibrations was the first thing I did when I turned on the phone (or tried to).

I’ve found the answer. Settings > language and input > android keyboard > preferences > vibrate on key press. Et voila.

3 Likes

That’s what I just guessed: a setting of the keyboard (not OS) :slight_smile:

Glad it worked for you! Not for me though…

There must be a non-obvious setting somewhere!

That would annoy the hell out of me. Tweet at them, asking for a replacement? Technically it’s faulty?

Imagine if you bought a fan that was permanently rotating. You’d want your money back!

Your phone “only” vibrates when typing on the keypad, right?
In that case it should be the tactile feedback setting found in the settings of the keypad (not system settings) often accessible via a cogwheel symbol on the keypad it self…
Have you tried an alternative keypad app?

2 Likes

That’ not it. See:

To be honest I have given up using the FP2. Between the buggy contacts handling, the vibrate thing, and the tendency to not let me answer the phone when it was charging, I couldn’t be bothered any more.
Mine was a work phone and it needed to be more reliable for that purpose.

Cheers for all the suggestions, though.

This tip worked on my FP2 fitted with android 6.0. Thanks!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.