Trying to push Lineage OS 15.1 zip file to FP2, but 'device unauthorized'

Dear everyone,
I’m a newbie in all this matter and I hope this is the right place to ask this question.

I want to install Lineage OS 15.1 on my new FP2, following these directions: https://wiki.lineageos.org/devices/FP2/install. Worked until incl. step 7.
But when I try to execute step 8, " Place the LineageOS .zip package … on the root of /sdcard", using adb, I get the error message:

“error: device unauthorized.
This adb server’s $ADB_VENDOR_KEYS is not set
Try ‘adb kill-server’ if that seems wrong.
Otherwise check for a confirmation dialog on your device.”

I might have forgotten to enable USB debugging :frowning: :sweat: If so, is there any workaround?
Thanks already in advance for your support.

The guide also says right after the ADB part … “You can use any method you are comfortable with.”

  • You have the phone connected via USB to a computer. Just boot into TWRP, and TWRP will offer Internal Storage and the SD card for file transfer via USB (might need MTP support from your computer’s OS).
  • If you have a fitting card reader or a microSD-USB adapter (always nice to have when owning cards), remove the SD card from the phone and use the card reader/adapter to transfer files to the card, then put the card back into the phone.

Thanks, @AnotherElk.
I tried option 2, transferring the zip file via SD card, seemed most practical. Only in TWRP > Install > Select Storage, it won’t let me select Micro SD (also says it has 0MB). So I suppose the FP2 doesn’t recognise the SD Card. Do I first have to reboot the FP2, with the card being inserted? Right into recovery mode again? (How?)
I don’t quite understand opt. nr. 1, sorry. Where does TWRP

and what is

?
Thanks again.

Nowadays some cards are formatted with the exFAT filesystem when you buy them. TWRP seemingly can’t handle that currently (but Android can, that’s why it often goes unnoticed).
Backup other important data from the card if there is any, and then use your computer to format the card with the FAT32 filesystem, if possible, and try again.

… means if your computer is prepared for it (e.g. Windows installs drivers for this when you connect the phone to it for the first time), you should be able to transfer files with your computer’s file explorer after booting TWRP.

MTP is just the term for the technology behind it, and TWRP is able to do it.

Micro SD card is formatted correctly (FAT32), but still won’t work.
I managed to transfer the installationzip file to the FP2 via Android File Transfer (thanks for the advice!).

Unfortunately, installation failed twice:

Checking for MD5 file…
Skipping MD5 check: no MD5 file found
Warning: No file_contexts
E3004: This package is for device: FP2; this device is .
E: unknown command [log]
Updater process ended with ERROR: 7 (when unchecking ‘zip signature verification’)

Zip signature verification failed! (with ‘zip sign. verif.’, apparently)

Now this is a different problem; but maybe you have another advice at hand? Or can refer me to another thread where this has been discussed already (otherwise I’ll search anew)?
Best regards!

In TWRP, check whether the card is enabled in “Mount”.

Which TWRP version are you using now? I seem to remember that older versions had this problem, make sure you use the latest one (currently 3.2.3-0) … https://twrp.me/fairphone/fairphone2.html .

2 Likes

Card isn’t enabled in “Mount”, but I also can’t enable it.

Just realised that it’s an older TWRP version indeed – even though I did install the newest one, but that was before wiping (could that be the reason?). If I download and install the newest version (again), do I also have to do the wiping again? In the guide, it says to do do a Wipe, Format Data and Advanced Wipe. Could that set it back to the originally installed TWRP version?

No.
But after installing a current TWRP version, you have to reboot right into it to let it make itself resident. Booting Fairphone OS or Fairphone Open OS instead right after installing will most probably result in the OS restoring its own recovery.

In the LineageOS install guide, this is “6. Now reboot into recovery to verify the installation”.

In the TWRP install guide, this is “Note many devices will replace your custom recovery automatically during first boot. To prevent this, use Google to find the proper key combo to enter recovery. After typing fastboot reboot, hold the key combo and boot to TWRP. Once TWRP is booted, TWRP will patch the stock ROM to prevent the stock ROM from replacing TWRP. If you don’t follow this step, you will have to repeat the install.”.

1 Like

Makes sense.

Can I do this also from TWRP > Reboot > Recovery, in spite of the warning that “no OS is installed”?

Might work.
But to be on the safe side, the default way to boot into recovery is to keep Volume + pressed while starting or rebooting the phone.

It doesn’t bother the recovery much whether an OS is installed or not, so you can ignore the warning.

2 Likes

It worked!
You guided me through perfectly, THANK YOU. :heart_eyes::smiling_face_with_three_hearts::kissing_heart:

P.S. in TWRP, I just chose Reboot > Power off; ignored the warning; and when restarting the phone, I kept the Vol + button pressed to ‘enter recovery’.

newest TWRP was installed > then could install Lineage OS 15.1 easily from the zip file. :tada:

4 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.