Troubles installing IodéOS on FP4

Hello !
I’ve just got my new FP4. As I was under FPOS on my old FP2 I really wanted to install something like IodéOS. But I’m a big newbie in all sort of code and stuff. I progressed slowly, read all the tutorials and help topics and reddit messages I couls for days but I can’t solve my problems. Here they are

  • I unlocked bootloader via the instruction on the fp page, multiple times, but everytime I reboot to bootloader it stays to “DEVICE STATE - locked”.
  • Even if the device is rightly recognized to use the adb command, it is not anymore as soon as it comes to the “fastboot” steps. The command get stuck on “waiting for any device” while one second earlier it was well detected. Basically I didn’t manage anything fastboot / flashing related.
  • When I got to the adb sideload step, it did work until 47% of the transfer, where each time I got : “E:footer is wrong
    Updage package verification took 0.0 s
    E:Signature verification failed
    E:error: 21”
    I saw many subject on this on the internet but can’t fix it anyway.

I’m loosing my mind on this but really don’t want to go back to google :confused: Can somebody help ?
I hope i’m understandable, I really don’t know the right words and the pro vocabulary :smiley:
Thankssss

With the instructions on the FP page you only create the possibility to unlock the bootloader: " Enable OEM unlock".
Unlocking the bootloader itself is done in bootmode with the command: “fastboot flashing unlock”.
Only then the bootloader is displayed as unlocked.

Only then will the following steps work:

Should that not be connected to the still locked bootloader you may need to update the fastboot driver for the FP4 on your PC. What OS do you use on your PC?

If you entered Bootmode you can check the device with: “fastboot devices”
If there is no device listed you have to try another cable or have to use another USB port.

overall, in bootmode the "fastboot … " commands are levant. In recovery mode, the “adb …” commands.

Ok , I do understand better, thanks. Still, when I execut this command, it stays on “waiting for any device”…

I’m using Windows 10 for this. I installed the all thing a few ays ago so I thought it was the good driver and the latest version but maybe not, I’m gonna check this

Indeed “fastboot devices” get to nothing. I’m using the “original” cable tho… Thanks for your help anyway.

Omg got ittttt thanks to @yvmuell it was indeed a driver I did not use properly.
Thank you ALL SO MUCH for your help !

In case it can be useful for others, here is what helped me

  1. download the Google USB Driver zip file.
  2. Extract the downloaded file.
  3. Now, press the Windows + X key simultaneously, and from the context menu, choose Device Manager.
  4. Expand the portable devices option.
  5. Right-click on the smartphone name you have connected with the computer using a USB cable, and choose the Update driver option.
  6. In the following window, choose the Browse my computer for drivers option.
  7. Click on Let me pick from a list of available drivers on my computer .
  8. Click on Have Disk option.
  9. In the prompt that pops up, choose the Browse option.
  10. Select, and open the android_winusb.inf file available in the Google USB folder.
  11. Now, click on OK.
  12. Select the Android bootloader interface from the following window and click on the next option.
  13. Choose the Install option from the prompt that pops up.
  14. That’s it. You have finally installed Android bootloader interface drivers on your system.
  15. Now you can see the Android Bootloader Interface option under the Android Device option.
  16. Now open Command Prompt in administrator mode on your Windows PC.
  17. Type the below-mentioned command and press Enter.

fastboot devices

That’s it. This time, Fastboot will work on your system and detect your Android smartphone.

1 Like