Trouble with Google Play Services after manual update via apk


I have just installed an update for Google Play Services via the app “APKUpdater”. Unfortunately, it seems to have been the wrong apk. A notification pops up continously - literally every few seconds - that Google Play Services has repeatedly been closed. It is not a “normal” notification, but pops up in the middle of the screen and I cannot make it go away. I have found the advide to reset Google Play Services to factory settings, but the reset is not possible. I have also tried deactivating “Find my device”, but I cannot access the option because once I try, the notification regarding Play Services pops up once a second or more and I cannot do anything. I also tried deinstalling Google Play Services via ADB, but that failed as well. I really do not know what to do anymore. It is hardly possible to use the phone. I also really would like to avoid a complete factory reset because I would lose all my apps, settings etc.
Many thanks in advance for any helpful advice.

Similar problem for me here as well, except I didn’t install anything special. But from this evening I’ve received several notifications of apps systematically crashing because using Google Play services…

Same problem as well but, like Antoine, I didn’t install or changed everything. Started this morning. Apps have been crashing one after the other and, every time, I get either " [name of the app] crashed systematically" or “Google Play service crashed systematically”…

Using FP3+, with 0084 system update

1 Like

From what I read elsewhere, this is most likely also a problem with the system app “Android System WebView”. There should be an update for this app available now to solve the problems. Only in case you cannot get ahold of the latest update, there is a workaround here:


Deinstalling Android System WebView did not solve the problem for me. Since the problem occured immediately after installing the apk-update for Google Play Services, I strongly suspect this to be the cause of the problem. I have read of other Android users experiencing the same problem in the past and tried some of the proposed solutions (as described in my first post above), but to no avail.
Just to clarify: I do not experience apps crashing, only the mid-screen notification on Google Play Services repeatedly having been closed. These notifications increase in frequency (once per second!) when I try to change the security settings, including deactivating “Find my device” (which is therefore not possible).

The version of Google Play Services I installed was this one:
And in “Settings”, it says the version now installed is 21.09.15 (00300-361652764)

Nochmal eine kurze Problembeschreibung auf deutsch, weil ich vllt. im Englischen falsche Begriffe gewählt haben könnte: Gestern habe ich via APKMirror ein Update für die Google-Play-Dienste installiert, das offenbar fehlerhaft war. Wahrscheinlich hat meine Updater-App (APKUpdater) mich auf die falsche Version verwiesen.
Seitdem erscheint ständig mittig auf dem Bildschirm die Meldung “Google Play Dienste wird wiederholt beendet” mit den Auswahlmöglichkeiten “App-Informationen” und “App schließen”. Die Meldung lässt sich nicht deaktivieren. Außerdem funktionieren diverse andere Apps nicht mehr richtig und die Systemeinstellungen lassen sich an manchen Stellen nicht mehr ändern. Installiert habe ich folgende Version:
Angezeigt wird mir, es sei folgende Version installiert: 21.09.15 (00300-361652764)
Auf meinem Handy ist als Betriebssystem Fairphone OS 21.01.0-rel.1 installiert. Das entspricht im Wesentlichen Android 9. Weitere Infos zum Gerät: dpi 440, P (9), ARMv7 Procesor rev1 (v7l), Anleitungssets armeabi-v7a, armeabi
Bis auf die dpi-Angabe scheint also eigentlich bei dem Update alles zu passen.
Bereits versucht habe ich:

  • Deaktivieren der Google Play Dienste (nicht auswählbar, anders als früher)
  • Zurücksetzen von Google Play Diensten auf Werkszustand (fehlgeschlagen)
  • Deaktivieren von “Finde mein Gerät” (Zugriff auf die Funktion nicht möglich, weil die Fehlermeldung dann beginnt, im Sekundentakt aufzutauchen)
  • Deinstallieren von Google Play Diensten via ADB (fehlgeschlagen)
  • Deinstallieren von Google Framework Diensten via ADB (erfolgreich, aber hat nichts genützt)
    Ich möchte dringend vermeiden, das gesamte Gerät auf Werkseinstellungen zurückzusetzen.

That worked for me on the regular FP Android 7.1 and all available updates installed.


Update on the situation : it appears Google is currently suffering a major bug, It’s not the phone, it’s the part of Google Play Services that allows for an app to open a page from internet. :sweat: :nerd_face:

1 Like

Still there has to be some way to get rid of the update again? Just to clarify: My problem does not involve Chrome or Mail apps. I am not even using either of them, nor do I use Google Play store. And my problem did not start this morning, but yesterday evening at about 21.30 German time, directly after I installed the update for Google Play Services. So there might be two different problems around here.

It worked for me, thanks a lot !

1 Like

The problem wasn’t with Android System WebView in my case, unfortunately. Deinstalled it and problem still continues. So I strongly suspect there to be two different problems conflated here. My problem was with an apk-installed update of Google Play Services.

Doesn’t anyone have an idea what I can do? I would be really, really grateful.

If the problem is Apps not working, uninstalling Android System WebView might not always help, but perhaps contribute …

Did you try installing the supposedly fixed version?

1 Like

The only thing that worked was a factory reset, unfortunately. The phone is now more or less back to what it was, though re-installing all the apps and doing the settings was quite a lot of work. But now the problem with Google Play Services is gone. I just hope it will not happen again.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.