Trouble w/ Android 6.01., Fairphone Open OS and Gapps -> can't verify Google account

Hi everybody,

I spent some days to update my FP2 to Android 6.0.1 with some Gapps but now I’m out of ideas. Maybe you can help…

Setup: encrypted (!) FP2 with Android 6.0.1

-> long story short: I updated from Android 5 and flashed Gapps from The Open Gapps project via ADB sideload.
Tried alos once with fastboot but it wouldn’t connect (neither on my Linux nor the Windows 10 machine).
It took me several tries to overcome all the “xxx has been stopped” messages and so on.
Basically I managed to get it somehow working with changing permissions after flashing the Gapps stuff.
I used a script some friendly user shared to set permissions for all the Gapps. Worked so far …

But now I’m stuck because whenever I access the google play store I get the meassage “your account needs to be verified, please login to your Google account”. Fairly easy I thought and opened up the google login page on my computer. Tried to login and goole tells me to take the phone and generate a security verifying key.

And here it goes wrong: I always get “while creating the key an error occured. Try again later”. So I end up not being able to login to my google account plus don’t have access to google play store and my purchases there.

Every once in a while there’s the “google play services has been stopped” message, but only very randomly.
Threema push service doesn’t work since I would need to reinstall it from play store but cannot without having access to my google account.

I tested several packages of Gapps (mini, micro, full and even stock), all the same issue.

Can anyone shed some light on the things? Or even show me a way back to stock OS if it can’t be fixed because I need to have that Threema and another app running which unfortunately depend on google services?

The first time I ever ran into so much trouble when updating the FP2 with Gapps. Don’t know whether the Gapps packages are to blame. Is there another way to install google services? Maybe a different package provider?

Any help appreciated,


Fairphone Open OS comes with TWRP as recovery (press Volume Up while turning on the phone or while rebooting), and with TWRP you can easily install ZIP (e.g. Open GApps) and IMG files. The files need to be somewhere TWRP can reach, a Micro SD card in the phone is easier to navigate than internal storage.

I always installed Open GApps pico (minimal package for getting access to the Play Store) via TWRP and never had any problem.

Sorry, I forgot to mention it: I also tried that and it left me with the same state. Google play services do not work correctly and I don’t know why.

I also erased cache,data and updates oft both Google play store and Google play services… No success either.

Sounds like there really is something wrong with the installation.
I would make a backup of my data, wipe the phone and make a clean install from scratch.
If you are interested …

… At the step in TWRP which installs the OTA file you could also add the Open GApps ZIP of your choice.

1 Like

Hi @AnotherElk,

I’d really like to do it froms scratch but TWRP wouldn’t allow me to wipe /data. Any suggestions?

GuBi .

Inside the TWRP “Wipe” menu, there is a Button "Format Data"
this should/could work, I used it once to get rid of encryption

1 Like

Hi everybody,

I finally managed to have it working.

Seems like the whole problem occured because /data couldn’t be accessed due to encryption.

What I finally did:

  • backup of data
  • used TWRP to “format data” as wipe data wouldn’t work
  • installed FP Open OS via TWRP
  • flashed Gapps with TWRP
  • encrypted the phone again

Thanks to everybody who helped here!!

Still that leaves me with some doubts: who would actually encrypt any device if updating to a newer OS
means to reinstall everything from scratch? Is there any easy way to update an encrypted phone’s OS?
Does the installer really need to have access to the encrypted stuff?

I mean, for me it’s ok that way… but if we want to have people care about these things (encryption of hard drives, email
correspodence, web traffic,…) we should ensure that it’s as easy to use as possible. Or is it just me? And I possibly don’t know how to do it correctly in the first place…

Anyways, thanks again!


This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.