Tried to install LineageOS, failed

Hey :slight_smile:
I tried to install LOS, since I have some strange OpenOS bugs and to get rid of them I’d have to completley wipe the phone and perform a new install, so I thought if I have to do this anyway, then I can also go to LOS (completely wiping the phone was the reason I didn’t do it before).
So I backed everything up with TWRP and Titanium and followed these instructions. After I booted into LOS and tried to recover my data from Titanium, I realised that I didn’t copy the backup folder from my internal storage to my PC, so I used my TWRP backup to revert to OpenOS, backed up via Titanium again, copied the files and installed LOS again, only this time no matter what I try I get stuck at the curved cyan line with circles going across.
I already wiped everything 3 times, installed TWRP again and reinstalled LOS a couple of times via adb sideload as well as installing the zip via TWRP, but it didn’t work. What did I do wrong?

For how long? It might take a while …

And formatted data?

After I left it for 15-20 minutes I force restarded it.

I wiped everything except the microSD card because that’s where my backups are on.

Ok, that’s too long :wink: .

Wiping is not formatting. I refer to the guide, “Installing LineageOS from recovery”, point 5 … “Now tap Format Data and continue with the formatting process.”

Looking at your trouble, it might be a good idea to actually format the other partitions, too (and not your Micro SD card, of course):
Wipe - Advanced Wipe - (select partition) - Repair or Change File System - Change File System - EXT4 - Swipe to Change

1 Like

Hi, maybe you should try this:
Power off, take battery out, wait 5 minutes, try again
this help me, and some outer user once with some strange boot behavior…

1 Like

I keep learning that I actually hardly know anything about this phone.

Thank you. Now, hopefully my Titanium backup I made on OpenOS works on LOS…

1 Like

What is the reason for not using TWRP to backup your phone?

TWRP doesn’t backup everything, and most importantly not user data in Internal Storage.

So TWRP is great for a backup of the OS, but you have to take additional measures to backup all of your personal data.


@AnotherElk Thank you for the explanation! I was not aware of that even though I’ve used the backup function in TWRP a lot.

Restoring the Titatium Backup worked, but a couple of apps instantly crash when I try to open them (e.g. Signal) and my SMS database is gone. I’m trying to restore the data partition from my TWRP backup now, hoping that that’ll work.
Moreover, some apps that worked on OpenOS Marshmallow didn’t work on OpenOS Nougat anymore and they still don’t work with LOS. How can this be?

So … Some Apps that worked on Android 6 (Marshmallow) didn’t work on Android 7 (Nougat) anymore and they still don’t work with Android 8 (Oreo = LineageOS 15.1).

Without anything more to go on, I’ll blame the Apps :wink: .
Can you list the Apps for comparison?

The apps are Lovoo (a dating app, and I honestly don’t care about it, anyway feel free to make stupid comments) and the timetable app for my university called “ÖH FHOOE” as far as I remember, which is the greater issue since the timetable website doesn’t have a mobile version and is therefore a pain to use on a phone.
Also, restoring the data partition causes the phone to get stuck in the circle-curve again, so I need to go back to OpenOS again and back everything up correctly now to get it working.

I love overcompliating annoying things that could’ve been done much easier if I would be able to think before I click :roll_eyes:

I use MyPhoneExplorer to easily sync the phone’s messages to my computer, or back to the phone if needed.
And I use it to sync my contacts, too (with Thunderbird) … and the calendar … and caller lists … and pictures … and additionally the whole Internal Storage for safety’s sake :slight_smile: .

1 Like

I also sync my contacts via DAVx5 (btw I deleted my entrie contact list while setting this up and I had to re-enter every contact manually with the names that Signal and QKSMS thankfully kept displaying in the conversation list). I’m going to make a backup via Signal itself to restore it on LOS (maybe the upgrade makes the Titanium backup unreadable idk) and via SMS Backup and Restore for my SMS. I hope that I don’t miss anything, because I really couldn’t handle reverting the upgrade for a third time without exploding and spitting fire.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.