Tried installing Sailfish OS, now softbricked without OS

Hi all :smiley:
I’ve just bought the FP2 and wanted to install Sailfish OS. Event though inexperienced, I tried doing everything on my own as it seemed pretty simple. The FP2 got softbricked and is now without OS. I am getting lost on what I should do and think asking for help at this point is the best thing to do. I have found no similar post on this forum so here’s what I did :

I first switched to Open OS and then I followed this tutorial link that I found on the forum.

I downloaded the .zip ( and copied it to an sd card which I put in the FP2.

I boot in recovery mode to TWRP, and installed the .zip (I disabled zip signature verification as indicated in the tutorial)
All seems to have worked fine so I reboot.

After the fairphone screen, it gets stuck on a blue screen. I concluded that the FP2 was softbricked so I looked for help on that. I found this on xda-developers.

I downloaded and Android SDK, followed the steps and when I tried “ADB Sideload” on TWRP, it stopped and displayed “error:7”.

At this point, I find unuseful help for other phones/ROMs and don’t really know what to do anymore so in TWRP, I go to “Advanced Wipe” and wiped “System”.

Now I can still access TWRP but whatever I do, it warns me that I have no OS and I don’t know what to do next.

I put the part in bold that explains why this file won’t work for you if you have no OS installed.

Here is what you should do:

  • get an SD card if you don’t have any
  • download the following files from here
    • FP2 - Update file of Fairphone OS 1.13.0 (~600MB)
    • FP2 - Update file of Fairphone OS 18.02.0 from 1.13.0 (Android 5.1) (~500MB)
    • FP2 - Update file of Fairphone OS 18.02.0 from 18.01.1 (~50MB)
  • and put them on your SD card
  • boot into TWRP and flash those files in the right order without rebooting in between (since you just bought the FP2 it has a new screen and the new screen doesn’t work with older OS versions, so only boot to system once you are on a recent version)
  • (optional) wait for an update to Sailfish as it doesn’t work with the new screen either (yet)
  • (optional) once this has been fixed try again, with help from the forum. :slight_smile:

To add to @paulakreuzer’s comments: This is the currently expected behaviour on new FP2s, as the new screen isn’t compatible with most of the system images currently available. Other than missing that small detail, you’ve probably done all the steps correctly - so don’t let that discourage you from trying again when the images are updated to work with the newer screens!

The going back to Fairphone OS thing is just confusing, as Fairphone recently changed which files they provide. If the approach that is suggested above doesn’t work, there is an alternative route using fastboot.


Thanks a lot for your answers ! I’m currently downloading the files.
@paulakreuzer I don’t mean to be rude but are you certain I need the third file ?


Last time I soft-bricked my FP2 was also after trying to install SailfishOS.

I restored the system by following the steps in

Basically you download and extract a single ZIP file and use the correct batch script (for Windows, Linux, macOS) to install FP OS again. Really simple.

Just in case the steps paula provided do not work. :wink:


Oh yeah, no you don’t. My bad.


I tried flashing the first file through “Install” and selected “” but it failed :
It outputed :

"Checking for MD5 file…
Skipping MD5 check: no MD5 file found
Can’t install this package (Thu Mar 2 11:10:24 SGT 2017) over newer build (Thu Jan 18 17:18:16 GMT 2018)
Updater process ended with ERROR: 7
Error installing zip file ‘/external_sd/’

Maybe flashing via #dic:fastboot will work as @Johannes suggested.
You could also try to wipe the system via TWRP and then try again. Just make sure you don’t wipe recovery.

1 Like

Just a quick note that the fastboot method is the same principle as the approach linked to by @Ingo above, so you’re best off following that.


Ok so… now when unplugged it doesn’t want to boot in any mode

Assuming you followed the instructions that Ingo linked to, were there any messages on the computer when you flashed the images?

Validating files…
Validation complete

and then it waited for very long
The FP was in fastboot but could only be in fastboot while staying plugged :confused:

Fastboot is only useful when plugged, as this mode is non-interactive except for the transfer of (system) files.

Is your computer running linux or windows? On linux you may need to run the script with “sudo”…

1 Like

Linux (Fedora)

I’ll try that thanks :slight_smile:

The no turning on problem seems to be caused by the fact that the phone charges extremely slowly and runs quickly out of battery…

And quite obviously but I mention it anyway : first install the adb/fastboot tools (for ubuntu : sudo apt-get install android-tools-adb android-tools-fastboot)
You can test if fastboot is recognising your device-in-fastboot-mode by typing sudo fastboot devices.

1 Like

Question for @mal : As Enz0 is not the first one to try to install SailfishOS on a new-screen-FP2 leading to the bluescreen bug, could you add a red warning message on the wiki page e.g. “Do not try the current version if you have a FP2 from summer 2017 or newer, or if the screen was recently changed” ? Thanks for your work :slight_smile: !


@oli.sax It worked only with sudo, thanks a lot ^^


Thanks everyone ! :grinning:

1 Like

Hi, sorry for not adding a proper note about the hardware support to the wiki page, I added it now. Also the next release will be available soon, I have everything ready except some issues getting the correct packages included in the image or during update because of some issues in OBS build system (again). I’ll try to hack around the issue so I can finally get the new release out, hopefully next release won’t take this long :slight_smile: