Transferring data to my new FP3 from my FP2

Hello all,
I just got a (used) FP3. Glad about it, because my FP2 didn’t work very properly anymore.
But now I am looking for a way to transfer my data and apps and settings to the new phone - without gogol, of course. I installed already /e/ on it (I have it on the FP2, too).

I was thinking about the migrate helper which seems a very cool tool to migrate ROMs. I didn’t check it completely, but I guess I need root and/or twrp in order to use it… Which is not great, from what I am understanding for the FP3:

Just to be clear for people reading along … you can’t “flash” TWRP on the Fairphone 3 .
You just fastboot boot it … or, if you really want to, you can install it once TWRP is booted, which embeds it into the boot partition using an install script, which breaks OTA updates because the boot partition gets changed this way and the updater checks for such partition changes and doesn’t update in this case. (From this post )

Or can I just boot twrp and use it without installing it (fastboot boot twrp.img ?)

So I will check migrate helper more closely, but does anyone have more ideas on how to transfer to a new phone without twrp?

In short without root I think there is nothing that will backup and restore the whole system, we have many topics about this here in the Forum, so maybe you want to search a bit. Booting TWRP instead of flashing it, still gives you the full funcionality, so would not see that as an issue. #twrpwoflashing

Having recently switched from FP2 to FP3 without root, I can say it needs a bit time, but not sure if more time then to try to understand root options😉


If you want to use it just for migrating, both ways (just booting it or installing it) will work with /e/OS. If installed (= embedded into the boot partition) TWRP will simply get overwritten next time you update /e/OS, because /e/OS will then restore its own boot partition including its own /e/OS recovery.

SAI for exporting and installing all your important App APKs (because some Apps have split APKs, which some other APK exporters can’t handle correctly), and MyPhoneExplorer for transferring contacts, SMS, calendar, pictures, the whole Internal Storage if you like (HowTo and FAQ, and here’s how to transfer SMS as it’s not very intuitive).


Something maybe interesting mentioned in another thread


Well, the problem is, you can’t boot into TWRP without unlocking the bootloader (on a FP3). And relocking would wipe the phone. So it’s a nonsense to restore your data with an unlocked bootloader, because locking it would wipe everything you restored beforehand…

I guess I need to check @AnotherElk 's propositions.


Which would be no problem before migrating.

If leaving the bootloader unlocked is not an option, using TWRP is out of the picture.

Question of priorities.
After assessing the security risk involved for my security requirements and my personal circumstances I decided to run an unlocked bootloader. This gives me TWRP with all its glory (data decryption is supported on the Fairphone 3).

1 Like

Or do you know if this solution with adb root would work? (Found in this thread)

1 Like

It’s at least worth a try, since /e/OS indeed lets you enable Rooted debugging in the Developer options (not a given across OSes), so adb root should work.
I didn’t do much this way myself.


Well, I couldn’t adb pull any files from my FP2… So that solution didn’t even work for a backup… :confused:

I just had a look on my Fairphone 2 … I can adb pull a random file which I can’t pull without adb root.
Which steps did you take, and what is the result? Any error message?

In fact, it seemed to work, only that the pulled folder was 0 and contained no files. I did exactly what was written in the guide. (Root debugging enabled).

Now I found a good way to migrate data to another phone. After the tries with migrate helper and adb pull didn’t work, and Seedvault couldn’t be restored either, I had to look for a backup solution with root. So I rooted my FP3 with magisk on the /e/ recovery like described here.
Then I installed OandBackupX from f-droid (now NeoBackup). And I transferred the backup file to my new FP3, and did a recovery with OABX there. It worked just like a charm! Just two apps made problems. Matrix Schildichat I couldn’t transfer data. And Signal has now a migrate option in its settings, that works pretty well too.
Neobackup (and it’s predecessor) can also make scheduled backups, even on sd-cards. Pretty good stuff!

Minus points: You need root. And my bootloader is still unlocked. But such a good backup solution may be worth rooting.

1 Like

Ok, so … Fairphone 2, /e/OS 0.22-q-20220228166118-dev-FP2, Android-Debugging enabled, Root-Debugging enabled … computer side is Windows 10 Pro 21H2 …

adb pull -a data/user/0 … creates directory 0 with 154 MB of data for me, along with a few warnings in cmd about stat failed for some lib directories along the way … and 1 path name apparently being too long for NTFS on the computer side.

adb pull -a data/app … creates directory app with 956 MB of data for me, says data/app/: 198 files pulled, 0 skipped. 24.9 MB/s (1003238269 bytes in 38.461s)

adb pull -a mnt/sdcard… creates directory sdcard with 10.2 GB of data for me, says mnt/sdcard/: 4488 files pulled, 0 skipped. 20.9 MB/s (11031943803 bytes in 504.110s)

1 Like

Oh man, I will retry. That would be a solution without root and unlocked bootloader!

1 Like

Worth to mention that my SD card is external, so ADB wouldn’t be needed, I just could transfer the card.

And perhaps you could do adb --version.
I’m using the Android SDK Platform Tools, not the most recent ones though …

Android Debug Bridge version 1.0.41
Version 31.0.3-7562133
Installed as C:\platform-tools\adb.exe
1 Like

So I tried it again, and… it worked! With Root debugging, and then as written in the guide. I had several warnings for mostly system apps, but my folders are now full of files. Seems that I skipped something, perhaps adb root.
Now I just have to test the restore action! Very interesting!


Ok, after having migrated to my FP3 with OandBackupX, I was free to play around with my FP2. I pulled everything with the adb root commands, then reset it to factory settings (by wiping data, cache and dalvik over TWRP), and tried to install the backup with adb root, as described in the article linked above. And… it works!! I have all apps back, most of them with the settings from before. So it looks like this is a pretty good solution for migrating/backing up phones which run /e/ OS (on which one can enable not only USB Debugging but also Rooted debugging!). And a solution which don’t need an unlocked bootloader and root.
For the time being, I will leave my FP3 as it is, I played enough around with it, now I want to use it. Perhaps later I will make a backup with this method, deroot and lock the bootloader, and play the backup back. Then I will have a FP3 with all my data and a locked bootloader.

I hope this thread helps others too!