Transfering files to FP3 from Linux

So I had this issue with a FP2 and upgraded to the FP3 which has the same issue.

I’ve an SD card in the FP2 & FP3 which is formatted for phone use, so the phone’s OS can use it for Apps and APP Data. So when I plug the phone into my laptop and enable file transfer to the phone my Linux laptop sits there spinning trying to mount the phone’s media but times out after an age.

Why does the FairPhone not implement file transfer for a Linux Laptop. When was this changed and why? A brand new FP3 is pretty useless to me if I can’t transfer files to it.

As Android 10 has a bug, it’s not recommended to use a SD card as internal memory. It will lead to others problems soon.
Which protocol did you choose to transfer data on the FP3?

1 Like

OOps wasn’t aware of that will reformat again.

Protocol is vanilla just plain old file transfer

I’m using my FP3 with with opensuse and KDE as Desktop environment and file transfer works as expected.

  • plug in the FP3 with a data cable
  • select ‘file transfer’ on the phone in the USB settings notification
  • click on “open in filemanager” in the notification that appears on the computer; there I can see both the internal memory of the FP3 as well as my SD card (formatted as mobile storage)
1 Like

Reformat the SD Card for portable storage and same problem still exists.

Why do people not get their Linux installations in order for Android file transfer.
Same sample data, just as valid a deduction out of it :wink: .


How about giving some more details like which distro and desktop environment you are using and how you try to mount the phone?

And one more basic question: are you sure your USB cable allows data transfer? If you ordered the Fairphone cable the answer would be “yes” but there are plenty of cables around that only do charging.


OpenSuse Tumbleweed: Received an error message when trying to connect to the FP3 filesystem

"Unable to access “FP3” Message recipient disconnectedfrom message bus without replying’

Ubuntu 20.04 Fails without any error message.

Windows works

Desktop environment should effect how the phone works? Surely this is a low level comms protocol defined but the USB Storage class which probably isn’t effected by me desktop.

I’m getting the impression that the FP3 works under a very limited number of cases. So I need a particular brand of SD card of a particular size manufactured between certain dates for this to work seemlessly. But when it works boy does it really work.

Solution is that when I want to transfer files to the FP3, Power it off, pull the SD card, insert it into the latpop, copy across the files I want, unmount, re-insert into the FP3 and power it up.

No problems so far on my Manjaro install with a KDE Desktop.

Did you try KDE connect as an alternative?

1 Like

It works fine for me with Kubuntu 20.04 but I sometimes have two possibilities to explore the file system of my FP3. One works and not the other one. Maybe you also have this phenomenon.

I wonder if KDE Connect is not the explanation about the transfer working for us. I think there now is an equivalent for gnome but before installing all KDE I would begin with KDE Connect.

Yes, see for example mtp - Debian Wiki

Sure, if some low-level functionality isn’t working, it doesn’t matter if the desktop accesses phone storage via GVFS, kio-slave or gMTP (depending on your desktop environment). :wink:


Ah, that sounds familiar. I used to have two entries in the notification about a new mass storage device and both had an identical label. My guess was that one was for MTP and the other for PTP.

I was able to change the label for one of the entries in the removable media settings of KDE relevant for MTP transfer (it say’s kioclient5 exec mtp:udi=%i/ in its details).


Different Desktops provide different wrappers for udisks.

What are your steps, same cable on every device I assume.
You connect the phone, unlock it and select “File Transfer” in the USB options?
(the error you get in openSuse sounds like you have not unlocked your device.)

Do you find your device with:
$ lsusb

$ lsusb -v 2> /dev/null | grep -e Bus -e iInterface -e bInterfaceProtocol
you should see the interface protocol which should be MTP

Do you have tried different USB ports on Ubuntu (front/back)?

For me everything works on Arch with a random cable and SD card.
Most likely its linux USB shenanigans and not the phones fault.


I had similar frustrations back in October 2020, and eventually put it down to a problem in Android. I fixed the problem by initializing the SD card for mobile storage, as suggested by other posters.

I just tried connecting my FP3 to my Debian home computer (Debian 9 and Gnome 3.22.2).

The FP3 made an alert noise, asked me how to connect; I chose “File Transfer”.
I opened Nautilus (file system explorer) on the computer, and saw in the left hand panel a device “FP3”.
I clicked on that device, and saw two entries: a disc icon labelled “Internal shared storage” and an SD card icon labelled “Samsung SD card”.

I clicked on the SD card, was able to navigate through the directories to get to photos taken using OpenCamera… everything seems to work normally.


Thanks for all the comments, but I’m happy enough with the solution where I just power down the phone to transfer files to the SD card. Works for me


using xubuntu 20.04.1 and /e/ with Android 9 on my FP3 I have never had any issues with file transfers from the sd card.


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.