English

Transfering files between Linux computer and FP2

usb
linux
Tags: #<Tag:0x00007fefbdf557a8> #<Tag:0x00007fefbdf55668>

#1

I’ve looked at old questions on this topic and it does not appear to have gotten any easier, over the years. I’ve followed the guides for MTP transfer but that hasn’t worked at all. Then tried PTP but whilst I can see the phone and open it in the file manager I can’t create directories to copy files into. Having tried those two I move on to try it with ADB over the USB Port but no joy there either, as I’ve got no permissions. On other Android phones when I’ve started ADB a popup on the phone checks if you want to allow and trust the connected computer, click “yes” and away you go. That doesn’t appear to be the case here.

So Linux with MTP, PTP and ADB don’t work moving on the a Windows 7 VM try both MTP and PTP neither of which get mounted in the file system, perhaps that’s down to pass through of Linux, but the Windows VM does seem them being connected and installed drivers for the MTP and PTP but neither appear to mount.

This is amazingly restrictive. I would have thought that transferring music to a phone is one of the first things to do. Apparently it’s just me. Maybe I should just take the SD Card out of it and copy music directly to the SD Card.

Is this down to the stock install in the Fairphone? Is the Lineage version any better?


#2

I don’t think this is a hardware problem. Things that come to mind is permissions (so you have udev rules, or do you run adb with sudo?), Usb mode etc. This is an Android topic, not Fairphone. I’m on Los for quite some time now without problems, but you have to setup that as well


#3

I tried adb with sudo but it gave me the same permissions problem, and I’ve added the device to udev rules. I agree that these are SW issues but I assume that this version of SW is one supplied with the phone and therefore sort of fair game on this forum.

I could and I may move to LineageOS but I’m not sure that would be helping Fairphone. Maintaining the SW and supporting it is a pain but they do need it to have a phone to sell. If they washed their hands of it and told users to install LineageOS I’m not sure how many people would tackle that. I can’t think it would be a high percentage.

Fairphone and Lineage team could enter into a symbiotic relationship, one doing the SW to support the other’s SW but that was tried before with Cyanogen and sort of didn’t work out well.

Anyhow that’s all by the by and not really going to get music onto my phone :wink: I’ll keep searching for the solution. Of the five options I tried it was just my luck that none worked. I’ve a proper Windows install on a laptop in work so I’ll try that. At lease see if it can see the filesystem and allow me to create a file.


#4

What about using KDE connect?

https://extensions.gnome.org/extension/1319/gsconnect/

https://community.kde.org/KDEConnect


#5

I had the same problem with my laptop running Antergos(based on Arch Linux). For me adding my device to the udev rules, reloading those and killing and restarting the adb server did work. After that, my FP showed the permission popup when I connected it to the laptop and after clicking “yes” adb worked without a problem.
Btw. KDE Connect works great with my FP/Laptop exept for the File Transfer. That doesn’t work for some reason.