Tracking down microphone failure with Checkup app

Im having issues with my microphone, a lot of noise over my voice. If I scream people ca barely hear me.

So I wanted to test the microphone using the checkup app, but I just couldnt find it.
I followed the instructions in this thread. I first tried the Activity launcher app. but it doesnt list any checkupp activity. so I tried the terminal alternative but i got
“Error: Unknown component com.fairphone.checkup/com.fairphone.checkup.MainActivity”

Any help?

In this specific case, a simple sound recording app should suffice. Maybe one is already included in LineageOS?

Did you install the App?
And perhaps a screenshot of your terminal inputs when you get this error might help.

I hadn’t installed before. Now i did it and did the test. The primary microphone actually works, i heard myself but at very very low volume. Then the secondary microphone is just noise. I couldn’t hear myself at all the noise went through feedback and saturated the speakers.

I unmounted the bottom module, clean it with air but didn’t help.

Btw, I noticed that screen is not locking when i put my phone in the ear, is it normal?

Thanks all of you for your help!


There’s an App to calibrate the proximity sensor in LineageOS, in German it’s just named “Kalibrierung” (German for calibration), I don’t know the name in other languages, just look for it.

Else …

Yeah. I did that. During a normal call it locks the screen, but not in the checkup app tests.

Im afraid my microphone module needs replacement, but not so sure if only the bottom one.

Checkup is included in and solely intended for Fairphone OS and Fairphone Open OS.

As you could see in the other topic, you may get Checkup to work in LineageOS with some trickery, but that should already tell you something about how much you can really rely on it in LineageOS. The checks it offers may work … or not.

If your proximity sensor works for normal calls … it works :+1: .

Just for the records, the bottom module was not working well, I opened it, cleaned it, reassemble but no, it was dead.

I got a new module installed in maybe 5 minutes and there it goes! I also ordered a new case so now I feel like having a new mobile :slight_smile: proudly giving longer life to my phone.

1 Like