Touchscreen unresponsive!

I’ve had the new FP3 but a week and the screen has started playing up! Sometimes it takes a while to light up after pressing the power/wake up button, other times it won’t light up at all!
Several times now once it’s lit up it is completely unresponsive to touch.
I have removed the battery and left it out for varying lengths of time with different results - sometimes it works others it still doesn’t and tonight the screen is totally unresponsive to touch and has been green, flickering and scrambled a couple of times on startup.
No response from Support as yet - anyone here having similar issues or can advise?

I don’t have a Fairphone 3 myself, but I guess it could be a connection issue. Try to disassemble the phone, remove the display module (see here for a tutorial), clean the contacts with a wet cloth (very little water) and screw it back together.

1 Like

this might help you. Fuzzy Touch Screen or Touch Screen not working. Solved

Hi @jimisea, do you still have that problem? Here’s a thread that seems to be dealing with the same issue - FP3 Display freezes!