Touchscreen test not working

I’ve tried the “touchscreen test for aberrant behaviour” and it didn’t worked.
First of all, my Fairphone started to type weird characters and not responding to my commands.
Then I’ve tried to restart but it was impossible because it ddin’t accept the PIN code, as it kept changing the screen and “dancing”: the screen was moving all the time so that it was impossible to type whatsoever.
Then I’ve tried the “touchscreen test for aberrant behaviour” and when I reached the “factory mode” the screen started to scroll up and down and it was impossible to select the “item test”. The rest of the procedure was immpossiible to follow.
My phone is useless this way, can you help me, please?

How can it scroll down? Maybe you accidentally pressed the volume buttons?

If it wasn’t you (accidentally), it is best to contact support, where you can talk to the FP staff directly. The community won’t be able to help you, if not even the factory mode works…

It scroll down without touching the volume buttons…
It seems a pretty messy affair. I’ll wait the FP staff reply then.
Thanks for your reply.

OK, please tell us, how you got this solved, afterwards! :slight_smile:

Hi, just to report what happened: I’ve done the Hard reset didn’t solve the problem that some parts of the screen don’t work (so that I can’t type proper messages or use some apps that are on these unusable parts). The touchscreen test revealed that the left side of my screen does not work and the bottom right neither. Still waiting from a solution from FP team.

So you got the touchscreen test working? In this case I would think that you get a warranty ticket for the defunct screen. Be sure to take a photo of the touchscreen test (with green and red squares) and add it to your support ticket.